Pre-configure blade in Cat6500

Unanswered Question
May 1st, 2009

How do I configure blades in a Cat 6500 that are not installed. I am configuring a supervisor for one of my 6500's to replace an existing sup and I don't want to build a entire switch just to configure the sup. The new sup is running v12.2(18)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Collin Clark Fri, 05/01/2009 - 05:50

You can build the config in notepad, tftp to flash, then once the cards are installed, merge the file into the running config and save.

Hope that helps.

h.parsons Fri, 05/01/2009 - 06:08

Yes, that helps but I was thinking there was a way to do this but it may be in the CatOS that this is available.

nate-miller Fri, 05/01/2009 - 11:47

More of a pity you can't UN-PROVISION a blade that's been removed without reinserting the blade, adding "module clear-config", and then pulling it back out!!!

davy.timmermans Sat, 05/02/2009 - 04:51

if you remove a blade, the configuration is removed from the running-configuration, if you do a write to startup then it's also gone from startup config.

Or do you mean something else?

nate-miller Mon, 05/04/2009 - 09:25

The config is only removed if the line "module clear config" is in the config.

This is handy for removing a config when you remove a linecard, it's kind of a downer when you're just replacing a failed linecard. (Copy start -> Run would effectivly reprovision this, but you'd need to do no-shuts, I think.)

It'd be nice to have some other method of removing a ghost config from a running box. If you take a linecard out when you don't have "module clear-config" in place, that config just hangs out and there appears to be no way of removing it, short of a reboot or other shenanigans.


This Discussion