Problem with Mobile Voice Access

Unanswered Question
May 1st, 2009

I'm attempting to get MVA to work and am running into an issue. I followed the instructions posted by cesar on the IPT: Mobile Voice Access hairpinning set up 3 parts:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cc1d36f

I have a 2801 configured as a H.323 gw in UCM with a RP (8699X) using the RL/RG I've created that points to the 2801 device.

Here's my config on my 2801 that has a VWIC-1MFT-TI in Slot 1:

Current configuration : 4642 bytes

!

! No configuration change since last restart

!

<snip>

!

clock timezone CST -6

clock summer-time CDT recurring

network-clock-participate wic 1

no ip routing

no ip cef

!

<snip>

!

isdn switch-type primary-4ess

!

voice-card 0

dsp services dspfarm

!

voice service voip

allow-connections h323 to h323

!

voice class h323 1

h225 timeout tcp establish 3

no call preserve

!

application

service MVA http://[UCM IP]:8080/ccmivr/pages/IVRMainpage.vxml

!

controller T1 0/1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

interface FastEthernet0/0

ip address 10.128.2.250 255.255.255.0

ip pim sparse-dense-mode

no ip route-cache

speed auto

full-duplex

no cdp enable

no mop enabled

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.128.2.250

!

interface Serial0/1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-4ess

isdn incoming-voice voice

no cdp enable

!

<snip>

!

voice-port 0/1/0:23

!

sccp local FastEthernet0/0

sccp ccm [UCM IP] identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP_MVA

!

dspfarm profile 1 mtp

codec g711ulaw

codec pass-through

maximum sessions hardware 5

associate application SCCP

!

dial-peer voice 86996 pots

service mva

incoming called-number 86996

direct-inward-dial

!

dial-peer voice 869960 voip

service mva

destination-pattern 86996

session target ipv4:[UCM IP]

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 101 voip

preference 1

service mva

destination-pattern 86996

voice-class h323 1

session target ipv4:[UCM IP]

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

line vty 5 15

access-class 1 in

codec g711ulaw

no vad

!

<snip>

!

end

I should note that we have an Ericsson MD110 in addition to our UCM. We pass all outgoing calls from both switches through the MD. We have external destinations created on the MD for our voip DNs to route the calls to the UCM. For example, I have an external dest created for 86996 in the MD where an incoming call should come into the MD (xxx-xx8-6996), it strips off the first 5 digits and passes the remaining five onto the UCM route (Digital Access PRI) we have setup.

I've tried to make a call to MVA and it pretty much just sits there and appears connected, but if I do a "sh voice call status" - nothing is listed. Please help...I know I'm just overlooking some (critical) step...Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion