IOS DHCP client: not working via helper-address, working directly

Unanswered Question
May 1st, 2009
User Badges:

Hi everyone,


I have a problem with IOS DHCP client (this is an 800 series, but I've seen this issue before on a different platform).


Here's the situation:


- Server: ISC DHCPD (FreeBSD), vlan A

- Client: IOS 12.4(22)T1, VLAN B

- Topology:

client --> distribution switch == > core switch <== rack switch <-- server

- Core switch: SVIs for all VLANs, helper address set to the dhcp server, also forwarding udp bootpc/bootps

- DHCP snooping enabled on all switches on the way from client to server,

- Inserting option 82.


Note: disabling dhcp snooping and / or option 82 doesn't help.


Now, when I put the 800 series on the same VLAN as the DHCP server, I get the lease without any problems. But as soon as I move the 800 series onto any other VLAN, I can't get a DHCP lease. I can see it sending DHCPDISCOVER to the server and the server replies with a DHCPOFFER, but I see no DHCPACK.


There are more than 500 nodes on the network and none of them are experiencing any DHCP problems. Only Cisco devices have issues (that 800 series, but also saw this with other models).


Does this issue sound familiar to anyone? Could this actually be the server's fault? For whatever reason the server doesn't send DHCPACK - but only when not on the same VLAN as the client.


Kind regards,

Wojciech







  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Fri, 05/01/2009 - 09:57
User Badges:
  • Blue, 1500 points or more

Hi, Wojo:


The server wont respond with a DHCPACK until it gets a DHCP REQUEST from the client. Is the router sending out a DHCP request in response to the offer?


Victor

wojciechowczarek Fri, 05/01/2009 - 10:14
User Badges:

Hi Victor,


Yes, sorry, I didn't include that in my first post - DHCP server sees no DHCPREQUEST from the client if they are on different vlans.


Thanks,

Wojciech

wojciechowczarek Fri, 05/01/2009 - 10:36
User Badges:

Hi,


I tried client-id before with the interface being the dhcp client, no luck. Also, the thing is that the client doesn't even send DHCPREQUEST. I set up an RSPAN session and I have the port monitored, but I just don't see it sending the request. I can't continue this discussion today but I'll post some packet dumps later. Maybe I'm missing something obvious. But like I said, any random DHCP client (laptop, etc.) works fine on that port.


I also tried ip dhcp limited-broadcast-address

and ip dhcp-client broadcast-flag.


cheers,

Wojciech

wojciechowczarek Fri, 05/01/2009 - 11:13
User Badges:

Hi everyone and thanks for your help.


Problem solved:


no ip dhcp-client broadcast-flag


- worked like a charm. I can now get a lease on any VLAN.


Many thanks,

Wojciech

Actions

This Discussion