×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

RTP header compression Over Bridged interface

Unanswered Question
May 2nd, 2009
User Badges:

Is it possible?


I want to achieve Qos and RTP compression

I have Point-Point conncetiond

One side is MetroEthernet - VLAN

One side is G.SHDSL - ATM - BVI


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Sat, 05/02/2009 - 09:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

No, you can have RTP compression only on serial point-to-point normally routed links.

recep.sefer Sat, 05/02/2009 - 10:12
User Badges:

Thank you,

Do you have a example config for qos

One side is MetroEthernet

One side is Atm and BVI


paolo bevilacqua Sat, 05/02/2009 - 10:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Configure route-bridged encapsultation under a p.t.p. subif for atm.

Nothing else should be necessary.

recep.sefer Sat, 05/02/2009 - 11:17
User Badges:

For Metro site no problem

But For G.SHDSL I cannot apply service-policy giving th following



Router(config-if-atm-vc)#interface BVI1

Router(config-if)# bandwidth 256

Router(config-if)# ip address 1.1.2.2 255.255.255.252

Router(config-if)#service-policy output WAN-EDGE

Class Based Weighted Fair Queueing not supported on interface BVI1

Router(config-if)#





Here is my G.SHDSL Config;


class-map match-any Call-Signaling

match ip dscp cs3

match ip dscp af31

class-map match-all Voice

match ip dscp ef

!

!

policy-map WAN-EDGE

class Voice

priority percent 33

class Call-Signaling

bandwidth percent 5

class class-default

fair-queue



bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0 0/35

encapsulation aal5snap

!

bridge-group 1

!



bridge 1 protocol ieee

bridge 1 route ip




interface BVI1

bandwidth 256

ip address 1.1.2.2 255.255.255.252




paolo bevilacqua Sat, 05/02/2009 - 11:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Do not use BVI. Use "atm route-bridged" under subif as recommended above.

recep.sefer Sat, 05/02/2009 - 20:45
User Badges:

Thank you,


You said RTP is not possible;

But router doesnt out any error?

Here is my all config



Router#sh running-config

Building configuration...


Current configuration : 1492 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

!

!

archive

log config

hidekeys

!

!

controller DSL 0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

!

!

class-map match-any Call-Signaling

match ip dscp cs3

match ip dscp af31

class-map match-all Voice

match ip dscp ef

!

!

policy-map WAN-EDGE

class Voice

priority percent 33

compress header ip rtp

class Call-Signaling

bandwidth percent 5

class class-default

fair-queue

!

!

bridge irb

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

bandwidth 256

ip address 1.1.2.2 255.255.255.252

atm route-bridged ip

pvc 0 0/35

encapsulation aal5snap

service-policy output WAN-EDGE

!

bridge-group 1

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address dhcp

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end


paolo bevilacqua Sun, 05/03/2009 - 08:25
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Check with show commands, no compression is occurring, as one end of media is Ethernet.


It might be possible with PPPoE, but I haven't personally ever seen that.


Please remember to rate useful posts with the scrollbox below.

recep.sefer Wed, 05/06/2009 - 12:05
User Badges:

For the Metro Ethernet site

I have Catalyst 3560

I have point-point links (128k-512k)

What do you recommend?


Thanks

paolo bevilacqua Wed, 05/06/2009 - 12:23
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Install normally first and observe. Once working, some testing can be made. But you will need a true router on both sides.

Actions

This Discussion