Cisco 1841 Configuration Help

Unanswered Question

I am very very new to this technology so please bear me out with the simple questions.

I have a network all ready set up which is SBS 2003 and a 2 nic setup, an ADSL Netgear modem/router/firewall.

I now need to have a link to another company in order to access their systems.

I have installed a 64k diginet line at my site and at the other site.

I have purchased 2 x 1841 Ciso routers one for me one for the other site.

I now need to setup and connect the two together and thats where it becomes grey and blurry.

The 1841 has a serial port connected to the NTU.

The other company has given me their ip address that my router on their side will connect to and told me

to setup the router first and then ship it down to them.

So I need to know what needs to be done this side from IP addressing and Ethernet and serial setup.

The router also needs to NAT.

This is what info I have so far, I need to know what type of IP address range and subnets I should be using

My Company

**********

Ethernet Switch Netgear Cisco

192.168.16.x 172.168.16.x Eth0 xxx.xxx.xxx

Ser0 xxx.xxx.xxx

External Company

****************

Ethernet Switch Cisco

192.168.17.x Eth0 xxx.xxx.xxx

Ser0 xxx.xxx.xxx

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 05/02/2009 - 14:42

Hello Chris,

the routers need a common subnet to be able to talk on the serial link.

At the same time their LAN interface needs to be on site ip subnet.

For example:

192.168.254.0/24 can be a good choice.

R1

ip routing

int ser0/0

ip address 192.168.254.1 255.255.255.0

enc ppp

no shut

int fas0/0

ip address 192.168.16.2 255.255.255.0

no shut

ip route 192.168.17.0 255.255.255.0 ser0/0.

you shouldn't need nat when talking to the other company until the ip subnets used by the two companies are different private ip addresses.

in case you need NAT the following changes are needed:

int f0/0

ip nat inside

int ser0/0

ip nat outside

ip nat inside source list 11 int ser0/0 overload

this is fine if there are not servers on your side.

if there are servers on your side that need to be accessed from other company you may need some addresses to perform static NAT entries

something like:

ip nat source inside static ip1 ip2

Hope to help

Giuseppe

Actions

This Discussion