NAM Upgrade Failure

Unanswered Question
May 2nd, 2009
User Badges:

Hi,I've tried to upgrade the NAM Application software from version 3.61b (Apps_Image)with 2.1.3 (Maintenace_Image) to version 4.0(Apps_Image)with 2.1.5(Maintenace_Image)after has succefully installed a new pair of 1GB RAM(Total 2GB now).I followed the NAM upgrade documentation which from Cisco.As the NAM running the Apps_Image,so i started to upgrade the Maintenance_Image to 2.1.5 and successful,but when the NAM running on Maintenace_Image and tried to upgrade the Apps, it fail with the error message as below and the upgrade halt:


%Application installation disk corrupted%


I don't think the harddisk is corrupted as i stil can running the older version of NAM Apps since the newer version upgrade failure.


Looking for help.

Many Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Sat, 05/02/2009 - 09:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This error has never shown up before in any other service requests. I also don't find it in NAM code, so I'm not exactly sure where it's coming from. It could point to a problem with your downloaded NAM 4.0 image. You should verify the checksum of your download against the one on Cisco.com. In this case, that is:


c6svc-nam.4-0-1.bin.gz : 247d76a9ab74ef16223dbd09fb39feb1

orochi_yagami Sun, 05/03/2009 - 06:03
User Badges:

Hi,i posted a log during the upgrade process.


[email protected]#upgrade ftp://xxxadmin@155.69.65.47/c6svc-nam.4-0-1.bin.gz

Downloading the image. This may take several minutes...

Password for [email protected]:

ftp://xxxadmin@155.69.65.47/c6svc-nam.4-0-1.bin.gz (84269K)

/tmp/upgrade.gz [########################] 84269K | 7674.18K/s

86291741 bytes transferred in 10.98 sec (7674.11k/sec)


Upgrade file ftp://xxxadmin@155.69.65.47/c6svc-nam.4-0-1.bin.gz is downloaded.

Upgrading will wipe out the contents on the storage media.

Do you want to proceed installing it [y|N]: y


Proceeding with upgrade. Please do not interrupt.

If the upgrade is interrupted or fails, boot into

Maintenance image again and restart upgrade.


Creating NAM application image file...


The application image hard disk is corrupt.

ERROR: Application installation has failed. View the upgrade log for details.


[email protected]#show version


Maintenance image version: 2.1(5)

mp.2-1-5.bin : Tue Nov 11 20:29:43 GMT 2008 : [email protected]


Line Card Number :WS-SVC-NAM-1

Number of Pentium-class Processors : 2

BIOS Vendor: Phoenix Technologies Ltd.

BIOS Version: 4.0-Rel 6.0.9

Total available memory: 2020 MB

Size of compact flash: 122 MB

Size of hard disk: 38154 MB


Appreciate your help.

regards

Joe Clarke Sun, 05/03/2009 - 09:41
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This problem may be solved by reformatting the harddrive during installation. Try running:


upgrade ftp://xxxadmin@155.69.65.47/c6svc-nam.4-0-1.bin.gz --install


If that does not work, you will need to get an RMA replacement for this NAM module by contacting TAC.

orochi_yagami Mon, 05/04/2009 - 06:07
User Badges:

Hi,just a quick check, if i perform the upgrade command as you mentioned above by reformatting the harddrive during upgrade, can i import back the previous save config files without additional works?

As i read the upgrade guide it indicated that the --install command will remove the partition that created previously. If this's the case, how we re-create back the partition?


Thanks in advance.

Joe Clarke Mon, 05/04/2009 - 08:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You cannot. The data will be lost.

orochi_yagami Tue, 05/05/2009 - 07:04
User Badges:

Just to ensure another before i proceed the re-installation,can i upgrade the existing 3.61(b)NAM to version 4 without upgrading the current maintenance image which is version 2.1.3? I have another unit of NAM,so would like to try out a different upgrade approach.As per Cisco NAM upgrade doc,as long the maintenance image is version 2.1(1) and above.


regards,

Joe Clarke Tue, 05/05/2009 - 10:37
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes, this should work. Our NAM was upgraded to 4.0 on maintenance image 2.1(2).

sumitsept3 Tue, 05/05/2009 - 18:29
User Badges:

i too have received the same error while i was trying to upgrade the name...later i tried with adding --install to my upgrade command and it solved the issue...



upgrade ftp://xxxadmin@155.69.65.47/c6svc-nam.4-0-1.bin.gz --install




orochi_yagami Tue, 05/12/2009 - 17:36
User Badges:

Hi,I managed to upgrade the module that given me an upgrade issue to the version 4 apps by reverting back the maintenance image from 2.1.5 to 2.1.3. And i did find out from Cisco Doc stated that 2.1.5 is only applicable for NAM-SVC-250-1 series.


HTH

alexc2010 Mon, 08/09/2010 - 04:13
User Badges:

Hi,

I am facing the same issue. Could someone help me with the procedure about reverting back the maintenance image from 2.1.5 to 2.1.3 ?

Thanks in advance.

REgards

Alex

anas.masoud Tue, 08/10/2010 - 05:59
User Badges:

Hi,


Me too I have the same issue and I could not find any documentation that explain how to revert back the maintenance image from 2.1(5) to 2.1(3) so, please if you have any information share it with us.



Regards,

anas.masoud Wed, 08/11/2010 - 02:48
User Badges:

Hello,


Just I got this reply from Cisco engineer it might be useful. I did not try it yet but I will do soon when I go to the customer site:


The downgrade procedure from 2.1.5 to 2.1.3 is the same as the upgrade, so, kindly follow the steps:

(1) boot the NAM to application image. (NAM usually is running in

application image, which you use to monitor network traffic.)

    In IOS switch, you do "hw-module module reset hdd:1"

    In CatOS switch, you do "reset hdd:1"

(2) session to NAM, do "upgrade ", then follow the prompt.

Here is the complete procedure: http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/4.1/switch/configuration/guide/advcfg_ps5401_TSD_Products_Module_Installation_Guide_Chapter.html#wp1035678



Best Regards,

Actions

This Discussion