problem with rip authentication

Answered Question
May 2nd, 2009

I am using frame-relay over ppp with rip, when i put the authentication both the routers lost rip learned routes(after 15-30 min) and after removing the authentication routes came back.please suggess me the solution for the same.

for refrence please see the attach conf.

Attachment: 
I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 8 months ago

Hello Claudiu,

the OP is doing PPP over Frame-Relay (not the opposite as he stated) so FR cannot see the IP multicast or brodacast packets that are carried inside PPP frames.

the strange part is that the problem happens only when authentication is used and after 15-30 minutes

I wonder if the routers have their clock in sync but I see that no lifetime is configured in the key chain so it looks like unrelated to clock issues.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
c.captari Sun, 05/03/2009 - 16:07

Please note that frame-relay is non-broadcast.

Try on each end

R1

interface Serial0/0/1

frame map ip 172.16.4.2 412 broadcast

R2

interface Serial0/0/1

frame map ip 172.16.4.1 512 broadcast

Correct Answer
Giuseppe Larosa Sun, 05/03/2009 - 21:30

Hello Claudiu,

the OP is doing PPP over Frame-Relay (not the opposite as he stated) so FR cannot see the IP multicast or brodacast packets that are carried inside PPP frames.

the strange part is that the problem happens only when authentication is used and after 15-30 minutes

I wonder if the routers have their clock in sync but I see that no lifetime is configured in the key chain so it looks like unrelated to clock issues.

Hope to help

Giuseppe

tyagi.vineet Wed, 05/06/2009 - 07:47

Thank yoy very much for your reply, but issue is resolveed now,after upgrading the IOS.

Actions

This Discussion