UCCX 7.0 Agents bouncing off & on Supervisor Desktop & Chat Window

Unanswered Question
May 4th, 2009

We have a new install of UCCX 7.0 and Agent Desktop 6.6. There are a couple of agents that pop on & off of the supervisor desktop. Windows Firewall is off and all ports are open to the UCCX server. This also happens with the agent Chat windows. The chat log shows "network commincation error sending message to application the application will be logged out". All other apps are working OK. The agent is still able to receive calls.

Has anyone else seen this issue?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

I've seen this issue quite a few times, and it's always an issue with the firewall on the agent's PC.

Make sure there is an exception for agent.exe. If one exists, try turning the firewall off completely.

Edit: You may have tried my above suggestion. It's not clear in your original post whether you're referring to the firewall on the UCCX server, or on the agent's PC.

monica.bryant Mon, 05/04/2009 - 07:42

The Windows Firewall is off on the agent's PC and the anti-virus was disabled briefly to test if that was the issue. I ran netstat -a and I see that listening on port 59020 but also a lot of waits for the same port. The agent log shows that the program is reconnecting automatically every few seconds.

Steven Griffin Mon, 05/04/2009 - 08:53

Monica,

It is a network communications issue.

Check the following:

Are there firewalls between the CAD and UCCX server?

If the agents are remote, is the VPN system configured correctly? Check the MTU as well.

What is the latency between CAD and the UCCX server. If it is too high the same issue can also manifest itself.

Disable all security software on both the UCCX server and the CAD client PC. This includes the Windows firewall, anti-virus/anti-malware, and the CSA.

micandre Fri, 05/08/2009 - 04:14

Hi Monica,

Did you fix this issue? I'm having a similar problem.

To test if it was a problem with the pc or the cad I logged on to a different pc with the same user account and it failed. The new pc works with other CAD accounts.

Regards, Michael

monica.bryant Fri, 05/08/2009 - 05:26

It seems resolved on 1 of the 2 agents. We added the agent.exe and supervisor.exe to the exclusions on the Symantec Anti-Virus. We are still testing to see why 1 agent still has the problem. Does the same user consistently have problems on your system?

micandre Mon, 05/11/2009 - 01:58

Many thanks for responding. The issue turned out to be the customer's implementation on their Citrix environment. All working now.

Michael Murphy Tue, 02/09/2010 - 14:10

Hi Monica,

Did you ever find the root cause of this issue?

I have seeing this happen for several users in our environment. I was able to correct it for several users.

One user is still seeing this issue however.  Error logs on the server show the error happening in 1 minute intervals (FCCS3008) "network connection error".  The agent's chat window refreshes and the Agent "bounces" in and out of Supervisor Desktop views.

Thanks,

Mike

monica.bryant Tue, 02/09/2010 - 14:55

Ports 59000-59030 should be open between the client and the Call Center
server. We found that the Anti-Virus was causing the problem.  A change in the AV to allow these ports resolved the issue.

Michael Murphy Tue, 02/09/2010 - 15:07

So the actual Anti-Virus software was blocking ports?  We are running Symantec Endpoint Protection v11.x.

Just curious, did you change general policy settings on your AV server and have it pushed out to clients, or did you have to make changes to the AV software at the desktop level?

Thanks for the quick response!

monica.bryant Tue, 02/09/2010 - 15:42

We also had Symantec.  We made the change in the AV admin and pushed the policy out to the end users.  That resolved all the issues. 

Michael Murphy Tue, 02/09/2010 - 15:47

Do you happen to remember if this was specific to the "firewall" feature of Symantec, or are there settings in the Antivirus scanning settings as well?

FYI:

- the Symantec Firewall feature is globally disabled

- I have advised to add exclusions for "agent.exe" and "supervisor.exe"

Let me know if you have any other suggestions.  Thanks much!!

-Mike

Ian Brendel Fri, 03/28/2014 - 08:56

I had an issue where this was related to bad file permissions on the computer in which the Agent was installed.  Once I removed the agent.exe via add/remove programs and then manually deleted the c:\program files\Cisco folder and then reinstalled the software was I able to resolve the issue.  I blame the computer it was installed on but the CAD software can be finnicky to say the least.

Actions

This Discussion