CCM 6.1 testing new 7961 software

Unanswered Question
May 4th, 2009

I downloaded and ran the software upgrade/install/upgrade service for cmterm-7941_7961-sccp.8-4-4.cop.sgn

From reading, for this software to take effect you need to reboot the cluster.

In 4.x you could run the devicepack install and then type in the load name to test the new software before you did a cluster reboot. I tried to put in cmterm-7941_7961-sccp.8-4-4 as the load name but it did not work and i do not see the any cmterm-7491_7961 in the manage tftp files area.

Is there a similar method in 6.1 to test new software without doing a cluster reload?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ecornwell Thu, 06/18/2009 - 12:59

Did you ever get this figured out? I need to load some older phone software in our 7.x server and I don't want it to override the default.

tkuzma1022 Fri, 06/19/2009 - 08:24

Yes after a call to TAC. I imported correctly but, when searching though the software upgrade/tftp file manager I was useing cmterm and really its SCCP and you need to be exact on the case since this is now Linux. Also note that even though the name listed in the release notes is cmterm_7960_7961 that is not the real name its SCCP_xxx just like before.

I put the correct load name on the phone device and I was able to test the new code.

tkuzma1022 Thu, 07/16/2009 - 08:41

The way it worked for me looking for SCCP load files was to goto the OS Admin page, Software/Upgrades, TFTP File Management, change the search to contains then SCCP (all caps*) in the search field and you will see all the load files ex. SCCP41.8-4-2S.loads then just copy that file name in the firmware load fild of the device reboot the device and it will load the new code.

* If you don't use the exact case you will not find the file becuse of the way it searches. Linux go figure.

I have been using this method and it worked great for me testing new code. I hope this helps you.

TomK

ecornwell Thu, 07/16/2009 - 09:14

I wish we had the ability to load the code in but not make it active. There are many times I would load new code and test it on a few phones then activate it during a window. It would be nice if we could upload the code without having to go back to change the default load to what it was before the upload.

tkuzma1022 Thu, 07/16/2009 - 10:50

Ahh, sorry, I forgot you had to stop/start the tftp service.

FYI, TAC wanted me to reboot the cluster to but, just restarting the TFTP service does the trick and does not place the new code in the default list for the rest of the devices like a cluster reboot would do.

Actions

This Discussion