DHCP issue

Unanswered Question
May 4th, 2009

I have a c881 with an interface configured to grab DHCP from a cable modem. However I keep getting

"Timed out Selecting state%Unknown DHCP problem.. No allocation possible"

I've rebooted the cable modem, I've done all I can think of.

interface Vlan2

description Backup to cable modem

ip vrf forwarding isp2

ip address dhcp

ip nat outside

ip inspect XXXFW_BKP out

ip virtual-reassembly

end

This is the interfaces configuration and this works on all my other routers.

Any help would be great.

Also there are no access-lists that would stop this.

Thanks,

Brent

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Laurent Aubert Mon, 05/04/2009 - 18:45

Hi Brent,

You can troubleshoot DHCP process with debug dhcp commands.

I would also suggest you during the troubleshooting session to keep your configuration as simple as possible like:

interface Vlan2

description Backup to cable modem

ip address dhcp

!

just to be sure there is nothing else that could prevent DHCP from working.

You can also changing the MAC address of the interface to see it it helps.

HTH

Laurent.

Brent Rockburn Tue, 05/05/2009 - 06:44

this is what I'm getting. It seems to time out I'm just not sure why.

May 5 14:41:37.204: Hostname: XXXXXXXXXO1

May 5 14:41:37.204: DHCP: SDiscover: sending 301 byte length DHCP packet

May 5 14:41:37.204: DHCP: SDiscover 301 bytes

May 5 14:41:37.204: B'cast on Vlan2 interface from 0.0.0.0

May 5 14:41:41.204: DHCP: SDiscover attempt # 3 for entry:

May 5 14:41:41.204: Temp IP addr: 0.0.0.0 for peer on Interface: Vlan2

May 5 14:41:41.204: Temp sub net mask: 0.0.0.0

May 5 14:41:41.204: DHCP Lease server: 0.0.0.0, state: 3 Selecting

May 5 14:41:41.204: DHCP transaction id: 1AC4

May 5 14:41:41.204: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

May 5 14:41:41.204: Next timer fires after: 00:00:04

May 5 14:41:41.204: Retry count: 3 Client-ID: cisco-0021.d87c.8e0c-Vl2

May 5 14:41:41.204: Client-ID hex dump: 636973636F2D303032312E643837632E

May 5 14:41:41.204: 386530632D566C32

May 5 14:41:41.204: Hostname: XXXXXXXXXO1

May 5 14:41:41.204: DHCP: SDiscover: sending 301 byte length DHCP packet

May 5 14:41:41.204: DHCP: SDiscover 301 bytes

May 5 14:41:41.204: B'cast on Vlan2 interface from 0.0.0.0

May 5 14:41:44.553: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x99E007C

May 5 14:41:44.569: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x99E007C

May 5 14:41:45.205: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible

May 5 14:41:54.605: DHCP: Waiting for 55 seconds on interface Vlan2

May 5 14:42:12.125: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x18E786B5

May 5 14:42:13.257: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x18E786B5

May 5 14:42:16.505: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x95668881

May 5 14:42:16.517: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x95668881

michael.perry Thu, 07/22/2010 - 08:31

Greetings, I searched the forum with a similar problem and after reviewing 2 pages of similar posts with no resolution I finally set up my scenario in a lab to find the answer. Here is what I found.

When you have DHCP lease failure on an interface (from an ISP in my scenario) you will see the following debug outputs.

Router#debug dhcp detail

DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
011692: Jul 22 11:13:49: DHCP: SDiscover: sending 313 byte length DHCP packet
011693: Jul 22 11:13:49: DHCP: SDiscover 313 bytes
011694: Jul 22 11:13:49:             B'cast on FastEthernet0/1 interface from 0.0.0.0
011695: Jul 22 11:13:53: DHCP: SDiscover attempt # 3 for entry:
011696: Jul 22 11:13:53: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet0/1
011697: Jul 22 11:13:53: Temp  sub net mask: 0.0.0.0
011698: Jul 22 11:13:53:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
011699: Jul 22 11:13:53:    DHCP transaction id: 1BC6
011700: Jul 22 11:13:53:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
011701: Jul 22 11:13:53:    Next timer fires after: 00:00:04
011702: Jul 22 11:13:53:    Retry count: 3   Client-ID: cisco-0017.59e2.e90f-Fa0/1
011703: Jul 22 11:13:53:    Client-ID hex dump: 636973636F2D303031372E353965322E
011704: Jul 22 11:13:53:                        653930662D4661302F31
011705: Jul 22 11:13:53:    Hostname: NB-Side-01
011706: Jul 22 11:13:53: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
011707: Jul 22 11:13:53: DHCP: SDiscover: sending 313 byte length DHCP packet
011708: Jul 22 11:13:53: DHCP: SDiscover 313 bytes
011709: Jul 22 11:13:53:             B'cast on FastEthernet0/1 interface from 0.0.0.0
011710: Jul 22 11:13:57: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible

Notice that the UDP discovery packet has been sent, the State =  3 "Selecting", and the final line "Timed out selecting state". What's happening is a DHCP Server is not responding probably due to a connectivity issue. "Selecting" to me is not the correct verb for what is happening here, how about "waiting for reply", or "No Response"? The causes can be:

1) A Layer 1 connectivity problem: Incorrect speed, duplex, cabling.

2) An ACL is blocking DHCP from the ISP. To fix it ASAP you need the following in an ACL

     ip access-list extended 101

     permit udp any any eq bootpc

     Then on your ISP facing Int

     Int f0/1

     ip access-group 101 in

3) Some weirdness on your ISP side. I saw posts here talking about they had to register the hostname or client-id with specific providers. You may want to check with them.

My ISP AT&T using a NetBridge device containing a USB cell modem attached to a FastEthernet port, the weirdness is sometimes it takes 3 minutes and 30 seconds to obtain an IP, sometimes it comes back within a few seconds. So weirdness exists and is likely specific to your hardward and ISP.

Other useful commands in troubleshooting:

sho dhcp lease

release dhcp f0/1

renew dhcp f0/1

The bottom line is if debugging shows State =  3 "Selecting", and "Timed out selecting state". You are not connecting or the DHCP Server is not responding. Enjoy!

Mike

imperialsupplies Wed, 12/08/2010 - 02:40

Thank you very much for the detailed post.

#2 solved my problem. I had an ACL tied to the interface and I didn't allow bootp traffic;

ip access-list extended allow-vpn
permit udp any any eq bootpc

Thanks!

Mike

Actions

This Discussion