Cisco 1410 Wireless bridge trunking

Unanswered Question
May 5th, 2009
User Badges:

I have a point-to-multipoint wireless bridge setup using Cisco 1400 series bridges (Cisco 1410)


I'm trying to transport VLANs across the bridges and I have (I think) configured them as per the documentation.


At either end of the 1410s the Cisco switch ports are set up as trunk ports.


Below is the config from one of the non-root bridges



!

hostname BR02

!

!

dot11 vlan-name land-corporate vlan 520

dot11 vlan-name corp-WiFi vlan 521

dot11 vlan-name dcs vlan 503

dot11 vlan-name guest-WiFi vlan 522

!

dot11 ssid *snip*

vlan 500

authentication open

infrastructure-ssid

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 500 key 1 size 128bit 7 <snip> transmit-key

encryption vlan 500 mode wep mandatory

!

ssid *snip*

!

station-role non-root bridge

rts threshold 4000

concatenation

infrastructure-client

!

interface Dot11Radio0.500

encapsulation dot1Q 500 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.503

encapsulation dot1Q 503

no ip route-cache

bridge-group 252

bridge-group 252 spanning-disabled

!

interface Dot11Radio0.520

encapsulation dot1Q 520

no ip route-cache

bridge-group 255

bridge-group 255 spanning-disabled

!

interface Dot11Radio0.521

encapsulation dot1Q 521

no ip route-cache

bridge-group 254

bridge-group 254 spanning-disabled

!

interface Dot11Radio0.522

encapsulation dot1Q 522

no ip route-cache

bridge-group 253

bridge-group 253 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

!

interface FastEthernet0.500

encapsulation dot1Q 500 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0.503

encapsulation dot1Q 503

no ip route-cache

bridge-group 252

bridge-group 252 spanning-disabled

!

interface FastEthernet0.520

encapsulation dot1Q 520

no ip route-cache

bridge-group 255

bridge-group 255 spanning-disabled

!

interface FastEthernet0.521

encapsulation dot1Q 521

no ip route-cache

bridge-group 254

bridge-group 254 spanning-disabled

!

interface FastEthernet0.522

encapsulation dot1Q 522

no ip route-cache

bridge-group 253

bridge-group 253 spanning-disabled

!

interface BVI1

ip address 10.10.150.16 255.255.255.0

no ip route-cache

!

ip default-gateway 10.10.150.1

!

bridge 1 route ip

!


When the switch ports are in trunk mode, the system falls over and the switch ports seem to shut down (very remote site so can't confirm at this stage)


When the switch ports are setup as an access port on the native VLAN (500) the bridges work but only for the native VLAN.


Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gamccall Tue, 05/05/2009 - 07:38
User Badges:
  • Silver, 250 points or more

Can you post the switchport trunking config you're using? Make sure you're setting "switchport trunk encap dot1q" and "switchport trunk native vlan 500".


Also note that VTP traffic will not cross the wireless link unless you use vlan 1 as the native vlan.

theroofisonfire Tue, 05/05/2009 - 15:48
User Badges:

Here is an example of the switch config I was testing:


If I use a config like Gi1/0/11 the bridge works for VLAN 500 only


If I use a config like Gi1/0/12 the bridges fail


interface GigabitEthernet1/0/11

description SWITCHPORT

power inline never

switchport access vlan 500

speed 100

duplex full

spanning-tree portfast

!

interface GigabitEthernet1/0/12

description TRUNKPORT

power inline never

switchport trunk encapsulation dot1q

switchport trunk native vlan 500

switchport mode trunk

spanning-tree portfast


Thanks


Ian

Roman Rodichev Tue, 05/05/2009 - 19:56
User Badges:
  • Gold, 750 points or more

Try configuring "switchport trunk allowed vlan 500,503,520,521,522" on switch ports

theroofisonfire Tue, 05/05/2009 - 21:03
User Badges:

Thanks for that, I'll try it when I can get my hands on the test setup again.


Does this mean that the Cisco 1400 documentation that states you should setup a trunk port is slightly misleading?

Roman Rodichev Tue, 05/05/2009 - 21:13
User Badges:
  • Gold, 750 points or more

"switchport trunk allowed" goes together with "switchport mode trunk"

theroofisonfire Tue, 05/05/2009 - 23:54
User Badges:

Ok, I misinterpreted that got appllied to an access port.


So my config would look something like:


interface GigabitEthernet1/0/12

description TRUNKPORT

power inline never

switchport trunk encapsulation dot1q

switchport trunk native vlan 500

switchport mode trunk

spanning-tree portfast

switchport trunk allowed vlan 500,503,520,521,522




I thought that all VLANs were passed by default unless specific ones were allowed. I'll give it a go though....

Roman Rodichev Wed, 05/06/2009 - 11:04
User Badges:
  • Gold, 750 points or more

The reason I suggested that is because I ran into the same issue just last week, and I vaguely remember fixing it with that command. I could be wrong, but if it doesn't work for you, I'll try to remember what else I did.


Are you basically seeing the switch taking the port into error disabled mode or SPT blocking? Do you have any vlans other than 500,503,520,521,522 configured on either switch?

theroofisonfire Wed, 05/06/2009 - 17:37
User Badges:

Not sure what happens to the switch as it's in middle of outback Australia (don't ask!!) and I didn't have time to diagnose it properly when onsite. The end switch has been temporarily deployed elsewhere so I can't get on to test it for the moment.


However the whole bridge network did go offline when I tried to setup the trunks, so there is a good chance there was some blocking going on.


Originally I thought I'd crashed the 1410 but then realised it hadn't rebooted and that the switch port had gone "off line".


I'll post an update when I get the switch back and can test.....


Thanks again.


Ian

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode