TEHO/IPIPGW configuration assistance

Unanswered Question
May 5th, 2009

I'm testing some TEHO configs in lab (for redundancy/disaster recovery, not really for toll-bypass). I have 2 2811's on the same network segment, each with a single POTS. I configured an h.323 gateway to a ccm 4.1 cluster for the sole purpose of placing test calls and testing inbound POTS delivery.

The purpose of my testing is to pass a call to router1 with 2 dial-peers - pref 1 routes to router2, pref 2 routes out the POTS on router1. I have the same configs in place on router2. I haven't gotten around to adding RSVP configs because I'm not getting RTP on all call legs.

From a phone registered to ccm, I place a test call to router1. The pref 1 dial-peer routes the call to router2. Router1 shows 2 active call legs - both h.323 (ccm to gateway & gateway to gateway). Router2 shows 2 active call legs - 1 telephony and 1 h.323 (router1 to router2 & POTS). The call rings to a 2nd test phone via the PSTN. I answer, and get no RTP either way and the call disconnects after 7-8secs every time.

I've attached the configs for both routers. Both are running c2800nm-adventerprisek9_ivs-mz.124-24.T.bin.

Any assistance will be greatly appreciated.

thanks,

Will

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Nicholas Matthews Wed, 05/06/2009 - 07:41

If your RTP is failing you probably have a codec negotiation issues.

Also, some CUBE guidelines:

SIP-H323:

voice service voip

h323

emptycapability

SIP-SIP

voice service voip

sip

midcall-signaling passthru

H323-H323

voice service voip

h323

h225 connect-passthru

hth,

nick

will.alvord Wed, 05/06/2009 - 08:48

I've tried adding the h225 connect-passthru statement to both routers but it's still the same -- no audio and the call disconnects 7-8 secs after answering it.

I can dial either of the 2 POTS (1 to each router) and ring my desk phone with 2 way audio. Right now the 2 dial-peers are setup as pref 1 - ipipgw, pref 2 - pstn. If I flip the preferences (cucm phone - isr - pots), I get 2 way audio.

It's only when I'm routing from cucm - isr 1 - isr 2 - pots (or vice versa) that I get no audio and the call disconnects.

I've only got g711ulaw in the voice class codec ref'd by all voip dial-peers. I found a Cisco page (can't find it now though) which specifically covered 1/no way audio issues, but didn't help me.

I'm not sure where to go from here, what debugs to run, etc.

A debug voice rtp shows this though which I'm sure is a problem:

*May 6 16:36:36.389: voip_rtp_create_session: callID=41, dstCallID=42 laddr=10.255.111.3, lport=17464,raddr=0.0.0.0, rport=0, type=3, sig_tos=3, ip_tos=5

...

...

*May 6 16:36:46.449: voip_rtcp_stop_session: ERROR - Dest IP Addr=0, no RTCP pkt sent

The remote address is all zeroes. Not sure how to fix it though. Any advice is welcome.

thanks,

Will

Nicholas Matthews Wed, 05/06/2009 - 09:22

Hi Will,

It sounds like you're going to need to run a considerable amount of debugs. I suggest a TAC case.

-nick

Tim Smith Thu, 07/22/2010 - 02:36

Hi Will,

did you end up with a resolution for this one?

think I'm having exact same issue.

Cheers,

Tim

will.alvord Thu, 07/22/2010 - 08:07

I don't recall that this was ever resolved.  Shortly after opening the tac case, my contract with that company ended.  I doubt anything was done on this after I left since it was sort of a pet project of mine.  I'll try to reach out to the remaining engineer who I believe is still working for that company and post again if he ever got it working.

thanks,

will

Tinnakorn Mukud... Thu, 07/22/2010 - 09:15

have you try these command?

voice service voip
h323
h245 caps mode restricted --> hidden command
h245 tunnel disable --> hidden command

Actions

This Discussion