Ciscoworks hardware inventory

Unanswered Question

Is it possible to search for a device by serial number? I have ran the RME/Reports/Reports Generator/Inventory/Hardware report. My concern is that report is not reporting every device on the network. Trying to renew Smartnet and I have some 2950 switches that were covered last year that don't show up on the report. Trouble is all I know about the units in question is model type and serial number. No clue where they might be on the network.I haven't replaced that many that where maybe the new unit never was added in place of a defective unit, so I don't know where these guys are or if they really exist. Not confident enough in CW to say for 100% the units are not here based on hardware report. Very much a NOVICE with CW. No training and used only periodically. Can anyone help?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 05/05/2009 - 10:51

Depending on the version of code on these devices and the version of RME, you may not find those serial numbers. The devices may not be reporting them, or RME may not be using the right objects to retrieve them.

The good news is that I am using LMS 3.1, and I have a 2950 running 12.1(22)EA10. Show ver reports the system serial number, and when I run the Hardware Report, I see the same serial number in the System Information section.

I have many 2950's that are reporting. Code on those is all over the place. The majority of the few that aren't reporting were on last year's contract as 2950T models. Probably old code. I gather from your reply that I'm stuck. Don't know where they are or if they even exist any longer, so I don't know where to go look for them to execute Sh Ver. Smartnet Contract only references model and serial numbers with all 200+ devices showing at one of two addresses. We actually have 65+ locations. Can't even narrow it down by location. Any ideas?

Joe Clarke Tue, 05/05/2009 - 11:07

First, what version of RME do you have? Are all of your 2950s in RME? It sounds like the answer is no.

Joe Clarke Tue, 05/05/2009 - 12:12

Good enough. This version is VERY old, and should be upgraded. However, I'm not sure the upgrade will help in this situation. Are there 2950s currently in the RME inventory that are not showing any serial number? That is, if you run a Hardware Report for your entire set of 2950s, are some of them showing an empty serial number field?

Joe Clarke Wed, 05/06/2009 - 14:22

If the problem is that the SNT contract shows different numbers, then there is one other thing you can try. Assuming your RME version is recent enough, you can go to RME > Tools > Netshow, and create a new Netshow job which runs show ver on all of these switches. Then you can search the output for the serial numbers in your SNT contract.

I think my first reply timed out before I could send. Sorry if this is a Dup.

The issue is my SNT contract from last year shows 8 2950t's that don't show up in my hardware report ran this year. I don't have anything to go on to try and locate them other than serial number (no actual location of IP Address). I know we haven't replaced that many in the last year, so it's not a case of those being replaced with units with different serial numbers. I ran the Netshow job you suggested. Didn't offer much more than what the hardware report does. I think we are going to move on on the SNT contract and away from Ciscoworks as a tool. It seems too complicated to use and is definitely too expensive to cover under SNT in order to get TAC support. We have our eye on a Solarwinds product. Thanks for your help.

Joe Clarke Thu, 05/07/2009 - 08:41

RME is doing the same underlying operations that Solarwinds would do. I see your problem as being one of two things. If the hardware report isn't showing you eight serial numbers that SNT claims you should have then either the devices with those serial numbers are not managed by RME, or those devices are not reporting the correct serial number via SNMP.

If Netshow, on the other hand does not show you the missing serial numbers from a show ver, then I would strongly suspect the devices are not managed by RME. Therefore, perhaps those switches WERE replaced, they were powered off, or simply not added to LMS.

You could try a Campus Manager Discovery sweep to see if it can pick up any missing devices via a CDP scan of the network. This can be run from Campus Manager > Admin.

Joe Clarke Thu, 05/07/2009 - 09:14

No, Discovery itself you not show serial numbers. However, if it found any new devices, it would add them to DCR which would cause RME to manage them. However, if periodic Discovery has been running, then it has most likely found all of the devices it can on your network. That leaves my other suggestions about replaced or inaccessible switches.

Actions

This Discussion