Unity 5.0 - call handlerwith DID

Unanswered Question
May 5th, 2009
User Badges:

Dear sir ,

I have three location A ,B and C , we are using cisco unity 5.0 and callmanager in central site (site C) as a centralized model .remaing two remote locations are connected on central site. In (remote site A) we have FXO and in Remote location B we have DID. we are using AA of unity with call handler .In remote location A with FXo when any incoming call land we can hear welcome greeting than it ask us press 1# for English and Press 2 # for Arabic ,when i press 1# i can listen english greeting when i press 2# I can listen arabic.But now my problem is that if I configure same unity call handler /greetings with my Remote location B with DID it gives me only inital greeting.when i press 1# or press 2# nothing happines with DID. but only initial greeting runs when call lands.

Appreciate your help regarding this matter.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dennis Mink Wed, 05/06/2009 - 04:01
User Badges:
  • Gold, 750 points or more

sounds like a dtmf issue.



check dtmf on the remote location B (assuming cisco equipoment)




For H323


debug h245 asn1


For SIP


debug voip rtp session named-event


Sample output


H323


Aug 21 21:07:37.902: h245_decode_one_pdu: more_pdus = 0, bytesLeftToDecode = 7

Aug 21 21:07:37.902: H245 MSC INCOMING ENCODE BUFFER::= 6D810447200063

Aug 21 21:07:37.902:

Aug 21 21:07:37.902: H245 MSC INCOMING PDU ::=


value MultimediaSystemControlMessage ::= indication : userInput : signal :

{

signalType “9″

duration 100

}


SIP


Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:04 00 00 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:04 00 00 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:04 00 00 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:04 01 90 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:84 03 20 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:84 03 20 >>

Aug 21 21:07:37.902: Pt:101 Evt:9 Pkt:84 03 20 >>



see if your key presses are received at all

zeeshan2007 Sun, 05/10/2009 - 23:25
User Badges:

Dear Sir,


As I mention in my last email I have tested a lot of thing now I found one result I have centrial CCM 4.3 and certilized unity in my centrial site and I have four PRIs with DID's. two of the PRI's are terminated in centrial site router and 2 are terminated in DR site router when ever I am trying to use auto attented on certrial site DID's which are terminated in centrial site router where is my CCM its is working fine but when ever I am trying to use auto attented on DR site DID's which are terminated in DR site router its give me same problem which I have mention in my last email my configuration in unity is fine because is start working when I use centrial site DID kindly help me I will be really thankful to you. only inital greetings work on DR sites


I m also attached both router configuration as well I m using MGCP for PRI.




Attachment: 
zeeshan2007 Tue, 05/12/2009 - 20:01
User Badges:

Dear Sir,


As I mention in my last email I have tested a lot of thing now I found one result I have centrial CCM 4.3 and certilized unity in my centrial site and I have four PRIs with DID's. two of the PRI's are terminated in centrial site router and 2 are terminated in DR site router when ever I am trying to use auto attented on certrial site DID's which are terminated in centrial site router where is my CCM its is working fine but when ever I am trying to use auto attented on DR site DID's which are terminated in DR site router its give me same problem which I have mention in my last email my configuration in unity is fine because is start working when I use centrial site DID kindly help me I will be really thankful to you. only inital greetings work on DR sites


I m also attached both router configuration as well I m using MGCP for PRI.

Actions

This Discussion