VLAN issue on 3750 switches

Unanswered Question
May 7th, 2009
User Badges:

Hi,


Strange one here, I have 2 x 3750G switches which connect to our Nortel core switches. The trunk is setup as an Etherchannel, I have 2 ports in each etherchannel goign to the Nortel switches.


(I can add a diagram if required)


On these 3750's is our Exchange 2007 email system and I use Solarwinds Orion tools to monitor these Exchaneg servers and email me if anything goings down.


I am using 3 VLAN's on the 3750's and Solarwinds happy ping sthe servers and I get no issues at all. The problem I am getting is pinging the VLAN's on these 3750's (basically their default gateways), throughout the day I will get email alerts saying VLAN 10 is down then up, then later VLAN 20 is down then up, this can take only 30 seconds, but they never go down at the same time and it might only be one 3750 switch for that day, the other will be fine.


I'm just not sure where to start as the Exchaneg system is fine, but it just concerns me.


Is it the Nortel's or the trunk?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smothuku Thu, 05/07/2009 - 00:57
User Badges:
  • Silver, 250 points or more

Hi ,


If logging is enabled on your switches you can the logs using show log on 3750 switches.


Are you seeing any interface flops in logs..


Thanks

satish

whiteford Thu, 05/07/2009 - 01:05
User Badges:

On both all I have is this, do I ned to change the logging level if so how?


Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

Console logging: level debugging, 2704 messages logged, xml disabled,

filtering disabled

Monitor logging: level debugging, 1 messages logged, xml disabled,

filtering disabled

Buffer logging: level notifications, 47 messages logged, xml disabled,

filtering disabled

Exception Logging: size (4096 bytes)

Count and timestamp logging messages: disabled

File logging: disabled

Trap logging: level notifications, 2707 message lines logged

Logging to 192.168.21.19, 1400 message lines logged, xml disabled,

filtering disabled


Log Buffer (8192 bytes):


14w6d: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.7.12)

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/10, changed state to down

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/19, changed state to down

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/10, changed state to down

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/19, changed state to down

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/10, changed state to up

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/19, changed state to up

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/10, changed state to up

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/19, changed state to up

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/10, changed state to down

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/10, changed state to down

15w0d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/10, changed state to up

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/10, changed state to up

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/19, changed state to down

15w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/10, changed state to down

3750-B#

smothuku Thu, 05/07/2009 - 01:10
User Badges:
  • Silver, 250 points or more

We can see the interface flap is happening...


Can paste the config...


Thanks,

Satish

whiteford Thu, 05/07/2009 - 01:12
User Badges:

These are 15w0d old though, not recent and are just cables put into port 10 and 19.

smothuku Thu, 05/07/2009 - 01:15
User Badges:
  • Silver, 250 points or more

Hi ,


Clear the logs and check the logs at the end of the day..after getting mail alerts...


Thanks,

Satish

whiteford Thu, 05/07/2009 - 01:31
User Badges:

Is my logging levels ok to capture this?


sh run | include logging

logging buffered 8192 notifications

logging enable

logging size 200

logging trap notifications

logging facility local4

logging source-interface Vlan1028

logging 192.168.2.9


glen.grant Thu, 05/07/2009 - 06:22
User Badges:
  • Purple, 4500 points or more

I would make your logging buffer size a lot bigger . the default does not give you many messages before it overwrites itself , I would make it like 100K .

whiteford Thu, 05/07/2009 - 11:35
User Badges:

Thanks, all done.


Should I be seeing anything using "terminal monitor" via telnet if my config is:


logging buffered 100000 notifications

logging trap notifications


or


logging buffered 100000 debug

logging trap debug


I added these lines, but see nothing

iyde Thu, 05/07/2009 - 10:13
User Badges:
  • Silver, 250 points or more

Hi. No, they happened 15w0d after last reload of the switch...

Oen reason why the Cisco default of "srvice timestamp log uptime" is annoying.

Always as a best practice user "service timestamp debug/log datetime msec" and if possible NTP in order to have useful time stamping of what goes on in your network.

whiteford Thu, 05/07/2009 - 11:01
User Badges:

Thanks, I have done this, do I need to change these settings to debug?


logging buffered 100000 notifications

logging trap notifications


lamav Thu, 05/07/2009 - 06:43
User Badges:
  • Blue, 1500 points or more

Hi:


Its hard to say what is wrong. I doubt there is any issue with the Nortel switch or the trunk.


For starters, why dont you configure more granular logging.


service timestamps debug datetime localtime

service timestamps log datetime localtime


Clear the log and lets see what kind of error messages pop up.


HTH


Victor

whiteford Thu, 05/07/2009 - 07:02
User Badges:

Hi,


I have changed a few settings, this what I have, do I need to change my trap and buffer to debug?


sh run | inc logg

logging buffered 100000 notifications

logging enable

logging size 200

logging trap notifications

logging facility local4

logging source-interface Vlan1028

logging 192.168.2.9


glen.grant Thu, 05/07/2009 - 13:53
User Badges:
  • Purple, 4500 points or more

If you want to see the debug in the logs then yes change it to logging buffered debugging .

whiteford Mon, 05/11/2009 - 12:35
User Badges:

Hi,


Well after a few days the vlans are still going up and down, but the "sh log" only shows my logins, does this mean the switches are fine? Maybe it is the opposite end of the trunk that is the issue, the Cisco's have a trunk to a Nortel core switch.

milan.kulik Thu, 05/07/2009 - 07:04
User Badges:
  • Red, 2250 points or more

Hi,


I guess this might be an Etherchannel between Cisco and Nortel problem.

How exactly is the etherchannel configured on your switches?


The 30 second outage also leads to an STP problem possibility.

Again, which STP mode is configured on your Cisco and Nortel switches?

Where is the STP root in your LAN?


BR,

Milan


whiteford Thu, 05/07/2009 - 07:10
User Badges:

Hello,


Please ignore the output, these ports going down were just a couple of servers rebooting.


Just a simple etherchannel


sh etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port



Number of channel-groups in use: 1

Number of aggregators: 1


Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) - Gi1/0/12(P) Gi1/0/24(P)



interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport mode trunk

flowcontrol receive on


interface GigabitEthernet1/0/12

description Dot1q Trunk to Nortel Core 1

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport mode trunk

flowcontrol receive on

channel-group 1 mode on


interface GigabitEthernet1/0/24

description Dot1q Trunk to Nortel Core 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport mode trunk

flowcontrol receive on

channel-group 1 mode on





Actions

This Discussion