Show Interface trunk

Answered Question
May 7th, 2009

With the following config on a Cisco 3845 router, I cannot seem to figure out why I cannot see the trunk details with show interface trunk command.

Ping, traceroute, EIGRP, iBGP peering is operational but no trunk details on the router side.

On Cisco 3845 router, IOS

c3845-advipservicesk9-mz.124-11.XJ4.bin

show interface trunk - no output

On peering Cisco 3750e switch

C3750e#sh int trunk

Port Mode Encapsulation Status Native vlan

Gi1/0/5 on 802.1q trunking 4

Gi1/0/6 on 802.1q trunking 4

Port Vlans allowed on trunk

Gi1/0/5 1-4094

Gi1/0/6 1-4094

Port Vlans allowed and active in management domain

Gi1/0/5 1-2,4-7

Gi1/0/6 1-2,4-7

Port Vlans in spanning tree forwarding state and not pruned

Gi1/0/5 1-2,4-7

Gi1/0/6 1-2,4-7

ROUTER 3845 config

vlan 2

name OER-2

!

vlan 4

name OER-4

!

vlan 5

name OER-5

!

vlan 6

name OER-6

!

vlan 7

name OER-7

!

interface GigabitEthernet0/0

no ip address

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1

ip address 172.26.1.1 255.255.255.240

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 2

ip address 172.26.2.1 255.255.255.240

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 4 native

ip address 172.26.4.1 255.255.255.0

!

interface GigabitEthernet0/0.5

encapsulation dot1Q 5

ip address 172.26.5.1 255.255.255.0

!

interface GigabitEthernet0/0.6

encapsulation dot1Q 6

ip address 172.26.6.1 255.255.255.0

!

interface GigabitEthernet0/0.7

encapsulation dot1Q 7

ip address 172.26.7.1 255.255.255.0

Cisco 3750e config

vlan 2

name OER-2

!

vlan 4

name OER-4

!

vlan 5

name OER-5

!

vlan 6

name OER-6

!

vlan 7

name OER-7

C3750e#sh run int g1/0/5

interface GigabitEthernet1/0/5

description master-connector

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

Tks

Frank

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 7 months ago

Hello Franck,

just a moment you have routed subinterfaces on the C3845 not a L2 trunk!

for seeing packets for vlans and the associated subintefaces use

sh vlan

or

sh vlans

(this is IOS dependent in 12.4 should be sh vlans)

this can tell you how much traffic is sent and received on each vlan and the corresponding subinterfaces

traffic is divided for L3 protocol (ipv4, ipx , ipv6)

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.

I searched for this command on my 2821. It is in the IOS but gives no information.

I looked through the master command index for 12.4 and 12.4T. The command is NOT shown in either of those.

The IOS command lookup tool was able to find it.

It looks like it is only supported on the 6500 series chassis. It was introduced for the Supervisor 2 and then added for the SUP720.

Link to the tool:

http://tools.cisco.com/Support/CLILookup/cltSearchAction.do?Application_ID=CLT&IndexId=IOS&IndexOptionId=123&SearchPhrase="*"&Paging=25&ActionType=getCommandList&Bookmark=True

Release Modification

12.2(14)SX

Support for this command was introduced on the Supervisor Engine 720.

12.2(17d)SXB

Support for this command on the Supervisor Engine 2 was extended to Release 12.2(17d)SXB.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXI

This command was changed to add the optional vlan vlan keyword and argument.

fsebera Thu, 05/07/2009 - 10:35

Hi Bret,

I used this setup on my 7206VXR running IOS 12.4T last year and all was good then.

Perhaps the Cisco 3845 programmers were under time constraints and just missed this one.

I guess as long as it works and passes traffic I should be happy!!!

Thanks again

Frank

Giuseppe Larosa Thu, 05/07/2009 - 10:50

Hello Frank,

sh int trunk is very handy and I use it on C6500 and C4500 it comes from the old sh trunk in CatOS.

However, not all IOS based switches support it.

the less readable alternate way in those switches is to use

sh int type x/y switchport

I would try if it works for your C3845.

Hope to help

Giuseppe

fsebera Thu, 05/07/2009 - 11:00

Thanks, it's a no go.

Switchport option not available but tried it anyway :).

I list the output from two different subinterfaces and both provide the same details -

Perhaps the description line should read -- SEE VISIO DOCUMENTATION!!!!

Thanks again

OER-Master1#sh int gigabitEthernet 0/0.4 switchport

^

% Invalid input detected at '^' marker.

OER-Master1#sh int gigabitEthernet 0/0.4 ?

aaa dot11 aaa information

dampening Show interface dampening info

description Show interface description

mpls-exp Show interface MPLS experimental accounting info

precedence Show interface precedence accounting info

rate-limit Show interface rate-limit info

| Output modifiers

OER-Master1#sh int gigabitEthernet 0/0.4

GigabitEthernet0/0.4 is up, line protocol is up

Hardware is BCM1125 Internal MAC, address is 0023.5eae.1f90 (bia 0023.5eae.1f90)

Internet address is 172.26.4.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 4.

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters never

OER-Master1#sh int gigabitEthernet 0/0.7

GigabitEthernet0/0.7 is up, line protocol is up

Hardware is BCM1125 Internal MAC, address is 0023.5eae.1f90 (bia 0023.5eae.1f90)

Internet address is 172.26.7.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 7.

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters never

Correct Answer
Giuseppe Larosa Thu, 05/07/2009 - 11:06

Hello Franck,

just a moment you have routed subinterfaces on the C3845 not a L2 trunk!

for seeing packets for vlans and the associated subintefaces use

sh vlan

or

sh vlans

(this is IOS dependent in 12.4 should be sh vlans)

this can tell you how much traffic is sent and received on each vlan and the corresponding subinterfaces

traffic is divided for L3 protocol (ipv4, ipx , ipv6)

Hope to help

Giuseppe

fsebera Thu, 05/07/2009 - 11:25

Duh, I am so ruined.

YOU ARE CORRECT.

Turns out, trunking is not a valid verb.

My sub-interfaces are not allowed to be layer-2 interfaces - only layer-3.

I guess the 3750e switch "TRUNKING" mislead me into thinking I was creating layer-2 interfaces and the subs were the layer-3 portion. It appears I need a switchport module to make use of the vlans on the 3845 router....

Thanks

OER-Master1#sh vlans

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.1

Protocols Configured: Address: Received: Transmitted:

IP 172.26.1.1 2506 2508

Other 0 199

2701 packets, 374945 bytes input

2707 packets, 371210 bytes output

Virtual LAN ID: 2 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.2

Protocols Configured: Address: Received: Transmitted:

IP 172.26.2.1 2544 2550

Other 0 4

2544 packets, 298974 bytes input

2554 packets, 299355 bytes output

Virtual LAN ID: 4 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.4

This is configured as native Vlan for the following interface(s) :

GigabitEthernet0/0

Protocols Configured: Address: Received: Transmitted:

IP 172.26.4.1 2549 4800

Other 0 4

2935 packets, 312323 bytes input

4804 packets, 410704 bytes output

Virtual LAN ID: 5 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.5

Protocols Configured: Address: Received: Transmitted:

IP 172.26.5.1 2756 2954

Other 0 4

2756 packets, 315709 bytes input

2958 packets, 327241 bytes output

Virtual LAN ID: 6 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.6

Protocols Configured: Address: Received: Transmitted:

IP 172.26.6.1 4789 2554

Other 0 4

4789 packets, 442759 bytes input

2558 packets, 299860 bytes output

Virtual LAN ID: 7 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet0/0.7

Protocols Configured: Address: Received: Transmitted:

IP 172.26.7.1 2513 2521

Other 0 4

2513 packets, 296666 bytes input

2526 packets, 298303 bytes output

glen.grant Thu, 05/07/2009 - 13:56

The only way "sh int trunk" would work in a 3845 is if it had hwic switchcard in one of the slots and you set up trunking on one of those ports , as previously stated it won't work on a routed port with subinterfaces.

Actions

This Discussion