Assistance with SNR

Unanswered Question
May 7th, 2009

Hello,

I am currently working on configuring SNR with 7.1.0EA software pack. I have a couple questions however:

  1. If you enter just the mobility command under the ephone-dn and leave out the SNR command, users are unable to enable and configure the SNR number through their IP phone. It states that that SNR is not configured. Is this by design? The reason I ask is because I relaize I am ommitting certain portion of the code, but as an administrator, it seems like it would be difficult to configure the propper SNR number and timeout features for each user when you might not know what number(s) they plan on using for SNR functionality. Is there any way to just enable mobility for a phone and allow the user to finialize the rest of the required settings through their phone?
  2. On a seperate ephone-dn, I enabled mobility and configured the SNR number with delay and timeout of 5 seconds. I then specified the VM piolot# for CF-Noan. But after the call is transfered to the SNR phone # (my cell phone), it rings for longer than the timeout period and then still goes to my cell phone VM.

Here is my config:

ephone-dn  13  dual-line
number 101 no-reg primary
pickup-group 1
label 101
description Brian Fleishman
name Brian Fleishman
mobility
snr 917326745057 delay 5 timeout 5 cfwd-noan 600
call-forward busy 600
call-forward noan 600 timeout 20

Thanks,

Brian

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Maulik Shah Sun, 05/10/2009 - 18:45

1. This is per design - you could enable SNR for a user without knowing the number by just adding the SNR CLI pointing to a dummy extension or voicemail and having the user update this on the phone. The timeouts still need to be configured by the admin.

2. Not sure what you are trying to do in this case - would recommend you always keey delay < the timeout value (make delay 0 or 1 second) - see below for what both timers do:

delay: 0 to 10 seconds. After this timer expires, will try to ring both PSTN phone and the SNR DN.

timeout: 5 to 60 seconds. After this timer expires, no call appearance will be shown onthe phone. User has to use soft-key to pull-back or send-to  cell phone. 60 seconds will be the default value if enabled.

jaydien1358 Mon, 05/11/2009 - 04:53

OK. That makes sense. I can just set the default number to VM extension or something. But I'm curious about the delay and timeout settings.

The delay setting is for the time period before the SNR number is dialed? And the timeout period is the period when the cisco phone removes itself from the phone call and just lets the SNR number handle the call?

Also, apparently from another post in this thread, when using a PSTN line it can't fallback to the UC500 VM if there is no answer? Is that correct?

Lastly, I'm not familar with FXO Disconnect Supervision. Can you elaborate?

Thanks.

-Brian

greenturtlesteak Mon, 05/11/2009 - 06:19

That is correct if you are using analog phone lines.  The SNR call will go out but once that call is made the system doesn't have a way to keep track if that call is answered or not, thus making the timeout and snr call-forward noan values useless.  This problem does not occur if you are using ISDN. 

I really wish Cisco would include complete support for analog lines using SNR in a future release.

Cole

jaydien1358 Mon, 05/11/2009 - 06:22

Yeah I agree. Not much difference than call forwarding at this point.

Brian

Maulik Shah Mon, 05/11/2009 - 10:10

See inline responses below:

The delay setting is for the time period before the SNR number is dialed?

Correct - you can set this to 0 in which case its immediate

And the timeout period is the period when the cisco phone removes itself from the phone call and just lets the SNR number handle the call?

No (I see your confusion from my statement earlier) - Sets the number of seconds that the call continues to ring on the desk phone even if theSNR number answers the call.

Here is an explanation of what happens with each timer:

For incoming calls to the SNR extension, UC500 rings the desktop IP phone first. If the IP phone does not answer within the configured amount of time (delay xx), it rings the configured remote number while continuing to ring the IP phone (timeout xx). Unanswered calls are sent to a configured voice-mail number (after both delay & timeout xx have expired)

Also, apparently from another post in this thread, when using a PSTN line it can't fallback to the UC500 VM if there is no answer? Is that correct?

Fallback to UC500 VM is not supported on analog lines (assume that is what you mean by PSTN line) as on analog lines there is no answer or disconnect supervision - meaning on an analog line the call is "connected" as soon as a call is setup, there is no notification from the CO (Central Office) to indicate the call has actually been connected to the called party or not unlike in ISDN / SIP trunks. The solution for this would require the called party to explicitly enter a digit to answer the call on the SNR number which is available using UCC Mobility SNR.

greenturtlesteak Sun, 05/10/2009 - 22:35

I ran into the same problem and it turns out that this feature does not work if you are using FXO ports for PSTN connectivity.  Only a PRI/BRI circuit will allow the SNR call to be pulled back to voicemail.

Cole

Maulik Shah Sun, 05/10/2009 - 23:04

Did you also keep the values for delay and timeout to be the same? If not it maybe a different issue in your case (FXO disconnect supervision perhaps??)

Actions

This Discussion