Facility IE with H.323

Unanswered Question
May 7th, 2009
User Badges:

I have the following topology:


Nortel Option 81 --- Qsig --- Cisco 3825 [12.4(3F)] --- Cisco 3825 [IOS 12.4(8c)] --- Qsig --- Avaya


They enabled Q.sig in order to have the Caller Name feature while calling from one PBX to the other. Now the problem is that the caller name is never received.


Taking the debug isdn q931 I see that the caller name is sent in Facility IE.


May 7 18:35:01.344: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x2601

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839E

Exclusive, Channel 30

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0980, '2110'

Plan:Private, Type:Unknown

Called Party Number i = 0x89, '43411'

Plan:Private, Type:Unknown

Sending Complete

Locking Shift to Codeset 5

Codeset 5 IE 0x31 i = 0x80

Codeset 5 IE 0x32 i = 0x81

.May 7 18:35:01.360: ISDN Se0/1/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0xA601

Channel ID i = 0xA9839E

Exclusive, Channel 30

.May 7 18:35:01.648: ISDN Se0/1/0:15 Q931: TX -> ALERTING pd = 8 callref = 0xA601

Facility i = 0x9FAA068001008201008B0100A1190202B6EA06072B0C0287780101040AC9003414010000000000

Facility i = 0x9FAA068001008201008B0100A1170202B6EB020101800E4352555A2C414C454A414E44524F

Progress Ind i = 0x8188 - In-band info or appropriate now available

.May 7 18:35:01.692: ISDN Se0/1/0:15 Q931: RX <- STATUS pd = 8 callref = 0x2601

Cause i = 0x81E4 - Invalid information element contents

Call State i = 0x04

.May 7 18:35:03.048: ISDN Se0/1/0:15 Q931: TX -> CONNECT pd = 8 callref = 0xA601

Facility i = 0x9FAA068001008201008B0100A1170202B6ED020102800E4352555A2C414C454A414E44524F

Progress Ind i = 0x8182 - Destination address is non-ISDN

Connected Number i = 0xC9, '43411'

.May 7 18:35:03.096: ISDN Se0/1/0:15 Q931: RX <- STATUS pd = 8 callref = 0x2601

Cause i = 0x81E4 - Invalid information element contents

Call State i = 0x0A

.May 7 18:35:03.100: ISDN Se0/1/0:15 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x2601



I cannot change to MGCP which I know that it supports Facility IE. I'm not sure if newer IOS versions supports Facility or if there is any other workaround that I can use.


Any help will be really appreciated.


Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 05/07/2009 - 16:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, my reading of your trace is a bit different.

PBX is not sending caller name (where do see that ?)

Router is sending alerting name and connected name, as received from remote PBX. PBX doesn't like the format (invalid IE), nevertheless the call is established.


Actions

This Discussion