DTMF not Working after Upgrade

Unanswered Question
May 8th, 2009

I have a UC500 and I’m having some issues with DTMF after I upgrade to uc500-advipservicesk9-mz.124-22.T.bin… It works find with uc500-advipservicesk9-mz.124-11.XW9.. I have tried different IOS’s and they are all the same. It does not send DTMF to our Fax Server. I’m connecting two lines to a Multitech Fax Finder.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Tue, 05/12/2009 - 19:11

Hi there,


When you say two lines, do you mean using FXS ports? Have you tried to configure the port as "fax" and not "user"?


Thanks,

Marcos

jorgediaz77 Thu, 05/14/2009 - 08:42

Hey Marcos,

How do you change an FXS port to Fax rather than user through the CLI?

Marcos Hernandez Thu, 05/14/2009 - 09:47

Jorge,


You do that by editing the POTS dial-peers associated with the FXS ports to only include a "destination-pattern" and "port" statement. Also, you delete the phones that have type "anl" (analog). This should do it.

Let me know how it goes.


Marcos

jorgediaz77 Thu, 05/14/2009 - 10:23

Marcos,

I have attached my dial-peer config as it stands now. What is happening now is I call into the numbers and it rings once and goes to a dialtone. We do have DID's and the T1 line is only passing through the last 4 numbers of the full phone number, not sure if that makes a difference.

Thanks,

Jorge

flora.r Thu, 05/14/2009 - 10:27

Ran into the same problem with a MultiTech fax server.  TAC upgraded the system to 12.4-20.T3 to fix it.

Rob

jorgediaz77 Thu, 05/14/2009 - 11:02

Thanks for the suggestion but we are already on the latest version which is actually a couple above the one you upgraded to.

jorgediaz77 Thu, 05/14/2009 - 11:34

Marcos,

I was looking through the running config and noticed several voice translation-rules that reference the numbers being used for faxes, are these the possible reasons:

voice translation-rule 4
rule 1 /6666/ /100/
!
voice translation-rule 5
rule 1 /6984/ /303/
!
voice translation-rule 6
rule 1 /6983/ /301/
!
voice translation-rule 8
rule 1 /3958/ /601/
!
voice translation-rule 9
rule 1 /6664/ /400/
!
voice translation-rule 1111
rule 1 /303/ /6984/
rule 15 /.*/ /3019486666/
!
voice translation-rule 1112
rule 1 /^9/ //
!
voice translation-rule 2001
!
voice translation-rule 2222
!
!
voice translation-profile AccountingFax_Called_5
translate called 5
!
voice translation-profile Accounting_Called_8
translate called 8
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile JeffFaz_Called_6
translate called 6
!
voice translation-profile MainLine_Called_4
translate called 4
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate calling 1111
translate called 1112
!
voice translation-profile Voicemail_Called_9
translate called 9

Marcos Hernandez Thu, 05/14/2009 - 13:54

Jorge,


You need a POTS dial peer for each DID number that is provided by your PSTN, and it needs to look like this:

dial-peer voice 3004 pots
description Accounting
translation-profile incoming Accounting_Called_8
incoming called-number 3958
direct-inward-dial

Incoming called number needs to match the 4 digits for the DID, and then each translation profile must be referenced accordingly. These are the ones that change the called number DID to the internal extension.

Let me know how it goes,

Marcos

jorgediaz77 Thu, 05/14/2009 - 17:32

OK, I think I am close, now when you dial in it kicks over to an extensions VM which I think is because of voice translation-rule. Should those be there or should there be different lines. below is the info for the two seperate fax lines.

dial-peer voice 3 pots
description Accounting
translation-profile incoming AccountingFax_Called_5
incoming called-number 6984
direct-inward-dial
port 0/0/2


dial-peer voice 1 pots
translation-profile incoming JeffFaz_Called_6
incoming called-number 6983
direct-inward-dial
port 0/0/0


voice translation-profile AccountingFax_Called_5
translate called 5

voice translation-profile JeffFaz_Called_6
translate called 6

voice translation-rule 5
rule 1 /6984/ /303/

voice translation-rule 6
rule 1 /6983/ /301/

jorgediaz77 Thu, 05/14/2009 - 17:55

OK, so I went in and looked at my config, I have 2 ephone-dn's with the extensions listed in the translation rules, they both had a 'call-forward busy' and 'call-forward noan'. I removed both of them and now the lines just ring forever.

I confirmed that the fax machines do see the inbound call and I can pick up the headsets on the fax machines it is a live line. I can make outbound faxes from the machines.

My thought is that the fax machines aren't hearing actual rings so they aren't picking up. I check on them and they are both set to pick up after 3 rings.

Could that be the case? Or am I way off base?

cblank1234 Thu, 05/14/2009 - 19:52

I have tried different IOS upgrades on my UC500 and cannot get the DTMF to work. It works fine on with 124-11.XW"XX" versions. Everything I upgrade to either uc500-advipservicesk9-mz.124-20.T2.bin, T3 or any newer version you cannot hear the DTMF.. With the XW version I can call any one of my DID numbers that are assigned to my fax group and I hear the four beeps for DTMF. I have tried the input and out put gain controls and the timming and cannot get it to work. I really need the upgrade so I can use the new CUE. There is one or two features that we really need for our company. if anyone has a suggestion I will try it this weekend.. I have asked several Cisco Techs and Embarq Techs and no one can figure out why the DTMF is working. If it is working the system cannot hear the tones. 

Marcos Hernandez Wed, 05/20/2009 - 14:11

This is a response to cblank1234


May I kindly ask you to go ahead and open a TAC case? We will need to track this and see where the differences lie in terms of IOS behavior.

Thanks,


Marcos

Actions

This Discussion