Unanswered Question
May 8th, 2009

IP Manager Assistant comes with a great wizard to setup.. How do you undo the settings? I am deleting / unassociating route points, partitions, and search spaces but I still cant delete the partitions. Something is associated with something that is not visible?

Cisco Unified Communications Manager Assistant is invoked already

Use Bulk Administration Tool to add manager and assistant.

Also can't just run the wizard over..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
allenelson Sat, 05/09/2009 - 05:25


Thank you for the fast response. I enabled the records, and ran a check. It shows there are 144 directory numbers utilizing a partition, however I cannot locate them because they were automatically generated by the wizard and do not show up under the directory numbers page in CCMADMIN, any thoughts?

allenelson Sat, 05/09/2009 - 05:29

Nevermind that post.. I can click on them and delete them from the dependency list.. There has got to be an easier way to delete these! Over 100 DNs it created!

allenelson Mon, 05/11/2009 - 04:50

After deleting the hundreds of DNs that were created and associated with the partitions, i still cannot remove the PTs or CSS's. Even though the dependency check reports 0 items, when trying to delete the error message states:

Delete failed. The pkid column in the callingsearchspace table in the database is being referenced from another table. Please check the dependency records and remove the reference and the try the delete again.

Does anyone know how i can get rid of this stuff? I cannot test features to use if you cannot add and re-add them! IPMA wizard definitely needs some work.

j.huizinga Fri, 05/15/2009 - 00:23

You can only run the wizard one time, after that you are stuck with it.

I also have some left overs from this wizard that I can not get rid of. In general the wizard is quite annoying and the auto configuration from IPMA makes more trouble then that it helps.

I am making all manual, and don't use the autoconfig option any more.

I try not to use IPMA, find it to complicated to implement (especially proxy-mode) and not user (assistant) friendly.

allenelson Fri, 05/15/2009 - 04:25

Wonderful! Exactly what i didn't want to hear...

What are your likes and dislikes about the feature? I cannot get the CFB/CFNA to work when no one is logged in and the manager is taking all calls. Calls from internal extensions do not complete (they do not ring, no busy tone, the dialing phone just hangs freezes and eventually reboots).

Sucks that these features are half implemented, this is one of the few that no other systems have.

j.huizinga Wed, 05/20/2009 - 23:09

I assume you talk about proxy mode, since shared-line mode has hardly any problems (except for transfer to manager)

In proxy mode the main issue is the complexity. It also is very sensitive to changes, meaning that when you make a small change, you are ending up with restarting the IPMA service, which in its turn will affect all your IPMA configuration (assistants are kicked out of the program etc) IPMA changes can be done only off hours then, very annoying, because assistant are at home, I don't know the AD password, so I make a change but I am not sure if all is OK since I can not test it.

The problems you mentioned are mostly related to CSS and partitions. I also had a problem once that calls did not complete to the boss when assistant was off-line. In my case there was a duplicate DN in the system that was in a partition before the bosses DN. Check this with Call routing/Route Plan Report.

I think Cisco would make many assistants happy if they gave an opportunity to make them self on-line/off-line using a button on the phone in proxy-mode, and make it easier to transfer a call to the manager in a shared line configuration.

They would make technicians more happy if they don't need to restart the IPMA service all the time.

Wondering what John Chambers is using: proxy,shared or he doesn't use it.

allenelson Thu, 05/21/2009 - 04:14

Lol. I've had a PDI case open for days with no response, because I cannot call the managers extension when no one is logged in. The phone just freezes and eventually reboots.

I cant tell you how thankful I am for your post, which made me change the order of the partitions to make the calls complete!

The shared line mode seems much more attractive to me, especially because of the simplicity. Is there a way to turn off the annoying phone status on the assistants phone? The thing flashes so much I wouldnt dare install that on a customer system.

j.huizinga Thu, 05/21/2009 - 22:33

Sorry don't get "Is there a way to turn off the annoying phone status on the assistants phone? The thing flashes so much I wouldnt dare install that on a customer system."


allenelson Fri, 05/22/2009 - 08:12

My apologies. I probably have more testing to do, but it seemed that when the IPMA assistant service was created and assigned to the assistants phone, whether logged in or not it would flash in between the console LCD screen and the idle softkey set.

I was configuring / reconfiguring proxy mode and shared line simultaneously so it is possible the phone was already logged in and was the reason for it.

Ill fool with it some more, for now im happy that proxy mode is working correctly.

Ajay Singh Thu, 06/11/2009 - 08:42

Well..i also gone through the same problem that once you run the wizard,all the auto generated CSS are automatically attached with phone templates as well, which are around 100 entries. I wonder why are u not getting this in dependency record...

allenelson Thu, 06/11/2009 - 08:46

I deleted everything that showed up in the dependency records. Off the top of my head, I can't remember 100% but I'm sure it made phone templates as well.

DN's, Templates, Intercoms, etc. All deleted, 0 dependencies yet you cannot remove the rest of the junk. I guess it doesn't really matter whether or not it is a bug, since the feature is on its way out the door.

Ajay Singh Thu, 06/11/2009 - 10:31

Hi Allenelson..

That junk doesnt affect,if you want to do manual configuration.. i am doing i right now and its seems to be working fine. You can run the wizard, but avoid running IPMA wizard as it complicates troubleshooting...make sure everytime you make any change to CTI RP, restart it and restart IPMA service as well.Your calling search space should be assigned prpoerly..lemme knw if i can help in some way :)


This Discussion