BGP routing does not work on 7206vxr

Answered Question
May 8th, 2009

I need to move bgp router from 7609 to 7206.

7609 has IOS c6sup22-psv-mz.121-26.E4.bin

7206 has IOS c7200-ik9o3s-mz.123-17a.bin

config for 7609

interface Vlan15

ip address 2.0.5.0 255.255.255.252

!

!

interface Vlan195

ip address 5.9.0.1 255.255.255.192 secondary

ip address 2.6.5.1 255.255.255.0

no ip redirects

ip route-cache flow

ntp broadcast

!

interface Vlan708

ip address 5.2.5.4 255.255.255.252

!

router bgp 50

no synchronization

bgp router-id 5.9.0.1

bgp log-neighbor-changes

network 5.9.0.0

neighbor 2.0.5.9 remote-as 89

neighbor 2.0.5.9 weight 50

neighbor 2.0.5.9 route-map AddAS out

neighbor 2.0.5.9 filter-list 1 out

neighbor 4.4.8.7 remote-as 54

neighbor 4.4.8.7 ebgp-multihop 3

neighbor 4.4.8.7 weight 10

neighbor 4.4.8.7 route-map AddAS out

neighbor 4.4.8.7 filter-list 1 out

neighbor 5.2.5.3 remote-as 58

neighbor 5.2.5.3 weight 100

neighbor 5.2.5.3 filter-list 1 out

!

ip classless

ip route 4.4.8.7 255.255.255.255 2.6.5.5

ip as-path access-list 1 permit ^$

ip as-path access-list 1 deny .*

and config for 7206

interface GigabitEthernet0/1

no ip address

no ip mroute-cache

duplex auto

speed auto

media-type gbic

negotiation auto

ntp broadcast client

!

interface GigabitEthernet0/1.195

encapsulation dot1Q 195

ip address 2.6.5.1 255.255.255.0 secondary

ip address 5.9.0.1 255.255.255.192

no ip redirects

ntp broadcast

no snmp trap link-status

!

interface GigabitEthernet0/2

ip address 2.0.5.0 255.255.255.252

no ip mroute-cache

duplex auto

speed 100

media-type rj45

negotiation auto

ntp broadcast client

!

interface GigabitEthernet0/3

no ip address

no ip mroute-cache

duplex full

speed 100

media-type rj45

no negotiation auto

ntp broadcast client

!

interface GigabitEthernet0/3.708

encapsulation dot1Q 708

ip address 5.2.5.4 255.255.255.252

no snmp trap link-status

!

router bgp 50

no synchronization

bgp router-id 5.9.0.1

bgp log-neighbor-changes

network 5.9.0.0

neighbor 2.0.5.9 remote-as 89

neighbor 2.0.5.9 route-map AddAS out

neighbor 2.0.5.9 filter-list 1 out

neighbor 2.0.5.9 weight 50

neighbor 4.4.8.7 remote-as 54

neighbor 4.4.8.7 ebgp-multihop 3

neighbor 4.4.8.7 route-map AddAS out

neighbor 4.4.8.7 filter-list 1 out

neighbor 4.4.8.7 weight 10

neighbor 5.2.5.3 remote-as 58

neighbor 5.2.5.3 filter-list 1 out

neighbor 5.2.5.3 weight 100

no auto-summary

!

ip classless

ip route 4.4.8.7 255.255.255.255 2.6.5.5

!

ip as-path access-list 1 permit ^$

ip as-path access-list 1 deny .*

What I configured wrong on 7206?

BGP is up on 7206 and I can ping any host outside my network from this router. But routing does not work on it. I can't to ping any host from my network to outside.

Correct Answer by frosalia about 7 years 9 months ago

You have flip-flopped primary and secondary IP addresses on g0/1.195 (old vlan 195). This may be part of you problem. Can you post 'sh ip bgp s'?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Correct Answer
frosalia Fri, 05/08/2009 - 15:59

You have flip-flopped primary and secondary IP addresses on g0/1.195 (old vlan 195). This may be part of you problem. Can you post 'sh ip bgp s'?

bvictor@lynx.ru Fri, 05/08/2009 - 16:26

It flip-flopped primary and secondary IP addresses on g0/1.195 and vlan 195 is a result of my experiments on config.

7609

Atlas#show ip bgp summ

BGP router identifier 195.149.110.1, local AS number 29450

BGP table version is 606478, main routing table version 606478

288388 network entries and 851404 paths using 58624180 bytes of memory

152643 BGP path attribute entries using 9161040 bytes of memory

137919 BGP AS-PATH entries using 4079840 bytes of memory

2394 BGP community entries using 159778 bytes of memory

8 BGP extended community entries using 240 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

100334 BGP filter-list cache entries using 1204008 bytes of memory

BGP activity 289064/1661 prefixes, 854568/3164 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

92.50.195.169 4 12389 63080 264 606478 0 0 02:09:42 283260

194.84.128.127 4 2854 51670 137 606478 0 0 02:12:04 281053

195.182.135.93 4 6858 57935 135 606478 0 0 02:10:46 287090

bvictor@lynx.ru Fri, 05/08/2009 - 16:38

and for 7206

Styx#show ip bgp summ

BGP router identifier 195.149.110.1, local AS number 29450

BGP table version is 1575498, main routing table version 1575498

288439 network entries using 29132339 bytes of memory

851564 path entries using 40875072 bytes of memory

152670 BGP path attribute entries using 9160800 bytes of memory

137916 BGP AS-PATH entries using 4079556 bytes of memory

2391 BGP community entries using 159444 bytes of memory

8 BGP extended community entries using 240 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

120266 BGP filter-list cache entries using 1443192 bytes of memory

BGP using 84850643 total bytes of memory

BGP activity 577278/288839 prefixes, 1705370/853806 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

92.50.195.169 4 12389 111146 102 1575498 0 0 00:01:34 283320

194.84.128.127 4 2854 97856 58 1575498 0 0 00:03:18 281105

195.182.135.93 4 6858 111204 56 1575498 0 0 00:02:19 287139

bvictor@lynx.ru Fri, 05/08/2009 - 17:19

It was my error.

In config 7206 bgp

no auto-summary was wrong line.

Now it works fine with

auto-summary

Actions

This Discussion