Frame Relay Theory question...

Answered Question
May 8th, 2009
User Badges:
  • Silver, 250 points or more

I was trying to help out another poster on this fourm, and was blaming Packet Tracer. I plugged his configs into two 2600's, but still cant get it working. But get I mean to simply ping the local ints and also directly connected int. I change encap to hdlc, can ping, so I know its not a layer 1 issue.


Can you setup to routers to pass traffic over Frame-Relay w/o specifically assinging one of them as a frame-relay switching?


RtrA-------serial connection-------dce-RtrB


Router A:

interface Serial0/1

ip address 172.16.0.9 255.255.255.252

encapsulation frame-relay

no keepalive

frame-relay map ip 172.16.0.9 103

frame-relay map ip 172.16.0.10 103 broadcast

no frame-relay inverse-arp

!


Router B:

interface Serial0/0

ip address 172.16.0.10 255.255.255.252

encapsulation frame-relay

no keepalive

no fair-queue

clock rate 64000

frame-relay map ip 172.16.0.9 301 broadcast

frame-relay map ip 172.16.0.10 301

no frame-relay inverse-arp

end

!


I tried using debug for frame-relay but its not showing me awhole lot.

I can post more info necessary.


Thank you

Jimmy

Correct Answer by Giuseppe Larosa about 7 years 11 months ago

Hello Jimmy,

back to back FR can be done in two ways:


a)

disabling keepalives


b)

making one side FR DCE as explained by Paolo


in any case if there is a direct cable between the two routers the DLCI cannot change at the two ends!

There is no FR switch/device in the middle so the DLCI must be the same.


I've explained this also in the other thread.


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Fri, 05/08/2009 - 17:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

On side (customarily dce, but does not need to),configure frame-relay intf-type dce.

You can then re-enable keepalives.

jimmysands73_2 Fri, 05/08/2009 - 17:45
User Badges:
  • Silver, 250 points or more

Thank you for your response, tried both of them. Didnt help.....


R3(config-if)#frame-relay intf-type dce

Must enable frame-relay switching to configure DCE/NNI

R3(config-if)#


As far as the keepalives (both sides), when I did that, protocol went down.


R3(config-if)#keepalive

R3(config-if)#

*Mar 2 21:50:03.247: FR-ADJ: dlci 301: 172.16.0.10: removing adjacency

*Mar 2 21:50:03.247: FR-ADJ: dlci 301: 172.16.0.9: removing adjacency

*Mar 2 21:50:04.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

paolo bevilacqua Fri, 05/08/2009 - 17:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

As the router says, configure frame-realy switching first.


Correct Answer
Giuseppe Larosa Fri, 05/08/2009 - 21:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,

back to back FR can be done in two ways:


a)

disabling keepalives


b)

making one side FR DCE as explained by Paolo


in any case if there is a direct cable between the two routers the DLCI cannot change at the two ends!

There is no FR switch/device in the middle so the DLCI must be the same.


I've explained this also in the other thread.


Hope to help

Giuseppe


jimmysands73_2 Sat, 05/09/2009 - 09:18
User Badges:
  • Silver, 250 points or more

You are 110% correct. I took out frame-relay switching, removed the inft dce statement, map'd to the same DLCI's, and it worked....thank you.


I appreciate your posting on this topic and all the other ones you regularly contribute too.


Jimmy

Actions

This Discussion