OSPF

Unanswered Question
May 9th, 2009
User Badges:

I have a router with lots of virtual interfaces. When one of the interfaces goes down every ospf route in the route table has its lifetime reset to zero.


I thought only the changed routes should change not all of them, am I right?


What would cause the whole route table to be recalculated and how do I stop it?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
Harold Ritter Sat, 05/09/2009 - 15:23
User Badges:
  • Cisco Employee,

Dave,


OSPF is a link state protocol. All routers in a given area share the same information and if one link changes state, the SPF algorithm is ran on all routers and all routes for that area are reinstalled.


Regards

davegibelli Sun, 05/10/2009 - 01:04
User Badges:

It appears only LSA type 1 cause the SPF algorithm to run.


Therefore, if the virtual-interfaces were redistributed into ospf instead of relying on the network statement I think it will stop SPF from running...


We see 33,000 SPF's!

lamav Sun, 05/10/2009 - 07:01
User Badges:
  • Blue, 1500 points or more

Can you post the config?

davegibelli Sun, 05/10/2009 - 08:00
User Badges:

Hi


The config for ospf is shown below. We have two router with the same config but only one is resetting every ospf route!


I suspect either an IOS bug or a 'feature' that makes 12.4 incompatible with 12.3 as that is the only difference I can see between both routers.


router ospf 1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

network 10.144.224.0 0.0.31.255 area 0

network 10.105.0.0 0.0.31.255 area 0

default-information originate always

distribute-list 50 in

Laurent Aubert Sun, 05/10/2009 - 11:52
User Badges:
  • Cisco Employee,

Hi Dave,


Using the network statement makes your virtual-access interfaces seen as intra-area links and so are announced as LSA type-1 to all the routers of the area.


As Harold said, receiving LSA type-1 is a trigger to run SPF algo as it means something changed in the topology (links added or removed)


Virtual-access interfaces are by definition not permanent links so each time they are created or deleted a LSA type 1 will be generated and SPF will be scheduled.


Changing the network statement to a redistribute configuration will stop the SPF iteration but you will have a lot of LSA type 5 generated instead. You should use the summary-address cmd to create an aggregated route:


http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_osp3.html#wp1017123


HTH


Laurent.



lamav Sun, 05/10/2009 - 17:01
User Badges:
  • Blue, 1500 points or more

Hi, Dave:


As was stated by two experts already, each router in an area must have an identical copy of the link state database. This allows each router to map out the area and create a logical view of the area network topology. When all the databases are synchronized and identical, the SPF algorithim is run to establish the most efficient route to each destination.


The link state database is populated by the link state advertisements that each OSPF neighbor floods to its neighbor. When there are point to point links within an area, the advertisements are categorized as LSA type 1, aka Router Link LSA, and they are sent to each neighbor. In an environment where the neighbors interfaces all belong to a broadcast network, a DR and BDR are elected, and then you have type 2 LSAs being exnchanged between the DROther Routers and the DR and BDR. These are known as network LSAs.


Getting back to your issue, your virtual interfaces (I'm assuming they are SVI vlan interfaces) are default OSPF Broadcast interfaces, but you are not establishing an OSPF neighborship with the vlan interfaces in the HSRP group, so its network type is inconsequential in this case. All interfaces are "passived-out", except for the gigabit interfaces (and Im assuming they are point-to-point links), which are creating neighborships and exchanging type-1 Router LSAs with the neighbor router.


If one of the virtual links goes down, the local router's database will now be altered, and thereby prompting the router to send send an LSU, Link State Update, to inform the neighbor router, who will in turn flood his neighbors, and so on and so forth, until all databases are once again synchronized. Once that happens, the SPF algorithim will be run again and a new RIB table derived.


Can you tell me exactly which "show" commands you are running and the output of each that is troubling you?


HTH


Victor




martin.alexander Sun, 05/10/2009 - 23:17
User Badges:

Hi


David has been helping me with this issue.


The virtual interfaces are (UK adsl) pppoA virtual-access interfaces. Whenever a connection

drops (or comes up) all routes in the ospf DB recalculate, we do not see this issue on any other LNS or router.


show ip route ospf will display something like this


O E2 192.168.0.1/32

[110/20] via 10.10.10.129, 00:01:48, GigabitEthernet0/0

[110/20] via 10.10.10.97, 00:01:48, GigabitEthernet0/1


I have changed the ospf network statement to include just the loopback/gig interfaces but this has not helped.


If I bounce a connection on a 7206 running 12.3 it does not recalc the whole DB


show ip route ospf will give the below


O E2 192.168.1.1/29

[110/20] via 10.10.10.132, 1d11h, GigabitEthernet0/3.999

[110/20] via 10.10.10.102, 1d11h, GigabitEthernet0/1.999


Of course the new routes will have a short time but the rest are ok.



Thanks





Laurent Aubert Mon, 05/11/2009 - 06:45
User Badges:
  • Cisco Employee,

Hi Martin,


Are you sure on the other LNS, the IP unnumbered address is part of OSPF or just redistributed ?


Can you post the config of both LNS ?


Thanks


Laurent.

martin.alexander Mon, 05/11/2009 - 08:06
User Badges:

Hello


Working router (7206)


router ospf 1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface GigabitEthernet0/1.999

no passive-interface GigabitEthernet0/3.999

network 192.168.224.0 0.0.31.255 area 0

network 10.10.0.0 0.0.31.255 area 0

default-information originate always

distribute-list 50 in


lc7206#sh ip ospf

Routing Process "ospf 1" with ID 192.168.0.254

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

It is an autonomous system boundary router

Redistributing External Routes from,

connected, includes subnets in redistribution

static, includes subnets in redistribution

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 3182. Checksum Sum 0x6574033

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

External flood list length 0

Area BACKBONE(0)

Number of interfaces in this area is 1479 (5 loopback)

Area has no authentication

SPF algorithm last executed 1d19h ago

SPF algorithm executed 537 times

Area ranges are

Number of LSA 9. Checksum Sum 0x0483A3

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0



broken router (7201)


router ospf 1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

network 192.168.0.0 0.0.0.255 area 0

default-information originate always

distribute-list 50 in


tc7201#sh ip ospf

Routing Process "ospf 1" with ID 192.168.0.252

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

Supports area transit capability

It is an autonomous system boundary router

Redistributing External Routes from,

connected, includes subnets in redistribution

static, includes subnets in redistribution

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Incremental-SPF disabled

Minimum LSA interval 5 secs

Minimum LSA arrival 1000 msecs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 3185. Checksum Sum 0x659284A

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Number of areas transit capable is 0

External flood list length 1

Area BACKBONE(0)

Number of interfaces in this area is 730 (4 loopback)

Area has no authentication

SPF algorithm last executed 00:00:47.312 ago

SPF algorithm executed 34155 times

Area ranges are

Number of LSA 9. Checksum Sum 0x0483A3

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0



Actions

This Discussion