Cisco Unified Communications 7 call forwarding

Unanswered Question
May 9th, 2009
User Badges:

I am running Cisco Unity Business Edition 7. I am trying to forward a cti port to a outside long distance number. When I forward the number to a local number it goes through fine. My external mask is set to a number that is allowed to make long distance calls. This worked fine until the phone company changed how the long distance was being tracked. Before they had a ani number assigned to the whole pri. This caused problems as there are multiple tenents in this building all being required to pay for their own long distance. If I call from a internal extension to the forwarded number it works fine.


I think is where the problem is because the phone company doesn't have that number in their switch so they aren't allowing the long distance call to go through.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Sat, 05/09/2009 - 18:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

CTI ports are to be used with JTAPI apps for 1st hand control of integrations, not for FW


if you need something like that then use CTI RPs


if you need to send a special ANI then use a translation pattern to modify as necessary


HTH


java


if this helps, please rate

d-schuemann Sat, 05/09/2009 - 18:37
User Badges:

Can you give me a example of both ?


Just curious why does it work with local calls ?

chadlincoln Sat, 05/09/2009 - 18:41
User Badges:
  • Bronze, 100 points or more

A couple things to troubleshoot. Can a phone with the same CSS call that number?

Turn some debugs on the gateway and see if it is even hitting the gateway. If it is, from there see if you are receiving a reject message from the telco.


Please rate if this helps.

d-schuemann Sat, 05/09/2009 - 19:40
User Badges:

Well this is interesting. I enabled all these debug flags. debug voip ccapi inout, debug vpm all, an debug vtsp all. I don't see anything going through. Even calls that complete.

daviddunaway Tue, 07/21/2009 - 08:11
User Badges:

Do you have terminal monitor turned on?

you wont see any debugs unless you have it on.

Actions

This Discussion