OSPF Doubt

Unanswered Question
May 10th, 2009
User Badges:

Hi,


I have two 6509 Core switches in my Datacenter and is running HSRP between them.It has got a couple of Vlans and Vlan interfaces created on it.It also has OSPF created for the same Vlans on the CORE switch .Can somebody explain to me what is the need of this OSPF.Is this for the communication between the CORE Switches ?

Please advice.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mahmoodmkl Sun, 05/10/2009 - 01:05
User Badges:
  • Gold, 750 points or more

Hi


Do u have any L3 link between the core switches..?


if not i dnot think its of any use.


Thanks

Mahmood

antonyice1 Sun, 05/10/2009 - 01:33
User Badges:

What do you mean by that ? The Configuration is given below.Please verify.


vlan 311

name FWSM_ADM_OUT


vlan 312

name FWSM_ADM_IN


vlan 321

name FWSM_DC_OUT


vlan 322

name FWSM_DC_IN


interface Loopback0

ip address 172.10.250.1 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp


interface Port-channel1

description ++++ L2 Link to Core 2 ++++

switchport

switchport trunk encapsulation dot1q


interface Vlan300

description ++++ Connetced to NetScreen ++++

ip address 172.10.2.3 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

standby 3 ip 172.10.2.5

standby 3 timers 1 3

standby 3 priority 110

standby 3 preempt

standby 3 authentication md5 key-string 7 06350A22595C0C31362522

standby 3 name TIER1FW


interface Vlan311

description ++++ FWSM Admin Out Interface ++++

ip address 172.10.2.10 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

standby 1 ip 172.10.2.9

standby 1 timers 1 3

standby 1 priority 110

standby 1 authentication md5 key-string 7 03375E08131D24647D3B29

standby 1 name FWSMADMOUT

!

interface Vlan321

description ++++ FWSM DC OUT Interface ++++

ip address 172.10.2.18 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

standby 2 ip 172.10.2.17

standby 2 timers 1 3

standby 2 priority 110

standby 2 preempt

standby 2 authentication md5 key-string 7 0538030C345E4B212A3727

standby 2 name FWSMDCOUT



router ospf 1

router-id 172.10.250.1

log-adjacency-changes

auto-cost reference-bandwidth 100000

network 172.10.2.10 0.0.0.0 area 0

network 172.10.2.18 0.0.0.0 area 0

network 172.10.250.1 0.0.0.0 area 0

Giuseppe Larosa Sun, 05/10/2009 - 03:31
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Antony,

from your configuration OSPF is used at least to exchange routing information about each switch's loopback ip address.


>> network 172.10.250.1 0.0.0.0 area 0



Hope to help

Giuseppe



iyde Sun, 05/10/2009 - 04:09
User Badges:
  • Silver, 250 points or more

Also, as the two other network statements are from the two VLANs going to the FWSM, it's a possibility that you exchange routing informations with the FWSM. This of course only if OSPF is configured on the FWSM as well.

HTH

antonyice1 Mon, 05/11/2009 - 02:33
User Badges:

No , OSPF is not configured on the FWSM .My doubt is something like this what will happen if OSPF was not configured since I could see lot of static routes on the CORE Switch.


Thanks for you advice.

Actions

This Discussion