Damaged Firmware on WRV210

Unanswered Question
May 10th, 2009


I purchased two linksys wrv210 routers and the firmware seems to be damaged. The dhcp server for the router is not working and even if i configure a static ip address on my notebook. I still can access the router via the web interface. I have already tried to reset the router to its default settings via the reset button but that proved to be useless. Can the firmware be reloaded via tftp? If not can you please advise me how to get around this problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Te-Kai Liu Sun, 05/10/2009 - 15:38

Yes, TFTP based firmware recovery is supported on WRV210. Check out the instructions in the product's user guide.

Te-Kai Liu Mon, 05/11/2009 - 08:30

Here is a snippet.

The firmware upgrade failed (the DMZ LED is lit solid green after the power is turned off and then on again).

If the Web-based utility’s firmware upgrade mechanism should fail, the Router will be non-functional. At this time, you can use the Router’s TFTP-based firmware upgrade mechanism to upload the new firmware (.img file) to the router. However, you first need to assign a static IP address to the PC that is hosting the TFTP client, in the subnet and with subnet mask, e.g.,


The following is the command that is entered into a Windows Command Line to upgrade the firmware using the Windows built-in TFTP client.

tftp -i put WRV210firmware.img

miguellam Wed, 02/03/2010 - 21:36

Hi, i tryed like you said, bur it does not work , i think because the WRV210 need a kind of authentication before TFTP.

I downloaded a cisco tftp aplication specific for another router, and yes, it ask me a router IP and password.but I did not found a aplication for wrv210

Te-Kai Liu Wed, 02/03/2010 - 21:44

If the DMZ LED is blinking, you can simply enter the following command in a Windows command line to push firmware into WRV210.

tftp -i put WRV210firmware.img

There is no authentication required. You do need to configure your PC to use Static IP in the same subnet as WRV210, which uses when its firmware is damaged.

miguellam Sat, 02/06/2010 - 21:28

Thanks, my mistake was the DMZ, after that, it take me 6 seconds.

very nice support. thanks again

byteplussystems... Fri, 02/11/2011 - 02:43

Please i have a similar problem. I can't get access to the Router thru the web-base feature. it assigns IPs alright but can't configure the router becos after login it comes with blank webpage. I tried tftp although my DMZ LED is totally off, i wasn't successful. Can i get help?



This Discussion