Cisco 2811 PVDM 32

Answered Question
May 11th, 2009
User Badges:

Hi guys

I am currently trying to configure a 2811 with a PVDM2-36DM and a HWIC-1CE1T1-PRI to allow remote users to dial in using both ISDN and pstn modem access. Is this possible using this combination of WICS?



Correct Answer by paolo bevilacqua about 8 years 2 weeks ago

You do not have "ppp authentication eap" in dialer like you do in group-async.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Mon, 05/11/2009 - 07:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, it should be possible.

ultra-datel Mon, 05/11/2009 - 07:53
User Badges:

this is the config we are running. we can dial a Windows XP machine in using PSTN no problem, however ISDN will authenticate the link, and then can't negotiate a PPP link

this is the config we are applying

version 12.4


no service pad


service tcp-keepalives-in


service tcp-keepalives-out


service timestamps debug datetime msec


service timestamps log datetime msec show-timezone


service password-encryption


!


hostname xxx


!


boot-start-marker


boot-end-marker


!


card type e1 0 0


logging buffered 4096 informational


enable secret xxxxxx


!


aaa new-model


!


!


aaa authentication login default local


aaa authentication login console local


aaa authentication ppp default group radius


!


!


aaa session-id common


clock timezone GMT 0


clock summer-time GMT recurring


network-clock-participate wic 0


network-clock-select 1 E1 0/0/0


!


modem call-record terse


modem country v12 e1-default


modem recovery threshold 10


no ip source-route


!


!


ip cef


no ip dhcp use vrf connected


ip dhcp bootp ignore


!


ip dhcp pool dialinusers


network xxxxx xxxxxx


default-router xxxxx


dns-server xxxxxxx xxxx


!


!


no ip domain lookup


multilink bundle-name authenticated


isdn switch-type primary-net5


isdn voice-call-failure 0


!


!


!


!


!


username xxxxxx password xxxxxx


archive


log config


logging enable


logging size 200


hidekeys


path flash:archeived-config


maximum 14


write-memory


time-period 1440


!


!


controller E1 0/0/0


pri-group timeslots 1-31


!


!


!


!


interface FastEthernet0/0


description "xxxxxx"


ip address xxxx xxxxxx



no ip redirects


duplex auto


speed auto


no cdp enable


!


interface FastEthernet0/1


description "xxxxxx"


ip address xxxxx xxxxxx



no ip redirects


duplex auto


speed auto


no cdp enable


!


interface Serial0/0/0:15


description "D Channel interface for the Primary Rate ISDN"


no ip address


encapsulation ppp


ip mroute-cache


dialer rotary-group 1


dialer-group 1


isdn switch-type primary-net5


isdn incoming-voice modem


no fair-queue


no cdp enable


!


interface Dialer1


no ip address


encapsulation ppp


dialer in-band


dialer idle-timeout 2147482


dialer-group 1


no peer default ip address


no fair-queue


no cdp enable


ppp multilink


!


interface Group-Async1


description "Global Interface for PRI Dial-In Connections"


ip unnumbered FastEthernet0/0


encapsulation ppp


dialer in-band


dialer idle-timeout 0


async mode interactive


peer default ip address dhcp-pool dialinusers


no fair-queue


ppp authentication eap


no ppp chap wait


ppp multilink


group-range 0/386 0/421


!


ip route xxxx xxxx FastEthernet0/0


ip route 1xxxx xxxx FastEthernet0/0


ip route 1xxx xxx FastEthernet0/1


!


!


no ip http server


no ip http secure-server


!


dialer-list 1 protocol ip permit


no cdp run


!


radius-server host xxxxx auth-port 1645 acct-port 1646


radius-server timeout 10


radius-server key xxxxxx


!


control-plane

line con 0

login authentication local

line aux 0

exec-timeout 0 1

no exec

transport output none

line 0/386 0/421

login authentication console

modem Dialin

modem autoconfigure discovery

rotary 1

terminal-type length

transport input all

autoselect during-login

autoselect ppp

line vty 0 4

exec-timeout 0 1

no exec

transport input none

transport output none

scheduler allocate 20000 1000

many thanks in advance

paolo bevilacqua Mon, 05/11/2009 - 08:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Does "debug ppp neg" shows anything ?

ultra-datel Mon, 05/11/2009 - 08:49
User Badges:

ay 11 16:44:14.251: Se0/0/0:0 LCP: MagicNumber 0x6F205023 (0x05066F205023)

*May 11 16:44:14.251: Se0/0/0:0 LCP: PFC (0x0702)

*May 11 16:44:14.251: Se0/0/0:0 LCP: ACFC (0x0802)

*May 11 16:44:15.175: Se0/0/0:0 LCP: I CONFREJ [ACKsent] id 52 len 17

*May 11 16:44:15.175: Se0/0/0:0 LCP: MRRU 1524 (0x110405F4)

*May 11 16:44:15.175: Se0/0/0:0 LCP: EndpointDisc 1 ras001 (0x130901726173303031)

*May 11 16:44:15.175: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 53 len 10

*May 11 16:44:15.175: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:16.099: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 53 len 8

*May 11 16:44:16.099: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:16.099: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 54 len 10

*May 11 16:44:16.099: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:17.019: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 54 len 8

*May 11 16:44:17.019: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:17.019: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 55 len 10

*May 11 16:44:17.019: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:17.939: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 55 len 8

*May 11 16:44:17.939: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:17.939: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 56 len 10

*May 11 16:44:17.939: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:18.863: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 56 len 8

*May 11 16:44:18.863: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:18.863: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 57 len 10

*May 11 16:44:18.863: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:19.047 UTC: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected to N/A N/A

*May 11 16:44:19.783: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 57 len 8

*May 11 16:44:19.783: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:19.783: Se0/0/0:0 LCP: O

ultra-datel Mon, 05/11/2009 - 08:49
User Badges:

followed by

CONFREQ [ACKsent] id 58 len 10

*May 11 16:44:19.783: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:20.703: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 58 len 8

*May 11 16:44:20.703: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:20.703: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 59 len 10

*May 11 16:44:20.703: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:21.623: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 59 len 8

*May 11 16:44:21.623: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:21.623: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 60 len 10

*May 11 16:44:21.627: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:22.547: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 60 len 8

*May 11 16:44:22.547: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:22.547: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 61 len 10

*May 11 16:44:22.547: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:23.467: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 61 len 8

*May 11 16:44:23.467: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:23.467: Se0/0/0:0 LCP: O CONFREQ [ACKsent] id 62 len 10

*May 11 16:44:23.467: Se0/0/0:0 LCP: MagicNumber 0x24583098 (0x050624583098)

*May 11 16:44:24.387: Se0/0/0:0 LCP: I CONFNAK [ACKsent] id 62 len 8

*May 11 16:44:24.387: Se0/0/0:0 LCP: AuthProto EAP (0x0304C227)

*May 11 16:44:24.387: Se0/0/0:0 LCP: Failed to negotiate with peer

*May 11 16:44:24.387: Se0/0/0:0 PPP: Sending Acct Event[Down] id[11]

*May 11 16:44:24.391: Se0/0/0:0 LCP: O TERMREQ [ACKsent] id 63 len 4

*May 11 16:44:24.391: Se0/0/0:0 PPP: Phase is TERMINATING

*May 11 16:44:25.307: Se0/0/0:0 LCP: I TERMACK [TERMsent] id 63 len 4

*May 11 16:44:25.311: Se0/0/0:0 LCP: State is Closed

*May 11 16:44:25.311: Se0/0/0:0 PPP: Phase is DOWN

*May 11 16:44:25.311: Se0/0/0:0 PPP: Phase is ESTABLISHING, Passive Open

*May 11 16:44:25.311: Se0/0/0:0 LCP: State is Listen

*May 11 16:44:25.311 UTC: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0 disconnected from unknown , call lasted 12 seconds

*May 11 16:44:25.315: Se0/0/0:0 LCP: I TERMREQ [Listen] id 1 len 16 (0x6F205023003CCD74000002DE)

*May 11 16:44:25.319: Se0/0/0:0 LCP: O TERMACK [Listen] id 1 len 4

*May 11 16:44:25.507 UTC: %LINK-3-UPDOWN: Interface Serial0/0/0:0, changed state to down

*May 11 16:44:25.507: Se0/0/0:0 LCP: State is Closed

*May 11 16:44:25.507: Se0/0/0:0 PPP: Phase is DOWN

Correct Answer
paolo bevilacqua Mon, 05/11/2009 - 09:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You do not have "ppp authentication eap" in dialer like you do in group-async.

ultra-datel Tue, 05/12/2009 - 00:20
User Badges:

many thanks worked a treat. must be going blind staring at configs

paolo bevilacqua Tue, 05/12/2009 - 08:12
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

It's called configuration blindness, and it's very common among engineers.


Thanks for the nice rating, and good luck!

Actions

This Discussion