SIP Trunk Tone On Hold

Unanswered Question
May 11th, 2009

CUCM Version: 6.1(3b)sr1

CUBE IOS Version: 12.3(20)T2

I am trying to configure Tone On Hold (ToH) on a SIP trunk. The initial objective was to disable MoH completely on the system and enable ToH to play a single audio tone when a call is placed on hold.

For SCCP devices this can be achieved with the Tone On Hold timer (value set to 0). All is well on Phone-to-Phone sessions as expected. Of course, this parameter does nothing for H.323 or SIP.

So, I have seen various "work arounds" on this forum. I have implemented one of these work arounds and it is functional. However, I would like to use something where I do not have to re-enable servers I simply don't want to run (i.e. Music on Hold).

In other words, I want a parameter (either in CUCM or on my voice gateway) that I can say "no moh" (or something similar).

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Bell Wed, 01/06/2010 - 09:53


The workaround we wound up applying follows:

1. Enable g729 as supported codec under "IP Voice Media Streaming Application" (this may be optional, depends on your specific scenario.  We had to add this step to get it to work as desired)

2. Configure "SampleSource" as a multicast capable audio source (any source will do, but we wanted to disable MoH for the network hold)

3. Configure one of the MoH servers:

- Run Flag: yes

- Enable MoH

- Restart MoH server

4. Configure a MRG for multicast and add the MoH server configured above

5. Put multicast MRG as the only MoH resource in the SIP gateway MRGL

6. Reset/Restart SIP gateway (from CUCM)

Essentially, we were trying to disable MoH.  To do this we had to enable MoH and use a configuration that is "broken".  In our case, multicast was not enabled on the network.  CUCM doesn't know this and would happily stream audio to the multicast address.  Since the multicast packets didn't traverse the network to the voice gateway the held party on the carrier side of the gateway never hears audio.  So, silence == MoH disabled.

If you have multicast enabled on the network then you may need to add an ACL blocking the multicast group.

The other option I have seen people promote is creating a silent MoH file and streaming that.  Harkens back to CM 3.x days.

Anyway, not really intuitive or graceful but it worked and I haven't gone back to the well recently to see if there is a more efficient method.

Thanks and regards,



This Discussion