Reccomended QOS for WAN Links with VOIP and Analog Devices

Unanswered Question
May 11th, 2009

Hi all I have a two sites that are connected via a 100Mb metro E link. Each site has about 40 Cisco VOIP phones with about 5 Fax machines at each location. I keep getting compalints about Faxs dropping on a regular basis. I deployed the access switchs via auto QOS however I relized that I dont have QOS on the gig interfaces connceting the two sites as well as the uplink gig interfaces for the access switches. I'm by no means a QOS expert so I was wondering if anyone has suggestions for a basic QOS class map and policy map that works. I obviously want to keep voice call quality but allow the faxs some higher priority. I've attached a quick drawing that explains the site.


Any help is apperciated,


thanks,


Mike



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
carbonscoring Mon, 05/11/2009 - 20:03

Hi Here is the show controllers t1 command:


East2821#sh controllers t1

T1 0/1/0 is up.

Applique type is Channelized T1

Cablelength is long 0db

Description: Timewarner PRI

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20071011, FPGA: 13, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (761 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 22 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs



thanks,

Mike

ivarnhagen Tue, 05/12/2009 - 05:16

Hi,


Try setting the faxes to send/recv rate 9600 baud and turn ECM (Error Correction Mode) off. This helped me in some cases.


hth

carbonscoring Tue, 05/12/2009 - 09:37

Thanks for the suggestion unfortunately I've already implemented these changes some time ago. I did see some success afterwards however, still having problems with dropped fax's.


thanks,

Mike

Vince.Whirlwind Tue, 05/12/2009 - 17:23

If you're relying on AutoQoS, you may not be prioritising the fax IP traffic.

You want to identify fax traffic and mark it high priority.

You can do it based on the known IP addresses of the fax machines:

ip access-list extended fax.traffic

permit ip host 10.1.2.3 any

class-map match-all fax

match access-group name fax.traffic

policy-map Assign.DSCP

class fax

set dscp EF

And then on your switch interface:

service-policy input Assign.DSCP

Actions

This Discussion