LMS 2.2 -> 2.5

Unanswered Question
May 11th, 2009
User Badges:

G'day mates.


Hopefully you could give me some advise. I am at a customer who had LMS 2.5 installed and the server died. No-one could find the media until recently. This is all on Solaris.


My problem is that the OS is 2.9 (which is required for LMS2.5) and when installing LMS 2.2, I get heaps of errors like web server cannot be started etc, because LMS 2.2 expects 2.8.


My question is this: Can I do a full install of LMS 2.5 and upload full license if LMS 2.2 AND upgrade license of LMS 2.5? Will this actually work?


Hope this not too confusing?


Output:

=================================================================

Finished: Tue May 12 15:44:38 EST 2009

=================================================================

===============- Software Installation Tool Completed -==============

=================================================================

===================- Possible Warnings/Errors Encountered -===================

ERROR: unregister daemons "JRunProxyServer" failed. :Connection refused

WARNING: OS Version 5.9 not supported.

WARNING: Results not guaranteed if installed on this version.

WARNING: at group permissions needed for casuser.

WARNING: Set at for casuser in /etc/cron.d/at.allow Or

WARNING: Unset at for casuser in /etc/cron.d/at.deny.

WARNING: cron group permissions needed for casuser.

WARNING: Set cron for casuser in /etc/cron.d/cron.allow Or

WARNING: Unset cron for casuser in /etc/cron.d/cron.deny.

WARNING: the syslog server is not listening on udp/514 for messages.

WARNING: now checking for an existing syslogd process...

WARNING: Not a recommended computer model. Please refer to the

WARNING: prerequisites chapter of the install guide.

ERROR: /opt/CSCOpx/setup/CSCOmd.info not found.

ERROR: GetProperty called with undefined package name: CSCOmd.

ERROR: /opt/CSCOpx/setup/CSCOmd.info not found.

ERROR: GetProperty called with undefined package name: CSCOmd.

installf: ERROR: invalid number of arguments for </opt/CSCOpx/objects/web/logs>

installf: ERROR: ftype <d> requires all fields to be specified

ERROR: Configuration of the WebServer was not sucessful.

installf: ERROR: invalid number of arguments for </opt/CSCOpx/www/classpath/com/cisco/nm/cvw/devpkgs>

installf: ERROR: ftype <d> requires all fields to be specified

ERROR: unregister daemons "JRunProxyServer" failed. :Connection refused

ERROR:save failed Add failed, record already exists., Error 0

=====================================================================

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
yjdabear Tue, 05/12/2009 - 06:12
User Badges:
  • Gold, 750 points or more

LMS 2.5 is supported on both Solaris 2.8 and 2.9:

http://www.cisco.com/en/US/prod/collateral/netmgtsw/ps6504/ps6528/ps2425/prod_bulletin0900aecd8021cd16.html


So the real problem as you've found out is LMS 2.2 has trouble on Sol 2.9, because it's not supported there.


Since LMS 2.2 has no license file to speak of, you plan should work, assuming your server runs Sol 2.8 rather than 2.9: Install LMS 2.2, upgrade to 2.5, input 2.5 license.


BTW, you may want to consider upgrading LMS 2.5 to 2.6, as the latter is much less buggy.

pieterddejong Tue, 05/12/2009 - 15:37
User Badges:

Hi yjdabear,


Thanks for the reply! Really appreciate it! You are correct except that I have 2.9 running currently. So instead of rebuilding the server(will take server team weeks to action the request), I just want to install 2.5 and install 2.5 upgrade licenses. Is that possible?

yjdabear Tue, 05/12/2009 - 17:55
User Badges:
  • Gold, 750 points or more

I believe so, just have have the LMS 2.2 install media (CDONE) handy, because when applying the 2.5 *upgrade* license, LMS will prompt you to insert the 2.2 disc for validation. Alternatively, to save yourself a trip to the server room :), you could satisfy the validation with an ISO image of the 2.2 disc, as discussed in this old thread:


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&topicID=.ee71a02&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddcbd1f

pieterddejong Tue, 05/12/2009 - 19:30
User Badges:

Hi yjdabear,


Thank you for your clear explanations. I uninstalled 2.2 and installed 2.5. I have created .iso's for the discs and have them ready. I just have 2 issue that are now in my way if you don't mind?


1. Cannot contact the cmf database due to username and password issues (attached)

2. When trying to validate the upgrade license, I get errors. (attached)


Have you come across these by any chance?


TIA


Pieter



Attachment: 
yjdabear Wed, 05/13/2009 - 07:11
User Badges:
  • Gold, 750 points or more

For 1, let me suggest a bit of a detour first. Choose either one of the two:


1.1: Uninstall LMS 2.5, reinstall 2.5, apply the 2.5.1 and 2.6 updates, regardless of selftest results.*


1.2: Keep the existing LMS 2.5 that fails selftest, apply the 2.5.1 and 2.6 updates on top of the current 2.5.*


* LMS 2.5.1 could possibly be skipped, in which case install 2.6 on top of 2.5 directly. The updates can be downloaded from here:

http://www.cisco.com/cgi-bin/tablebuild.pl/lms251

http://www.cisco.com/cgi-bin/tablebuild.pl/lms26


Whichever course you pick, to address the failed selftest, try the following steps:


- Shut down dmgtd.

/etc/init.d/dmgtd stop


- Delete /opt/CSCOpx/databases/cmf/cmf.log, if it exists.


- Then

# csh

# setenv LD_LIBRARY_PATH /opt/CSCOpx/lib:/opt/CSCOpx/objects/db/lib

# setenv ASANY /opt/CSCOpx/objects/db

# /opt/CSCOpx/objects/db/bin/dbsrv9 -f /opt/CSCOpx/databases/cmf/cmf.db


- Now restart dmgtd.

/etc/init.d/dmgtd start



2. The issue of "./validateupgrade ld.so.1: validateupgrade: fatal: libstdc++.so.3: open failed: No such file or directory Killed" can be addressed by setting an env variable first:


env LD_LIBRARY_PATH=/opt/CSCOpx/MDC/lib:/opt/CSCOpx/lib /opt/CSCOpx/bin/validateupgrade



according to this post:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.2cc19f43/0#selected_message


Secondly, I misspoke earlier. The LMS 2.5 validateupgrade will ask for the "RME 3.5" disc of LMS 2.2, rather than CDONE (Common Services).

pieterddejong Wed, 05/13/2009 - 22:16
User Badges:

Thank you yjdabear!


I followed your instruction on item 1 but afterwards I could not browse to the webpages. Came back with no authorisation issues. I uninstalled CS's and reinstalled and everything is working perfectly!


I will install 2.5, and then 2.5.1. I will also follow your advise on item 2 and provide an update.


Once more, thanks for the great advise!

pieterddejong Thu, 05/14/2009 - 22:21
User Badges:

And we have liftoff!! This can be done via lofiadm also. Below is the output.


Thanks again for your help mate!!


Pieter


bash-2.05# env LD_LIBRARY_PATH=/opt/CSCOpx/MDC/lib:/opt/CSCOpx/lib /opt/CSCOpx/bin/validateupgrade


This utility will validate your proof of purchase of the product and allow you to obtain an upgrade license.

Please enter the CiscoWorks product for the proof of purchase validation (such as LMS, ITEM, VMS):LMS


Please select the source for upgrade validation from the following


1. Validate from a CD (older version of RME).

2. Validate from a remote server (where older version of RME is installed).


Please enter 1 to upgrade from a CD; enter 2 to upgrade from a remote server [1 / 2] :1


Please insert the previous versions of RME CD into the CDROM drive

and provide the absolute path to the CD drive: /mnt/disk1


Validation succeeded.

Actions

This Discussion