Configuring IPM to measure HTTP performance

Answered Question
May 12th, 2009
User Badges:

I currently use IPM 2.6. I configured HTTP performance from a remote router to a local server. I got "Data Response Error..." when I view statistics. Do I need to add local server to the target group along with SNMP string? Thank you in advance.

Correct Answer by Joe Clarke about 8 years 2 weeks ago

Good.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 05/12/2009 - 09:42
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

No. Just make sure that if you've added a hostname for your HTTP server that the router is configured to be able to resolve hostnames to IP addresses.

santipongv Tue, 05/12/2009 - 10:05
User Badges:

I added host name with its IP address to the source router configuration and am still getting "Data Response Error @ . Please kindly advise. Thank you.

Joe Clarke Tue, 05/12/2009 - 10:07
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of code is running on your source router?

Joe Clarke Tue, 05/12/2009 - 10:24
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of show rtr configuration and show rtr coll.

santipongv Tue, 05/12/2009 - 10:29
User Badges:

6509#sh rtr configuration

Complete Configuration Table (includes defaults)

Entry Number: 7077

Owner: 161|ipm-ciscoworks2-vorabhas

Tag: 6509 to Cha

Type of Operation to Perform: http

Reaction and History Threshold (milliseconds): 5000

Operation Frequency (seconds): 60

Operation Timeout (milliseconds): 5000

Verify Data: FALSE

Status of Entry (SNMP RowStatus): active

Protocol Type: httpAppl

Target Address:

Source Address: 0.0.0.0

Target Port: 0

Source Port: 0

Request Size (ARR data portion): 1

Response Size (ARR data portion): 1

Control Packets: enabled

Loose Source Routing: disabled

LSR Path:

Type of Service Parameters: 0x0

HTTP Operation: get

HTTP Server Version: 1.0

URL: http://chantilly-rt/cgi-bin/routers2.cgi

Proxy:

Raw String(s):






Cache Control: disabled

Life (seconds): infinite - runs forever

Next Scheduled Start Time: Start Time already passed

Entry Ageout (seconds): 3600

Connection Loss Reaction Enabled: FALSE

Timeout Reaction Enabled: FALSE

Threshold Reaction Type: immediate

Threshold Falling (milliseconds): 3000

Threshold Count: 5

Threshold Count2: 5

Reaction Type: trapAndNmvt

Verify Error Reaction Enabled: FALSE

Number of Statistic Hours kept: 2

Number of Statistic Paths kept: 1

Number of Statistic Hops kept: 1

Number of Statistic Distribution Buckets kept: 1

Statistic Distribution Interval (milliseconds): 20

Number of History Lives kept: 0

Number of History Buckets kept: 15

Number of History Samples kept: 1

History Filter Type: none





6509#sh rtr collection-statistics

Collected Statistics


Entry Number: 7077

HTTP URL: http://chantilly-rt/cgi-bin/routers2.cgi

Start Time: 13:18:27.000 EDT Tue May 12 2009


Comps: 0 RTTMin: 0

OvrTh: 0 RTTMax: 0

DNSTimeOut: 0 RTTSum: 0

TCPTimeOut: 0 RTTSum2: 0

TraTimeOut: 0 DNSRTT: 0

DNSError: 0 TCPConRTT: 0

HTTPError: 0 TransRTT: 0

IntError: 60 MesgSize: 0

Busies: 0



Entry Number: 7077

HTTP URL: http://chantilly-rt/cgi-bin/routers2.cgi

Start Time: 14:18:27.000 EDT Tue May 12 2009


Comps: 0 RTTMin: 0

OvrTh: 0 RTTMax: 0

DNSTimeOut: 0 RTTSum: 0

TCPTimeOut: 0 RTTSum2: 0

TraTimeOut: 0 DNSRTT: 0

DNSError: 0 TCPConRTT: 0

HTTPError: 0 TransRTT: 0

IntError: 10 MesgSize: 0

Busies: 0

Joe Clarke Tue, 05/12/2009 - 10:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You're still using a hostname for the URL. From this switch, can you run:


telnet chantilly-rt 80


And get a successful connection?

santipongv Tue, 05/12/2009 - 10:33
User Badges:

6509#telnet chantilly-rt 80

% telnet connections not permitted from this terminal


6509#telnet 192.168.4.35 80

% telnet connections not permitted from this terminal


6509#

ip host chantilly-rt 192.168.4.35

Joe Clarke Tue, 05/12/2009 - 10:37
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Try removing the collector from the device, then re-add it (i.e. delete the collector through IPM then recreate it). Also, make sure that this URL returns a proper result code. You can check this from another host:


telnet chantilly-rt 80

GET /cgi-bin/routers2.cgi HTTP/1.0

(Then hit enter twice)


You should get a proper HTTP response.

Joe Clarke Tue, 05/12/2009 - 10:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Do you mean you're waiting to see what happens, or you're seeing the same problem?

santipongv Tue, 05/12/2009 - 10:52
User Badges:

After I changed URL lookup string to server IP address, the error went away and I got 100% successful attempt (2 out of 2).

Correct Answer
Joe Clarke Tue, 05/12/2009 - 10:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Good.

Joe Clarke Tue, 05/12/2009 - 11:05
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes. The HTTP report is generated daily.

Actions

This Discussion