Accessing Windows File shares through NAT

Unanswered Question
May 12th, 2009

I have a router between two networks(192.168.1.x/24 and 10.208.16.x/24). A server on the 192.168.1.x network has file shares that I would like to be able to access from hosts on the 10.208.16.x network. I have a static NAT translation of 192.168.1.10(inside) to 10.208.16.10(outside). How do I make this work? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 05/12/2009 - 09:00

Sonny

Not sure i understand what your issue is.

Do you have an acl between the 2 networks ? If not then you should be able to access them anyway. You would need to use the Natted address.

Jon

spfeffer Tue, 05/12/2009 - 10:44

Basically, we need the hosts on the 10.anything network to be able to access the windows file shares on the customer network via the 10.208.16.10 NATted address. Any idea on what I'm doing wrong?

Here are the pertinent parts of the config...

interface FastEthernet0/0

description ***Uplink to Customer Network***

ip address 192.168.1.253 255.255.255.0

ip nat inside

duplex auto

speed auto

interface Serial0/3/0

ip address 10.201.11.170 255.255.255.252

ip nat outside

no fair-queue

!

interface Vlan1

ip address 10.208.16.254 255.255.255.0

ip nat outside

ip nat inside source list 111 interface Serial0/3/0 overload

ip nat inside source static 192.168.1.10 10.208.16.10

access-list 111 deny ip host 192.168.1.10 any

access-list 111 permit tcp 192.168.1.0 0.0.0.255 host 10.1.1.88 eq 3389

access-list 111 permit icmp 192.168.1.0 0.0.0.255 any

This is what the NAT Translation table looks like BEFORE trying to access the file share on the host 192.168.1.10 via the 10.208.16.10 NATted address:

Pro Inside global Inside local Outside local Outside global

--- 10.208.16.10 192.168.1.10 --- ---

This is what the NAT Translations look like while TRYING to access the file share on the host 192.168.1.10 via the 10.208.16.10 NATted address:

Pro Inside global Inside local Outside local Outside global

udp 10.208.16.10:137 192.168.1.10:137 10.208.16.102:137 10.208.16.102:137

tcp 10.208.16.10:139 192.168.1.10:139 10.208.16.102:56666 10.208.16.102:56666

tcp 10.208.16.10:445 192.168.1.10:445 10.208.16.102:56665 10.208.16.102:56665

--- 10.208.16.10 192.168.1.10 --- ---

Actions

This Discussion