cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
558
Views
0
Helpful
3
Replies

Routing Issue (MP-BGP-MPLS) ?

francisco_1
Level 7
Level 7

I have 3 routers, PE1 -- P --- PE2

MPLS LDP is setup between all 3 routers. MP-BGP is setup between PE/PE2. The problem is i cannot ping any interfaces in RNS/Smart-Cluster between PE1/PE2!!!

Any Ideas?

PE 1

ip vrf RNS

rd 200:200

route-target export 200:200

route-target import 200:200

!

ip vrf Smart-Cluster

rd 100:100

route-target export 100:100

route-target import 100:100

!

no ip domain-lookup

vtp domain none

vtp mode transparent

mls ip slb purge global

no mls acl tcam share-global

mls netflow interface

no mls flow ip

no mls flow ipv6

mls cef error action freeze

mpls ldp holdtime 15

mpls ldp advertise-labels for LDPInterface

mpls label protocol ldp

vlan 60

name Smart-Cluters

!

vlan 61

name RNS

interface Loopback0

description MPLS LDP Interface

ip address 172.18.254.3 255.255.255.0

!

interface Loopback1

description OSPF Router ID

ip address 172.17.254.3 255.255.255.0

!

interface Loopback102

ip vrf forwarding RNS

ip address 192.168.102.1 255.255.255.0

!

interface Vlan60

ip vrf forwarding Smart-Cluster

ip address 192.168.60.10 255.255.255.0

!

interface Vlan61

ip vrf forwarding RNS

ip address 192.168.61.10 255.255.255.0

!

!

router ospf 1

router-id 172.17.254.3

log-adjacency-changes

passive-interface default

no passive-interface GigabitEthernet6/2

network 172.17.254.3 0.0.0.0 area 0

network 172.18.254.3 0.0.0.0 area 0

network 192.168.2.2 0.0.0.0 area 0

network 192.168.254.0 0.0.0.255 area 0

!

router ospf 4 vrf Smart-Cluster

log-adjacency-changes

redistribute bgp 1 subnets

network 192.168.60.0 0.0.0.255 area 4

!

router ospf 3 vrf RNS

log-adjacency-changes

redistribute bgp 1 subnets

network 192.168.61.0 0.0.0.255 area 3

network 192.168.102.1 0.0.0.0 area 3

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 172.17.254.2 remote-as 1

neighbor 172.17.254.2 update-source Loopback1

no auto-summary

!

address-family vpnv4

neighbor 172.17.254.2 activate

neighbor 172.17.254.2 send-community both

exit-address-family

!

address-family ipv4 vrf Smart-Cluster

redistribute ospf 4 vrf Smart-Cluster match internal

no synchronization

exit-address-family

!

address-family ipv4 vrf RNS

no synchronization

exit-address-family

!

ip classless

!

!

no ip http server

no ip http secure-server

!

ip access-list standard LDPInterface

permit 172.18.254.0 0.0.0.255 log

!

!

!

!

!

mpls ldp router-id Loopback0

3 Replies 3

francisco_1
Level 7
Level 7

PE2

PE 2

ip vrf RNS

rd 200:200

route-target export 200:200

route-target import 200:200

!

ip vrf Smart-Cluster

rd 100:100

route-target export 100:100

route-target import 100:100

!

no ip domain-lookup

vtp domain SW-ESB2TSRD43

vtp mode transparent

mls netflow interface

no mls flow ip

no mls flow ipv6

mls cef error action reset

mpls ldp holdtime 15

mpls ldp advertise-labels for LDPInterface

mpls label protocol ldp

!

!

Vlan 60

name Smart-Clusters

!

vlan 61

name OSPF-Nei-Adj

!

!

interface Loopback0

description MPLS LDP Interface

ip address 172.18.254.2 255.255.255.0

!

interface Loopback1

description OSPF Router ID

ip address 172.17.254.2 255.255.255.0

!

!

interface Loopback100

ip vrf forwarding RNS

ip address 192.168.88.1 255.255.255.0

interface GigabitEthernet4/1

ip address 192.168.1.2 255.255.255.0

ip ospf priority 0

mpls ip

Interface Vlan60

ip vrf forwarding Smart-Cluster

ip address 192.168.60.2 255.255.255.0

!

interface Vlan61

ip vrf forwarding RNS

ip address 192.168.61.2 255.255.255.0

!

interface Vlan999

description OSPF Adj

ip address 192.168.99.1 255.255.255.0

!

router ospf 1

router-id 172.17.254.2

log-adjacency-changes

passive-interface default

no passive-interface GigabitEthernet4/1

network 172.17.254.2 0.0.0.0 area 0

network 172.18.254.2 0.0.0.0 area 0

network 192.168.1.2 0.0.0.0 area 0

!

router ospf 3 vrf RNS

log-adjacency-changes

network 192.168.61.0 0.0.0.255 area 3

network 192.168.88.1 0.0.0.0 area 3

!

router ospf 4 vrf Smart-Cluster

log-adjacency-changes

network 192.168.60.0 0.0.0.255 area 4

!

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 172.17.254.3 remote-as 1

neighbor 172.17.254.3 update-source Loopback1

no auto-summary

!

address-family vpnv4

neighbor 172.17.254.3 activate

neighbor 172.17.254.3 send-community both

exit-address-family

!

address-family ipv4 vrf Smart-Cluster

redistribute ospf 4 vrf Smart-Cluster

no synchronization

exit-address-family

!

address-family ipv4 vrf RNS

redistribute ospf 3 vrf RNS

no synchronization

exit-address-family

!

ip classless

!

!

no ip http server

no ip http secure-server

!

ip access-list standard LDPInterface

permit 172.18.254.0 0.0.0.255 log

!

!

!

mpls ldp router-id Loopback0

Hello Francisco,

first of all, each af ipv4 vrf vrf-name under router bgp should have at least redistribute connected otherwise the local prefixes are not advertised over the VPNv4 af to the remote PE.

From experience I would put red connected in every af ipv4 vrf vrf-name.

verify with

sh ip bgp vpnv4 all

that each PE receives the routes of the other one.

Second step:

troubleshooting MPLS forwarding plane

sh mpls forwarding remote-PE-BGP-loopback

you will see that you are using

172.17.254.x addresses for BGP but you are not allowing labels to be created and advertised for them.

this is the root cause of your connectivity issue

I would suggest the following:

use one set of loopbacks for:

OSPF, LDP and BGP

Hope to help

Giuseppe

Harold Ritter
Cisco Employee
Cisco Employee

Francisco,

Make sure that you use a 32 bit mask on the loopback interface IP addresses. This is always recommended when setting up MPLS VPN.

In this specific example the loopback interfaces of PE1 and PE2 use overlapping IP addresses (i.e. 172.18.254.3/24 on lo0 PE1 overlaps with 172.18.254.2/24 on lo0 PE2 and 172.17.254.3/24 on PE1 lo1 overlaps with 172.17.254.2/24 on PE2 lo1).

Also as Giuseppe recommended, it would definitely be a good idea to use the same loopback address for both LDP and OSPF.

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card