cant upgrade AP to Lightweight using WCS or Upgrade Tool

Unanswered Question
May 12th, 2009
User Badges:

when I try the Upgrade Tool, I get an error that Station Role should be a Root. When I try WCS to upgrade I got the error below. HELP

INFO: Telnet to device done.

INFO: Privilege level is equal to 15.

INFO: Setting vty line completed.

INFO: Dumped Environmental variables.

INFO: AP is supported for Upgrade process

INFO: IOS version is greater than or equal to 12.3(7)JA.

INFO: AP has MIC installed already.

INFO: Station role is root.

INFO: Station role is root.

INFO: DNS and Domain name configured.

INFO: Mac address of device is 00:1d:a1:ef:f7:58

INFO: Completed Dot11Radio0 shutting.

INFO: Device set up done and time configured on device.

INFO: Run-config dumped.

INFO: Gateway

INFO: Hostname MHaccess1_203F

INFO: Dumped Environmental variables.

INFO: Starts loading recovery image, takes time based on link speed.

ERROR: Device Response :: examining image...

%Error opening (Invalid IP address or hostname)

archive download: takes 0 seconds

ERROR: Image Loading FAILURE.

INFO: Un-shut radio 1 done.

END: Migration Process Failure: Image Loading Failure.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Roman Rodichev Tue, 05/12/2009 - 13:14
User Badges:
  • Gold, 750 points or more

post "show run" of your AP and post screenshot of upgrade tool before you start upgrade

Roman Rodichev Tue, 05/12/2009 - 13:23
User Badges:
  • Gold, 750 points or more

You have this on Dot11Radio0

station-role root fallback shutdown

Change it to

station-role root

and try again

everestr1 Tue, 05/12/2009 - 13:39
User Badges:

that got me farther than before, the LWAPP image will not load, I am assuming it's the TFTP server possibly ...

2009/05/12 16:34:33 INFO User has Full privilege

2009/05/12 16:34:33 INFO Getting AP Name

2009/05/12 16:34:34 INFO AP has 12.3(7)JA Image or greater

2009/05/12 16:34:34 INFO Term Length configured.

2009/05/12 16:34:34 INFO Upgrade Tool supported AP

2009/05/12 16:34:34 INFO AP has two radios

2009/05/12 16:34:34 INFO AP has Supported Radio

2009/05/12 16:34:34 INFO Station role is Root AP

2009/05/12 16:34:35 INFO MIC is already configured in the AP

2009/05/12 16:34:35 INFO Hardware is PowerPCElvis Ethernet, address is 001d.a1ef.f758 (bia 001d.a1ef.f758)

2009/05/12 16:34:35 INFO Inside Shutdown function

2009/05/12 16:34:37 INFO Shutdown the Dot11Radio1

2009/05/12 16:34:39 INFO Shutdown the Dot11Radio0

2009/05/12 16:34:40 INFO Updating the AP with Current System Time

2009/05/12 16:34:41 INFO Saving the configuration into memory

2009/05/12 16:34:41 INFO Getting AP Name

2009/05/12 16:35:25 ERROR Unable to Load the LWAPP Recovery Image on to the AP

2009/05/12 16:35:31 INFO Dot11Radio1 is up now

2009/05/12 16:35:36 INFO Dot11Radio0 is up now

everestr1 Tue, 05/12/2009 - 13:40
User Badges:

Thanks very much for your help by the way! I am going to try the upgrade tool TFTP server and see how it goes now

everestr1 Tue, 05/12/2009 - 13:41
User Badges:

I did get an error that the ACL\Firewall might be blocking the TFTP and to disable it. I am using Vista with Forefront Client Security

Roman Rodichev Tue, 05/12/2009 - 13:45
User Badges:
  • Gold, 750 points or more

The command that upgrade tool is trying to run on AP and fails is this:

"arch down /over /create-space tftp://"

try to run this command manually on the AP and see what error message it gives you? Are you sure TFTP server is running on your PC? Does it point to the right directory?

Your upgrade tool is configured for "Use External TFTP Server", maybe try "Use UpgradeTool TFTP Server" setting.

Leo Laohoo Tue, 05/12/2009 - 15:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

You are using the 1130? Very good! Are you willing to try the following procedures?


• Image file (The recovery file has the prefix “rcv” in the image name, such as c1130-rcvk9w7-tar.122-15.JA.tar);

• AP is connected to the Wireless LAN Controller; and

• AP can ping the TFTP server where the image is located.


1. Copy the recovery file to the AP using the following command:

archive tar /x tftp:/// flash:

2. Let the AP boot on this image:

boot system flash://.bin

3. Reboot the AP.



• IF POSSIBLE, type the following commands:

 clear lwapp private-config (This will bring the AP to factory default.);

 clear lwapp ap ip address

 clear lwapp ap hostname

 clear lwapp ap controller ip address

4. Let the AP connect to the Wireless LAN controller.


If an AP refuses to join the Wireless LAN Controller, type the following command from the AP:

lwapp ap controller ip address

everestr1 Wed, 05/13/2009 - 10:36
User Badges:

I changed the dot11radio1 station-role parameter as suggested and that seemed to have worked but windows firewall was preventing the TFTP transfer even after TFTP exception was created. I disabled the firewall all together and ran the upgrade tool again and thankfully the AP has now converted to lightweight.

The issues now is it has not joined WCS. I believe this is related to VLAN/DHCP issues at this point. I am switching VLANs and will check the scope build on our DHCP server.

Roman Rodichev Wed, 05/13/2009 - 10:42
User Badges:
  • Gold, 750 points or more

I believe you mean it hasn't joined WLC.

Is AP on the same VLAN as management IP of WLC? If it is, it should have joined automatically, so I assume it's not on the same subnet.

You have three options:

1. DHCP option 43. Look for instructions on CCO

2. DNS. AP will attempt to resolve CISCO-LWAPP-CONTROLLER host name from the DNS server provided by DHCP

3. Manually prime AP from CLI, here's an example from CCO:

AP1240#clear lwapp private-config

AP1240#lwapp ap hostname AP1240

AP1240#lwapp ap ip address

AP1240#lwapp ap ip default-gateway

AP1240#lwapp ap controller ip address

AP1240#show lwapp ip config

LWAPP Static IP Configuration

IP Address

IP netmask

Default Gateway

Primary Controller

Once AP associates with WLC, then you configure PRIMARY WLC in the AP settings on the WLC web interface. That name is the system name of the WLC controller (it's not a DNS name! and don't put an IP address in there!). Next time AP resets it will connect to the last primary WLC it remembers about.

everestr1 Thu, 05/14/2009 - 13:05
User Badges:

ok It looks like I finally got it to join the WLC and it's talking to WCS.

DHCP option 43 was used to add the 4 WiSM controller and nothing else. The AP was on the same VLAN as the Mgmt IP of the WiSM.

It was showing up with a DHCP assigned IP as well as a static IP ( on the wrong WiSM controller. I unchecked the static IP box and then tried to select the proper AP group and controller.

Unfortunatley the AP group I had built was not showing and when trying to save the setting that I could modify, amessage came up requesting to create a Global Username/Password??? I did and eventually the AP group showed and the AP moved to the proper controller. But then guess what? The clients couldn't connect to the SSID's.

I checked VLAN settings on our Dist and core switches as well as DHCP scopes and Radius. It all matched up but finally found out I had not added the IP range we wanted to use for wireless to the access list on our core switches. after doing so, VOILA! we now have full wireless connectivity.

Questions. It seems that when the AP tried to join the controller I wanted it to, I didnt see the AP group I had built in there. It instead joined the backup controller before I forced it to join the primary WLC.

Why am I bing asked to create a global username after I had already done so in my upgrade text file.

Why was the AP being introduced to the WLC with DHCP and Static IP's?

The original problem with the TFTP transfer was related to desktop issues with my windows firewall.

Thanks for your help. This was my first experience with the Cisco Forum and I am happy I got you guys.



This Discussion