CBWQ and interface bandwidth

Answered Question
May 13th, 2009
User Badges:

Hi,


I'm trying to use CBWQ to share a career link beetween two agencies.


I'm using classe based weight queue to do that.


I have one interface by agency and one wan interface (fastethernet connected to a 2mbit/s link where the policy is applied).


The problem is not in the bandwidth sharing (I have two class with a match input interface and a policy that provide a bandwith percent for each class) but about the wan interface. How can i tell the qos mecanism that my total bandwidth is not 100mbit/s (fastethernet) but 2mbit/s ?


I've tried with the keyword bandwith in the interface config mode but it does not limit the trafic...


Thank you for your help

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mathieu.ploton Wed, 05/13/2009 - 01:22
User Badges:

I've already read that.

My config :

class one

match input interface f0/1

class two

match input interface f0/0/0


policy-map bandwith-share

class one bandwith 50 percent

class two bandwith 50 percent


int f0/0

service policy output bandwdwith-share



How can I configure my router to tell the qos that there is only 2mbit/s to share and not 100mbit/s ?

I would configure something like:-


ip access-list standard customer1

permit 172.16.1.0 0.0.0.255


ip access-list standard customer2

permit 172.16.31.0 0.0.0.255


class-map match-all cust-1

match access-group name customer1


class-map match-all cust-2

match access-group name customer2


policy-map customers

class cust-1

bandwidth percent 50

class cust-2

bandwidth percent 50


policy-map shape-customers

class class-default

shape average 4194304

service-policy customers


HTH>

mathieu.ploton Wed, 05/13/2009 - 01:59
User Badges:

Ok so the above config will do the job ?


class one

match input interface f0/1

class two

match input interface f0/0/0


policy-map bandwith-share

class one bandwith 50 percent

class two bandwith 50 percent


policy-map parent

class class-default

police 2048000 103000 103000 conform-action transmit exceed-action drop

service-policy bandwidth-share


int f0/0

service policy output bandwdwith-share



Thank you very much !

Joseph W. Doherty Wed, 05/13/2009 - 03:05
User Badges:
  • Super Bronze, 10000 points or more

No, you want:

(edit2 NB: syntax might be incorrect)


class one

match input interface f0/1

class two

match input interface f0/0/0


policy-map bandwith-share

class one

!syntax might be bandwith percent remaining 50

bandwith remaining percent 50

class two

bandwith remaining percent 50


policy-map parent

class class-default

shape avg 2048000

service-policy bandwidth-share


int f0/0

service policy output parent


[edit]

BTW, on many platforms/IOSs, the shaper alone will do (W)FQ. I.e. you might find traffic behavior is better without the child policy.


[edit2]

i.e.

either


policy-map apolicy

class class-default

shape avg 2048000


int f0/0

service policy output apolicy


or


int fa0/0

traffic-shape avg 2048000

Actions

This Discussion