AIR-AP1231G - false Vendor Type and Model Name

Answered Question
May 13th, 2009
User Badges:
  • Bronze, 100 points or more

Hi,


we use a lot of accesspoints AIR-AP1231G-E-K9 and I want to generate an inventory report of theese devices.

OID: .1.3.6.1.4.1.9.1.525


But some of the devices are not shown valid (screenshot), others are right.


The IOS is the same on all devices.


The only difference is the Top Revision Number:

False devices: B0

Right devices: A0


Is there a issue with the device package? I installed the latest versions, but it doesn't work.


Thanks a lot!



Correct Answer by Joe Clarke about 8 years 1 month ago

The fix was to properly read correct values from the hardware based on the version, so it is entirely possible one board rev is fine while another is not.


It looks like the fix was also integrated into 12.3(8)JEC which you may be able to move to.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 05/13/2009 - 08:41
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This looks like bug CSCsj13648. It is fixed in 12.4(10b)JA.

Sven Hruza Thu, 05/14/2009 - 00:12
User Badges:
  • Bronze, 100 points or more

Thanks for your reply!


Is it right, that we have the problem with the IOS c1200-k9w7-mx.123-8.JA2 in context with the special Top Revision Number "B0"?


Because other accesspoints work fine with the same IOS.


Because an update is not possible I have to live with this fault....

Sven Hruza Thu, 05/14/2009 - 01:47
User Badges:
  • Bronze, 100 points or more

For the completeness I attached the "show version" for a accesspoint with the right model name and one for the wrong model name.


The processor board revision number is different, too.



Correct Answer
Joe Clarke Thu, 05/14/2009 - 08:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The fix was to properly read correct values from the hardware based on the version, so it is entirely possible one board rev is fine while another is not.


It looks like the fix was also integrated into 12.3(8)JEC which you may be able to move to.

Sven Hruza Mon, 05/18/2009 - 07:51
User Badges:
  • Bronze, 100 points or more

I found a accesspoint to test the 12.3(8)JEC and it works!


Thanks for your response, Joe!

Actions

This Discussion