IPM - how can I specify target IP when it's not reachable from LMS server?

Unanswered Question
May 13th, 2009

I want to use IPM and IP-SLA to monitor a VoIP network between campuses and cities. The Data and VoIP networks are converged in the campus but not over the MAN or WAN. Routing controls force the traffic over the desired path(s).

Shadow routers are being deployed on access switches in each campus. Each shadow router has two connections to the access switch - one in the data vlan and one in the VoIP vlan. Because of the routing controls, the LMS server can manage the shadow routers only via the IP address in the data vlan. This creates a problem when I create a collector as, by default, for the target device IPM uses the IP address by which the device was added to the LMS DCR - whereas I need it to use the VoIP IP address. For some Operations I could add an Adhoc Target using the VoIP vlan IP address of the shadow router, but for UPD Jitter IPM throws an error message "Only Responder enabled devices permitted for selected operations".

How can I get IPM to do what I need or can you suggest an alternate design?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 05/13/2009 - 12:23

If IPM cannot contact the responders, then it will not be able to determine that they have the responder enabled. I don't see a good solution for this other than making your target devices reachable on their voice addresses.

It may be possible to add a target destination IP address field in a future release, however.

One thing I haven't tried which may work is to define the collects on your source device manually using the CLI. Then, if you're running IPM 4.1, you can import the collector from the device via the CLI:

ipm importcollector -u xxx -p xxx -source SOURCE_DEVICE -oper UDPJitter

This way, you would be able to view the data from the collectors in IPM. As I said, this is untested, and may not work if the target is not defined in IPM.

Joe Clarke Thu, 05/14/2009 - 22:19

I think this feature would be useful to have, so I filed CSCsz66719 requesting it be implemented in a future IPM release.

d.land Fri, 05/15/2009 - 05:01

Hi Joe,

Thanks for your response and also the request to add this feature to IPM. I haven't yet tested your suggestion but will let you know result when I do.

Dick

d.land Mon, 05/25/2009 - 10:39

Joe,

IPM CLI importcollector from the source device works ok even though IPM cannot reach the target device to check if SLA Responder is enabled. In IPM the Monitor function for the imported collector returns data but the Graph does not.

I think this is because the polling interval for the imported collection is set to 60 minutes (I created 3 collectors in IPM across the data network and get Graph data for 1 and 5 minute polling but not for 60 minute polling). However I should also mention that the operation created on the device has Entry Ageout=never whereas the IPM created ones =3600 seconds.

It is not possible to change the polling interval for the imported collector in IPM and I'm unclear if this collector can be imported or modified using the file option of the CLI importcollector command. Any suggestions?

Thanks, Dick.

Joe Clarke Mon, 05/25/2009 - 11:47

The input file allows you to control some parameters of the imported collectors. The format of the file is:

;HEADER:Collector Name,Description,Source Display Name,Target Display Name,Operation Name,Operation Type,Source Interface Address,Collector Type,Start Date,End Date,Poll Start Time,Poll End Time,DaysOfWeek,Poll-Interval

You can see an example by running the imp export command to export current collectors. In my test, the imported collectors all had the same parameters as an infinite collector I had already created within IPM.

In my testing, I imported a collector from a device with a poll interval of 60000:

;HEADER:Collector Name,Description,Source Display Name,Target Display Name,Operation Name,Operation Type,Source Interface Address,Collector Type,Start Date,End Date,Poll Start Time,Poll End Time,DaysOfWeek,Poll-Interval

Coll_14.32.100.75_1_Echo,Coll_14.32.100.75_1,14.32.100.75,172.18.123.33,Echo_117,1,,1,05/25/2009,01/31/2021,00:00:00,00:00:00,127,60000

ipm importcollector -u xxx -p xxx -oper Echo -file /tmp/exp.csv

d.land Tue, 05/26/2009 - 08:02

I tested importing my collector from a file and found that IPM tries to validate that SLA Responder is enabled on the target device...

"Invalid Target (10.91.81.9). It should be Responder Enabled for Operation (UDP Jitter_200)"

I guess I'm stuck with importing from the source device because IPM does not validate Responder then.

So do you have any ideas why I cannot get Graph data for this imported collector?

================================

Here's the operation config:

mlixphfx1t2a#show ip sla mon config

SA Agent, Infrastructure Engine-II

Entry number: 200

Owner:

Tag: Halifax-King Jitter

Type of operation to perform: jitter

Target address: 10.91.81.9

Source address: 0.0.0.0

Target port: 23000

Source port: 0

Operation timeout (milliseconds): 5000

Codec Type: g729a

Codec Number Of Packets: 1000

Codec Packet Size: 32

Codec Interval (milliseconds): 20

Advantage Factor: 0

Type Of Service parameters: 0xA0

Verify data: No

Vrf Name:

Control Packets: enabled

Operation frequency (seconds): 60

Next Scheduled Start Time: Start Time already passed

Group Scheduled : FALSE

Life (seconds): Forever

Entry Ageout (seconds): never

Recurring (Starting Everyday): FALSE

Status of entry (SNMP RowStatus): Active

Threshold (milliseconds): 5000

Number of statistic hours kept: 2

Number of statistic distribution buckets kept: 1

Statistic distribution interval (milliseconds): 20

Enhanced History:

================================

...and the exported collector...

Coll_mlixphfx1t2a_200_UDP Jitter,Coll_mlixphfx1t2a_200,mlixphfx1t2a,10.91.81.9,UDP Jitter_200,9,,1,05/21/2009,01/31/2021,00:00:00,00:00:00,127,3600000

================================

Joe Clarke Tue, 05/26/2009 - 09:10

Not based on this data. My only guess is that you're not waiting long enough for data. If you try to monitor this collector, do you start to see data points?

d.land Tue, 05/26/2009 - 10:08

Yes I see data points in the Monitor. The collector ran for several days but still no data in the Graph.

I don't think this is related specifically to my imported collector. As mentioned before, I created 3 UDP Jitter collectors across the data network using IPM and get Graph data for 1 and 5 minute polling but not for 60 minute polling. Could this be a bug?

Joe Clarke Tue, 05/26/2009 - 10:10

Maybe. More analysis would need to be done. I suggest you open a TAC service request.

Actions

This Discussion