7206 to 3750 gigabit fiber link is extremely slow

Unanswered Question
May 14th, 2009
User Badges:

I have a three switch stack consisting of


2 3750G-24s

1 3750G-48p



I am trying to connect a 3750 via the gigabit fiber port to a 7206 NPE-400 Sup Engine gigabit port.


The 3750 is using the 1000base-SX SFP


The 7207 is using the 1000base-SX GBIC



After experimenting with the port config, I was able to get both ends to sh up/up, but the connection is very slow.


Doing a ping from the 7206 interface to the switch vlan svi (or vise versa) results in


!..!!

!!!..

!.!!.


I have two DMX devices connected via the gigabit ports to the 48port switch and it is working fine.


Both GBICs on that connection are the same type the small 1000base-sx SFP.


I am getting the same results on all three swithes reying to upling to the 7206.


I have tried numerous different GBICs and cables.




I have tried using nonegotiate on both ends and also configuring both ends to negotiate the connection with the same results.


7206


interface GigabitEthernet0/0

ip address 10.1.7.1 255.255.255.0

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

duplex auto

speed auto

media-type gbic

negotiation auto

end




3750


interface GigabitEthernet1/0/28

switchport access vlan 7

switchport mode access

spanning-tree portfast


or


7206


interface GigabitEthernet0/0

ip address 10.1.7.1 255.255.255.0

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

duplex full

speed 1000

media-type gbic

no negotiation auto

end




3750


interface GigabitEthernet1/0/28

switchport access vlan 7

switchport mode access

speed nonegotiate

spanning-tree portfast




Any thoughts on what could be the problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mlkahn Fri, 05/15/2009 - 14:57
User Badges:

I am confused by the connection of a layer-2 switchport (3750) to a layer-3 routed port (7206). Is the ip address of the 3750's vlan interface a 10.1.7.x address?

And why do you have portfast enabled on a port that will connect to another network device? I thought portfast should only be used where a single, non-routing or bridging host is known to be on the other end.


Excuse my lack of knowledge about other methods, but I would connect the two devices with each end being switchports, either both are trunks or both are access ports; or, I would configure the 3750's port as a layer-3 interface with an IP address in the subnet. And I would not have portfast enabled in any case.


As far as layer-1, it's been my experience that Cisco devices connect to each other just fine when allowed to negotiate freely, and nonegotiate is only useful when the far end does not support Cisco's gig-ethernet protocol. Media converters are one example.

wilson_1234_2 Fri, 05/15/2009 - 21:31
User Badges:

"I am confused by the connection of a layer-2 switchport (3750) to a layer-3 routed port (7206). Is the ip address of the 3750's vlan interface a 10.1.7.x address?"


Yes, the switchport is a layer 2 port in vlan 7, which connects the two layer three interfaces (The 3750 has an SVI in vlan 7).


I am not sure I understand your suggestion of connecting both ends as switchports.


If the port on the switch is a switchport, how do I make the router interface with an IP address a switchport, unless subinterfaces are created and encapsulated dot1q?


When removing the fiber connection and connecting the ethernet port of the router the same way, it worked fine (which is how it is connected in production right now).


So I don't think portfast is an issue.


Also in my post, I have an example of what you suggest that exibited the same symptoms:


interface GigabitEthernet0/0

ip address 10.1.7.1 255.255.255.0

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

duplex auto

speed auto

media-type gbic

negotiation auto

end



3750


interface GigabitEthernet1/0/28

switchport access vlan 7

switchport mode access

spanning-tree portfast

Paolo Bevilacqua Sat, 05/16/2009 - 23:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sshow interface ?

You might have a faulty fiber patch.

wilson_1234_2 Thu, 06/04/2009 - 16:54
User Badges:

paolo,


I have tried numerous cables and modules on both ends.


What I have is


gbic 1000base sx -->to--> 1000base sfp


I am seeing a ton of frame errors on the sx side and the reliability is poor.


Is there a problem going from sx to sfp?


It looks like some sort of incapatability between the two modules.


The 7206 side with the sx bgic:

GigabitEthernet0/0 is up, line protocol is up

Hardware is i82543 (Livengood), address is 0011.bb6d.cf08 (bia 0011.bb6d.cf08)

Description: connected to Lakeland LAN

Internet address is 10.100.202.100/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 153/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is autonegotiation, media type is SX

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:03:16, output 00:00:01, output hang never

Last clearing of "show interface" counters 1d06h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 0 bits/sec, 0 packets/sec

30 second output rate 0 bits/sec, 0 packets/sec

575 packets input, 208680 bytes, 0 no buffer

Received 564 broadcasts, 88 runts, 0 giants, 0 throttles

1324597283 input errors, 7 CRC, 1324597188 frame, 0 overrun, 0 ignored

0 watchdog, 437 multicast, 0 pause input

0 input packets with dribble condition detected

10048 packets output, 1015769 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out



The 3750 side with the sfp:

GigabitEthernet1/0/28 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0011.9362.f91c (bia 0011.9362.f91c)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:21, output 00:00:11, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 1000 bits/sec, 1 packets/sec

11491 packets input, 1211198 bytes, 0 no buffer

Received 1833 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 1790 multicast, 0 pause input

0 input packets with dribble condition detected

201282 packets output, 21091511 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Leo Laohoo Fri, 05/15/2009 - 18:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I agree. Remove the duplex and speed settings from both sides.

Actions

This Discussion