cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2527
Views
0
Helpful
6
Replies

Etherchannel CISCO 6509 to IBM Blade 3012 Switch

ArrowSIVAC
Level 1
Level 1

Issue bringing up etherchannel aggregate.

Goal:

sw00 8/3-4 --> po1 ---> sw15 0/15-16

**

**509**

!

interface Port-channel1

no ip address

!

<snip>

!

interface GigabitEthernet8/3

shutdown

speed 1000

duplex full

spanning-tree portfast

channel-group 1 mode desirable

channel-protocol pagp

!

interface GigabitEthernet8/4

shutdown

speed 1000

duplex full

spanning-tree portfast

channel-group 1 mode desirable

channel-protocol pagp

!

sw00#sh interfaces etherchannel

----

GigabitEthernet8/3:

Port state = Down Not-in-Bndl

Channel group = 1 Mode = Desirable-Sl Gcchange = 0

Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.

A - Device is in Auto mode. P - Device learns on physical port.

d - PAgP is down.

Timers: H - Hello timer is running. Q - Quit timer is running.

S - Switching timer is running. I - Interface timer is running.

Local information:

Hello Partner PAgP Learning Group

Port Flags State Timers Interval Count Priority Method Ifindex

Gi8/3 d U1/S1 1s 0 128 Any 0

Age of the port in the current state: 1d:01h:04m:44s

----

GigabitEthernet8/4:

Port state = Down Not-in-Bndl

Channel group = 1 Mode = Desirable-Sl Gcchange = 0

Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.

A - Device is in Auto mode. P - Device learns on physical port.

d - PAgP is down.

Timers: H - Hello timer is running. Q - Quit timer is running.

S - Switching timer is running. I - Interface timer is running.

Local information:

Hello Partner PAgP Learning Group

Port Flags State Timers Interval Count Priority Method Ifindex

Gi8/4 d U1/S1 1s 0 128 Any 0

Age of the port in the current state: 1d:01h:04m:44s

----

Port-channel1:

Age of the Port-channel = 0d:10h:22m:06s

Logical slot/port = 14/1 Number of ports = 0

GC = 0x00000000 HotStandBy port = null

Passive port list = Gi8/3 Gi8/4

Port state = Port-channel L3-Ag Ag-Not-Inuse

Protocol = PAgP

sw00#

**

**3012**

!

interface Port-channel7

!

<snip>

!

interface GigabitEthernet0/15

switchport mode trunk

shutdown

channel-group 7 mode on

!

interface GigabitEthernet0/16

switchport mode trunk

shutdown

channel-group 7 mode on

!

sw15#sh interfaces etherchannel ?

module Limit display to interfaces on module

| Output modifiers

<cr>

sw15#sh interfaces etherchannel

----

GigabitEthernet0/15:

Port state = Down Not-in-Bndl

Channel group = 7 Mode = On Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po7

Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:14h:53m:54s

----

GigabitEthernet0/16:

Port state = Down Not-in-Bndl

Channel group = 7 Mode = On Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po7

Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:14h:53m:54s

----

Port-channel7:

Age of the Port-channel = 0d:09h:56m:40s

Logical slot/port = 10/7 Number of ports = 0

GC = 0x00000000 HotStandBy port = null

Port state = Port-channel Ag-Not-Inuse

Protocol = -

Port security = Disabled

**

6 Replies 6

mahmoodmkl
Level 7
Level 7

Hi

I think u need to use LACP instead of pagp becoz its cisco proprietary.

And i see the ports on the other switch as shutdown,enable them and check.

Thanks

Mahmood

Thanks for reply:

Both switches are CISCO

CISCO 6509

CISCO 3012

***

sw15(config-if-range)#no shut

% Shutdown not allowed on this interface.

% Range command terminated because it failed on GigabitEthernet0/15

sw15(config-if-range)#exit

*****

sw00(config)#int range gi8/3 - 4

sw00(config-if-range)#no shut

sw00(config-if-range)#exit

****

sw00#sh interfaces port-channel 1

Port-channel1 is up, line protocol is down (notconnect)

Hardware is EtherChannel, address is 0013.5f31.530a (bia 0013.5f31.5300)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

****

sw15#sh interfaces port-channel 7

Port-channel7 is down, line protocol is down (notconnect)

Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

Hi

Can u try the below config on both the switches.

interface range gig8/3-4

switchport

switchport mode trunk

switchport trunk encap dot1q

channel-group 1 mode desirable

Thanks

Mahmood

You are forcing one side on while the other side is trying to negotiate using pagp , make both sides as desirable non-silent .

channel-group x desirable non-silent.

I have had other issues but am coming back to this issue which is still outstanding:

Here is the current state. I have followed the CISCO / IBM redbook on how to do almost the EXACT configuration that i have (http://www.redbooks.ibm.com/abstracts/redp3869.html pages 124-128)

Also CISCO website http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/prod_white_paper09186a00800c8441.html

****6509****

!

interface Port-channel1

description EtherChannel to sw15 15-16

duplex full

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 11

switchport mode trunk

spanning-tree guard root

!

!

interface GigabitEthernet8/3

description sw15-15 (po 1)

duplex full

switchport

switchport trunk native vlan 11

switchport mode trunk

spanning-tree guard root

channel-group 1 mode active

!

interface GigabitEthernet8/4

description sw15-16 (po 1)

duplex full

switchport

switchport trunk native vlan 11

switchport mode trunk

spanning-tree guard root

channel-group 1 mode active

!

sw00#sh etherchannel port-channel

Channel-group listing:

-----------------------

Group: 1

----------

Port-channels in the group:

----------------------

Port-channel: Po1 (Primary Aggregator)

------------

Age of the Port-channel = 0d:01h:19m:50s

Logical slot/port = 14/1 Number of ports = 0

Port state = Port-channel Ag-Not-Inuse

Protocol = LACP

sw00#sh cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

sw15 Gig 8/5 167 S I WS-CBS3012Gig 0/15

sw15 Gig 7/6 167 S I WS-CBS3012Gig 0/18

sw15 Gig 7/5 167 S I WS-CBS3012Gig 0/17

******

****3012****

!

interface Port-channel1

description EtherChannel po1 sw00 8 3-4

switchport trunk native vlan 11

switchport mode trunk

!

!

interface GigabitEthernet0/15

description sw00 8 3-4

switchport trunk native vlan 11

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode active

!

interface GigabitEthernet0/16

description sw00 8 3-4

switchport trunk native vlan 11

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode active

!

sw15#sh etherchannel port-channel

Channel-group listing:

----------------------

Group: 1

----------

Port-channels in the group:

---------------------------

Port-channel: Po1 (Primary Aggregator)

------------

Age of the Port-channel = 0d:01h:12m:18s

Logical slot/port = 10/1 Number of ports = 0

HotStandBy port = null

Port state = Port-channel Ag-Not-Inuse

Protocol = LACP

Port security = Disabled

sw15#sh cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

sw15 Fas 0 152 S I WS-CBS301 Gig 0/19

sw15 Gig 0/19 161 S I WS-CBS301 Fas 0

sw00 Gig 0/18 128 R S I WS-C6509 Gig 7/6

sw00 Gig 0/17 128 R S I WS-C6509 Gig 7/5

sw00 Gig 0/15 128 R S I WS-C6509 Gig 8/5

******

I figured out the error.

I just needed another CISCO guy to sit next to me to point it out ...

Root Cause: Patching cables and documenting 2am :(

If you look closely at CDP neighborhood it shows:

sw00 Gig 0/18 128 R S I WS-C6509 Gig 7/6

sw00 Gig 0/17 128 R S I WS-C6509 Gig 7/5

so the sw15 (3012 blade switch)ports 17 and 18 are plugged into sw00 ports 7/5 and 7/6 NOT the 7/3 and 7/4 that I was expecting.

Lesson learned: CDP = Friend trust it not your helpers patching cables.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: