NetFlow exports on 4500s

Answered Question
May 14th, 2009
User Badges:

Hello,


I have NetFlow configured on 2 different 4500s, with the below hardware:


THATCH_CR451_01#sh mod

Chassis Type : WS-C4510R


Power consumed by backplane : 40 Watts


Mod Ports Card Type Model

---+-----+--------------------------------------+----------

1 2 Supervisor V 1000BaseX (GBIC) WS-X4516


Mod Submodule Model

----+-----------------------+------------

1 Netflow Services Card WS-F4531


running IOS: cat4500-entservices-mz.122-25.SG4.bin


THATCH_CR451_01#sh ip flow export

Flow export v5 is enabled for main cache

Exporting flows to 161.12.20.11 (9991)

Exporting using source interface Loopback0

Version 5 flow records

47178983 flows exported in 1572650 udp datagrams


and....


HORLEY_CC450_01#sh mod

Chassis Type : WS-C4506


Power consumed by backplane : 0 Watts


Mod Ports Card Type Model

---+-----+--------------------------------------+--------------

1 2 Supervisor IV 1000BaseX (GBIC) WS-X4515


Mod Submodule Model

----+-----------------------+------------

1 Netflow Services Card WS-F4531


running IOS: cat4500-entservices-mz.122-25.SG.bin


HORLEY_CC450_01#sh ip flow export

Flow export v5 is enabled for main cache

Exporting flows to 161.12.20.11 (9991)

Exporting using source interface Loopback0

Version 5 flow records

2137814974 flows exported in 71260500 udp datagrams


both have the same config applied:


ip flow-export source Loopback0

ip flow-export version 5

ip flow-export destination 161.12.20.11 9991


There is no option to add the "ip route-cache" line under each layer-3 interface, however HORLEY_CC450_01 is collecting stats, but the THATCH_CC450_01 is not....


Feature navigator states netflow should work on the IOS installed, but is defintely not. I can see flows saying they are being exported, but not collecting within Netflow. Is this a known bug, or is there additional config needed? Any help appreciated.


Thanks

Phil

Correct Answer by adam.craft about 8 years 2 months ago

I found some documentation stating this as well, but I believe it is specific to routers.


I also found this document: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/25ew/configuration/guide/nfswitch.html#wp1014923 which explicitly states "Enabling NetFlow on a per interface basis is not supported on a Catalyst 4500 switch."



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
adam.craft Fri, 05/22/2009 - 04:52
User Badges:

Ahoy Phil,


Have you had any success with this? I am experiencing the same issue on cat4000-i5k91s-mz.122-25.EWA14.bin.


Would appreciate any insight, thanks!


-Adam

phil_carter Fri, 05/22/2009 - 05:17
User Badges:

Hello,


No - nothing of note to resolve this problem... I guess its a 'feature' with the cisco code/HW combination....


Rgds

Phil

johnlloyd_13 Fri, 05/22/2009 - 18:16
User Badges:
  • Blue, 1500 points or more

in some recent IOS releases Cisco Express Forwarding has to be enabled. make sure you've issued the ip cef command in global config mode

phil_carter Tue, 05/26/2009 - 02:03
User Badges:

If only it was that easy... CEF configured on all 4500s already....


phil_carter Wed, 05/27/2009 - 01:20
User Badges:

Adam,


"ip flow ingress infer-fields" in global config command enabled netflow for me....


thanks for your help!... be warned though, when entering the command your session freezes for a short period, so be careful if adding on a live network in the middle of the day (just in case it does have an impact)!

Actions

This Discussion