csim err:csim_do_test invalid major major(16) minor(0)

Unanswered Question

Hi, i had a problem with a gateway h323 with some MGCP parameters and SRST with MGCP fallfack. The IOS was c2800nm-advipservicesk9-mz.124-22.T.bin


The problem was that suddenly it can't receive and make calls trough the E1 and the analog lines. I made a debug and when the call come in appears the error cause 38 (Network issue) and when i want to make a call appears the error cause 47 (dsp problem)


The E1 provider saw the layer 1 down from its node but from the router "sh osdn status" i saw the layer 1 up and the layer 2 in multiframe-stablished.


Well, i resolved the problem reconfiguring the voice parameters from the gateway. But now i cannot make a csim start and appears this message:


csim: called number = 06256837, loop count = 1 ping count = 0


csim err:csim_do_test invalid major major(16) minor(0)

csim: loop = 1, failed = 0

csim: call attempted = 1, setup failed = 0, tone failed = 0


Do any of you have this problem before???


Thanks for your help.


Jose


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
amritpatek Wed, 05/20/2009 - 12:33
User Badges:
  • Silver, 250 points or more

If you are using SSH, then csim start doesn't work with SSH.

garrett.scroggin Thu, 08/26/2010 - 05:00
User Badges:

Oddly enough, I concur with amritpatek.


When I use the command "csim start " during a telnet session (TeraTerm as an example), the call simulation works as expected.  The far side rings and I see the respective facility in use (PRI for example).


When I run the same command in a SSH session (puTTY as an example), I receive the same message as the OP, and the call is never attempted.  No debug info is returned with every debug option I've tried.  I've tried this on c2800nm-advipservicesk9-mz.124-22.T1.bin and c3825-advipservicesk9-mz.124-22.T1.bin.


Kind of wacky, no?  Buy hey, at the end of the day it's an undocumented command

paolo bevilacqua Thu, 08/26/2010 - 05:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You are right, csim does not work with SSH. Note it disconnects the call right away.

That does not happen with telnet.


vg-bws-rome-1#who
    Line       User       Host(s)              Idle       Location
*194 vty 0     pab        idle                 00:00:00 10.0.97.3


vg-bws-rome-1#sh ssh
Connection Version Mode Encryption  Hmac         State                 Username
0          2.0     IN   aes256-cbc  hmac-sha1    Session started       pab
0          2.0     OUT  aes256-cbc  hmac-sha1    Session started       pab
%No SSHv1 server connections running.

vg-bws-rome-1#debug isdn q931
debug isdn q931 is              ON.
vg-bws-rome-1#term mon
vg-bws-rome-1#csim start 123
csim: called number = 123, loop count = 1 ping count = 0


csim err:csim_do_test invalid major major(16) minor(0)
csim: loop = 1, failed = 0
csim: call attempted = 1, setup failed = 0, tone failed = 0


vg-bws-rome-1#
Aug 26 14:27:26.388 CEST: ISDN BR0/0/1 Q931: Sending SETUP  callref = 0x002A callID = 0x8030 switch = basic-net3 interface = User
Aug 26 14:27:26.388 CEST: ISDN BR0/0/1 Q931: TX -> SETUP pd = 8  callref = 0x2A
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x8A
                Exclusive, B2
        Called Party Number i = 0x80, '123'
                Plan:Unknown, Type:Unknown
        Sending Complete
Aug 26 14:27:26.408 CEST: ISDN BR0/0/1 Q931: TX -> DISCONNECT pd = 8  callref = 0x2A
        Cause i = 0x80AF - Resource unavailable, unspecified

Aug 26 14:27:26.420 CEST: ISDN BR0/0/1 Q931: RX <- CALL_PROC pd = 8  callref = 0xAA
        Channel ID i = 0x8A
                Exclusive, B2
Aug 26 14:27:26.424 CEST: ISDN BR0/0/1 **ERROR**: Ux_BadMsg: Invalid Message for call state 11, call id 0x8030, call ref 0x2A, event 0x2
Aug 26 14:27:26.428 CEST: ISDN BR0/0/1 Q931: TX -> STATUS pd = 8  callref = 0x2A
        Cause i = 0x80E202 - Message not compatible with call state or not implemented
        Call State i = 0x0B
Aug 26 14:27:26.436 CEST: ISDN BR0/0/1 Q931: RX <- RELEASE pd = 8  callref = 0xAA
        Cause i = 0x82AF - Resource unavailable, unspecified
Aug 26 14:27:26.444 CEST: ISDN BR0/0/1 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x2A

paolo bevilacqua Wed, 05/20/2009 - 12:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

[edited due to incorrect information]

albrasin Wed, 06/29/2016 - 01:17
User Badges:
  • Cisco Employee,

NOTE that csim start on SSH works if you give the command in the same line of the login command (at the end of the command).


Actions

This Discussion