(2) IP ranges over Multilink Frame Relay via 3xT1

Unanswered Question
May 14th, 2009
User Badges:

I have (2) external IP ranges I'd like to assign to a multilink frame relay interface, both of which are controlled by the same ISP. The frame relay is bundling (3) T1s into a 3xT1 running on a Cisco 2821 with IOS Version 12.4(25).


I successfully have the following config running, except for sub-int .501 which I will be adding once the routing is changed with the ISP for the additional range.


Two questions:

1. Will the below config function correctly since the DLCI is being duplicated on the subinterfaces?

2. Will I need an additional DLCI even though it's probably connecting to the same DCE frame-relay switch?


Let me know if there is a better configuration for this setup.


!

!

controller T1 0/0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/0/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

!

interface MFR0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface MFR0.500 point-to-point

ip unnumbered GigabitEthernet0/0

no cdp enable

frame-relay interface-dlci 500

!

interface MFR0.501 point-to-point

ip unnumbered GigabitEthernet0/1

no cdp enable

frame-relay interface-dlci 500

!

interface GigabitEthernet0/0

ip address xx.xx.xx.xx 255.255.255.128

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address yy.yy.yy.yy 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0/0:0

no ip address

encapsulation frame-relay MFR0

no arp frame-relay

frame-relay multilink lid link3

!

interface Serial0/0/1:0

no ip address

encapsulation frame-relay MFR0

no arp frame-relay

frame-relay multilink lid link1

!

interface Serial0/1/0:0

no ip address

encapsulation frame-relay MFR0

no arp frame-relay

frame-relay multilink lid link2

!

interface Serial0/1/1:0

no ip address

!

ip route 0.0.0.0 0.0.0.0 MFR0.501

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 05/14/2009 - 22:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Adam,

this config is not correct the same DLCI cannot be associated to two different subinterfaces.

You need to negotiate with ISP a second DLCI to be used on the second subif.

Then each subif can accomodate a different ip subnet, for example in the way you have done with ip unnumbered.


Look at the MFR interface as a normal serial interface with FR encapsulation the same rules apply here.


Edit:

for outbound load balancing you will need a second default static route using the other subif as exit point.


Hope to help

Giuseppe


machine825 Fri, 05/15/2009 - 08:21
User Badges:

Does outbound load balancing really matter since regardless of outgoing sub-interface, all traffic is being bundled over MFR0 via the 3xT1?


Thank you for your help.


-Adam

Giuseppe Larosa Fri, 05/15/2009 - 08:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Adam,

that's right but symmetric solutions are better unless NAT is involved.

In case one DLCI is deleted on FR switch the other one still allows you to go out.


If you use NAT it is probably better to have a second floating static route to avoid to mix up with translations


Hope to help

Giuseppe

Actions

This Discussion