pix cable modem configuration DHCP but need static

Unanswered Question
May 16th, 2009

I am going to connect a Pix 501 to a cable modem. It is going to use DHCP. I am going to use the following configuration but have a question. I need to be able to get a Remote Desktop Connection on a server behind the PIX. I am going to have only 1 outside IP address and it's going to be DHCP. Any suggestions on how to get this to work? There is only one machine behing the PIX and possible two. Here is the config I was going to use but I am not sure how to do the NAT/PAT.

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password PVSASRJovmamnVkD encrypted

passwd PVSASRJovmamnVkD encrypted

hostname pixMDC

domain-name keene.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 10.8.6.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 10.0.0.0 255.0.0.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 10.8.6.0 255.255.255.0 0 0

access-group outside_access_in in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 10.0.0.0 255.0.0.0 inside

http 10.8.6.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet 10.8.6.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 10.8.6.2-10.8.6.33 inside

dhcpd dns 151.203.0.84 151.202.0.84

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80

Cryptochecksum:6ca15e834dc867c6f12b46b2bd28a4a8

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

first create the access-list

access-list inbound permit tcp any interface outside eq 3389

apply access-list to interface

access-group inbound in interface outside

Then create the NAT statements

static (inside,outside) tcp interface 3389 xx.xx.xx.xx 3389 netmask 255.255.255.255 0 0

(where xx is the internal address of the workstation you want to connect to.)

I would recommend you changing the outside RDP ports to something different for ex: 3390

you can do this by changing the nat statement

static (inside,outside) tcp interface 3390 xx.xx.xx.xx 3389 netmask 255.255.255.255 0 0

we will also have to change the access-list to access-list inbound permit tcp any interface outside eq 3390

Actions

This Discussion