Voicemail doesn't answer incoming call

Unanswered Question
May 16th, 2009
User Badges:

I am studying for my CCNA Voice exam and have configured a small voice network already. This weekend I wiped it all clean to try it again with a bit more knowledge of what I was doing. Unfortunately, it doesn't appear to be working when it comes to voicemail.


I have two networks. One has extensions in the 1000 range and the other has extensions in the 2000 range. The problem occurs whether it is calling inside extensions or outside extensions. I make a call to a phone and it rings just fine. But the call is never forwarded to the internal Unity Express. I am able to have a phone dial into CUE and setup voicemail preferences just fine, so the dial plan appears to be correct. It is just that unanswered calls aren't forwarding onto the CUE.


Here is a little bit of my configuration if this helps...


interface Loopback2

ip address 192.168.200.1 255.255.255.252


interface Service-Engine 1/0

ip unnumbered Loopback 2

service-module ip address 192.168.200.2 255.255.255.252

service-module ip default-gateway 192.168.200.1


ip route 192.168.200.2 255.255.255.255 Service-Engine1/0


dial-peer voice 7000 voip

description Voicemail

destination-pattern 7000

session target ipv4:192.168.200.2

dtmf-relay sip-notify

codec g711ulaw

no vad


telephony-service

voicemail 7000


Any help would be appreciated. Note: I typed the above config in manually, so it may have a typo or two.


This is on CME 7.1 and CUE 7.0.1 (I think)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rob Huffman Sat, 05/16/2009 - 15:28
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Kevin,


call-forward noan


To configure call forwarding so that incoming calls to an extension (ephone-dn) that does not answer are forwarded to another number, use the call-forward noan command in ephone-dn or ephone-dn-template configuration mode. To disable call forwarding, use the no form of this command.


call-forward noan target-number timeout seconds


timeout seconds - Sets the duration that a call can ring with no answer before the call is forwarded to the target number. Range is from 3 to 60000. There is no default value.


For your setup it would look like this;


call-forward noan 7000 timeout 15


From this good CME doc;


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_c1ht.html#wp1063669


Hope this helps!

Rob


Kevin Breit Sat, 05/16/2009 - 15:50
User Badges:

Rob - This kind of helps. A few questions surrounding this method.


First, should CUE automatically setup call-forward when mailboxes are created? Last time I configured this I didn't have to set forwarding up but it seemed to work.


Second, call-forward noan causes problems when called from the "remote" extensions (example: 2000 calling 1000). It gets forwarded, but then it seems I get the error signal over the phone (not sure the name, but kind of like the fast busy signal). If I had to guess, this is a problem with dial-peers. My voice mail number on both CME systems is 7000 and I have a dial peer setup for both which points to the respective internal CUE module.


Thanks for the fast response.

Actions

This Discussion