SPA3102 - Line 1 answers only with "Reorder Tone" after using PSTN

Unanswered Question
May 17th, 2009


got a SPA3102 and everything works fine if I only use Line 1. When I change the Dial Plan from (xx.) for example to (<#,:>xx.<:@gw0>|xx.) all outbound calls over Line 1 work until I make _one_ call out over the PSTN. After that I can not reach any number over VoIP/Line 1, every attempt gives me the "Reorder Tone" after dialing or at the latest when the opposite side goes off hook.

When I restart the SPA3102 I can do outwards calls over Line 1 again until ...

Calls from outside over Line 1/PSTN work in both situations incl. representation of the CLIDs fine. As I am in France the land line provider is France Telecom.

Device has latest firmware 5.1.10(GW), I've reset it already several times to factory defaults and configured only the strict minimum to get it going. Line voltage readings on the 'Info'-tab look normal, around 54V.

Any pointer would be greatly appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
trosinenko Tue, 06/23/2009 - 12:59

I actually experience exactly the same problem. Has this been resolved somehow?

Thanks in advance,


Patrick Born Tue, 06/23/2009 - 14:53

Hi trosinenko,

The issue is still under investigation. I have Peter's config and syslog file, I'd missed them in my inbox...  :-(

I'll update this thread shortly.




firmelogiq Mon, 07/13/2009 - 12:26

Hi Patrick

I have exactly the same problem as Peter and Denis
The problem came with the change of firmware from 3.3.6 (GW) to 5.1.10 (GW).

Me too I am in France and the land line provider is France Telecom.
I already performed a factory reset [73738] with a very simple configuration: a sip account in line1 and a simple dial plan.

No problem with PSTNline (which rings through to Line1  (PSTN Ring Thru Line 1: yes))

No problème with line1 except after a incoming call on PSTN line.
- Incoming call : ok
- Outgoing call : "reorder Tone"
To release line1, it is necessary to ring this line1

Thanks in advance,

firmelogiq Tue, 07/14/2009 - 11:47

Hi Patrick

Attached  5 files with debug and syslog messages :
1 - Outgoing call from line1 to mobile phone : ring ok
2 - Incoming call from mobile phone to PSTN : creates the problème
3 - Outgoing call from line1 to mobile phone : "reorder Tone"
4 - Incoming call from mobile phone to line1 to release the problem
5 - Outgoing call from line1 to mobile phone : ring ok


Alberto Montilla Tue, 07/14/2009 - 12:10

Dear Sir;

The trace looks incomplete.

Make sure you use only the Debug server information (level 3) and also that activate the trace in Line 1 according to the instructions...

One suggestion to try is downgrading the firmware to an earlier version (not the latest) to see if the issue is there.  Try the attached and let us know if the issue is still there.


firmelogiq Wed, 07/15/2009 - 08:43


Very good suggestion. Is it ok with the firmware spa3102-5.1.7



trosinenko Thu, 07/16/2009 - 07:31

Hi Patrick.

Here is the log you have asked for. Plz let me know whether it was done in the right way and whether it will help you solve the problem.

I would also appreciate whether you could tell me what seems to be the probkem and when do you expect to fix it - as it stands now, it is a nightmare.

The Log file respresents the following situation:

1) Outgoing Call - OK

2) Incomming Call-OK

3) Outgoing Call - Failure (Reorder Tone)

My SPA3102 has

Hardware Version:1.4.5(a)

Many thanks.


Alberto Montilla Thu, 07/16/2009 - 07:44

Dear Sir;

If the problem is solved with 5.1.7, I suggest you stay with it for some time. We will work meanwhile to solve your issue.


purpuroni Sun, 07/26/2009 - 16:52

Hi everybody,

as a result of an outage of my usual VoIP provider I opened an account at an other provider. And there to my great surprise, everything worked marvellous. That revitalized my interest in the strange error of the SPA3102 that I had already abandoned weeks ago. And led me to a profound debugging session, which eventually brought no solution for me but showed me at least what caused the problem in the first place.

The crucial point is that the ATA proposes and accepts depending on your configuration different codecs during the SIP-negotiations (INVITE). In my case for instance it looked like that:

a=rtpmap:0 PCMU/8000

a=rtpmap:2 G726-32/8000

a=rtpmap:4 G723/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729a/8000

a=rtpmap:96 G726-40/8000

a=rtpmap:97 G726-24/8000

a=rtpmap:98 G726-16/8000

a=rtpmap:100 NSE/8000

a=rtpmap:101 telephone-event/8000

After making a call via PTSN the same offer during the attempt to call out via Line1 had melted down to

a=rtpmap:0 PCMU/8000

a=rtpmap:100 NSE/8000

a=rtpmap:101 telephone-event/8000

As the server of my original provider accepted only PCMA bad luck, the second accepted PCMU so no problem occurred. Curiously in the same state (without reboot) the SPA3102 had no problem in the case of a call from outside (Line1 and PSTN) to accept PCMA.

Unfortunately I could not convince the device through any changes in the configuration like “Preferred Codec” or “Use Pref Codec Only” to change that behaviour. So I came to the result, that there has to be a nasty bug in the firmware which will be hopefully addressed very soon.



Alberto Montilla Tue, 07/28/2009 - 08:35

Dear Sir;

Thanks for your debugging. Actually this issue is a known problem. We are working to solve that in a coming maintenance firmware release. Once it is available I will let you know.


trosinenko Sat, 09/05/2009 - 07:57

Good Day!

Over a month have passed since your last message, where you have promised to provide us with a pretty "critical" update. I would like to know the ETA of its release, as I am somewhat tired of unpluging the device from the electric plug everytime I feel like calling my family and friends.


Your Cisco client

Alberto Montilla Mon, 09/07/2009 - 06:23

Dear Sir; soon as I get response (today is holidays in US) I will let you know.

Regards and thanks for your patience;

trosinenko Wed, 09/16/2009 - 11:02

Dear Alberto,

I am still awaiting for some news from you...

How long do we have to wait for a decent firmware?


Alberto Montilla Thu, 09/17/2009 - 06:51

Dear Sir;

No firmware is yet available, I'm trying to get something out soon, however I would suggest you stay on 5.1.7, your device will operate without this issue.



This Discussion

Related Content