AP 1140 DHCP Issue

Unanswered Question
May 18th, 2009

Hi All

I am installing a 3750 switch with integrated controller and 12 x Cisco 1140 AP's. I have configured the 3750 WLC with a management and AP Manager IP address along with 3 WLAN profiles and security settings. I am confident that these are correct, and in any case are, I believe, not related to the problem I have.

None of my AP's would connect to the controller and when I checked the DHCP (Windows Server) server they had not been issued with an IP address. I logged into an AP via the console and saw the following message "Not sending discovery request AP does not have an ip" If I plug a laptop into the port the AP connects to I pick up an IP address without a problem from the DHCP server. This is not a faulty AP issue as none of the AP's are getting an IP address.

The only other relevant fact is that the Windows DHCP server is on a different subnet (VLAN)though I have enabled DHCP forwarding which obviously works as my laptop gets an IP address.

I have raised this with Cisco TAC and their first response has been to get me to configure Option 43. I will try this but am not expecting it to work as the only thing this will do is to return the IP address of the controller. My AP's however are not getting any response.

Any suggestions as to how to resolve would be gratefully received.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Robert.N.Barrett_2 Mon, 05/18/2009 - 08:03

Wouldn't option 43 only work when the AP's are actually getting an IP address?

Could you post an extended capture of the AP output during the boot and lack of join?

To make sure you connectivity is what it should be, you could always try manually assigning an IP address to the AP, and also manually tell the AP the controller IP address. If that works, then you likely have a problem with your DHCP server or scope definition. Do you have any MAC assignments/reservations in the DHCP scope? Have you tried reserving the AP IP addresses by MAC address within the relevant DHCP scope?

terrywatson Mon, 05/18/2009 - 11:41

Hi Robert

Thanks for the post.

As you say, the suggestion that I configure Option 43 didn't address the issue as the AP was not getting an IP address and therefore the fact that it couldn't find the WLC is an irrelevence.

My next step was going to be to port mirror the AP port to see the DHCP Discovery/Offer process. However with an unhappy customer I may have to manually assign addresses to get the system up and running.

If I do get to the bottom of the issue I'll let you know for future reference.

Rgds

Actions

This Discussion