clns router isis tag command is not allowed

Unanswered Question
May 18th, 2009

the current version dont allow configure the command "clns router isis dcn" in a interface and asociate to vrf.

the release is 12.2(33)SRC3.(7609OSR)

I want to know if have another way for configure this?


interface Vlan350

description BSS O&M

ip vrf forwarding o&m

ip address

no ip redirects

no ip unreachables

logging event link-status

standby 106 ip

standby 106 timers msec 300 1

standby 106 preempt

clns router isis dcn (dont allow this command)

service-policy input QoS-LAN-O&M



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Laurent Aubert Mon, 05/18/2009 - 17:19


CLNS is not supported if ip vrf forwarding is configured. Only ISIS for IP is supported



Giuseppe Larosa Thu, 05/21/2009 - 11:58

Hello Alfredo,

to carry CLNS over MPLS VPN I used point GRE tunnels end to end between CE nodes.

you need to disable hello padding on GRE interface and you should use a reduced clns mtu to make it to work

Hope to help


apratt2009 Mon, 06/01/2009 - 10:14

Hello Giuseppe,

can you send a example configuration or a link how to make this config ?

Giuseppe Larosa Mon, 06/01/2009 - 10:35

Hello Alfredo,

we moved the CLNS to the CE node.

We built a point to point GRE tunnel from CE to remote CE node end to end

CE1--PE1 --- MPLS cloud --- PE2 -- CE2


peers with PE1 and CE1-PE1 link is the VRF access link.

CE1 has an IOS version that supports IPv4 and CLNS routing

int tunnel 100

tunnel source CE1:ipaddr

tunnel destination CE2:ipaddr

clns router isis

see the following:

router isis

net 39.380f.0065.0064.0000.0102.0304.0200.0000.0009.00

is-type level-1

no hello padding point-to-point

lsp-mtu 1000


interface Tunnel471

no ip address

no ip directed-broadcast

ip route-cache distributed

clns mtu 1400

clns router isis

isis priority 70 level-1

tunnel source FastEthernet5/0/0.4

tunnel destination

tunnel checksum


this worked for us and allowed to integrate in an MPLS VPN a management network where there is SDH equipment using CLNS to communicate with SDH manager servers.

Hope to help


drubiogr Mon, 06/01/2009 - 10:25


AFAIK we don't support CLNS routing in vrf's.

I've tried to configure it and this is what I get,

PE-Massa(config-if)#clns router isis test

%CLNS: Cannot enable CLNS for non-default VRF interface

I hope it helps.




This Discussion