UCCE 7.2(3) - ICM Call Variable not showing in CAD

Answered Question
May 18th, 2009

Greetings,

I have configured an ICM Call Variable to show in CAD. The variable is filled in a routing script and for 3 DN's it is displaying the right information.

Last week I added another DN with a different value to be displayed through this variable, but the variable never shows the value I assigned; it remains empy.

I had exactly the same problems upon creation of this Call Variable (the first in our environment), but for reasons not clear to me, it started working.

Any thoughts as where to look next?

Tia

--bas

I have this problem too.
0 votes
Correct Answer by boyd.lynn about 7 years 6 months ago

I had exactly the same problem which was resolved by restarting the CAD services.

In fact what I did was shutdown CAD on the A side and found that when running on the B side the data was displayed correctly. When I restarted the A side and made it active the data continued to be displayed.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Abdulbaseer Mohammed Tue, 05/19/2009 - 00:47

Do they have exact same characteristics like field length etc.

And did it take few days before it start working or few minutes?

Try to setup some check points and run your script and see if the variable is being pased all along

sebastiaanv Tue, 05/19/2009 - 01:05

I am using the predefined "ICM Call Variable 8".

When I use this query: "SELECT * FROM t_Termination_Call_Detail WHERE DateTime > '2009-05-19' AND Variable8 IS NOT NULL" the data is present and accurate.

I assume I'd better upgrade to CAD 7 SR2 since it looks like it's just a problem in presentation.

Thanks,

--bas

Correct Answer
boyd.lynn Tue, 05/19/2009 - 03:39

I had exactly the same problem which was resolved by restarting the CAD services.

In fact what I did was shutdown CAD on the A side and found that when running on the B side the data was displayed correctly. When I restarted the A side and made it active the data continued to be displayed.

sebastiaanv Wed, 05/20/2009 - 04:30

I'll have a look syncing the LDAP services when the next request comes along. The layout was already ok as I have been adding values in the past.

Would be nice if that's all there is to it.

Actions

This Discussion