1242 downgrade process fails - why?

Unanswered Question
May 19th, 2009
User Badges:

I am attempting to downgrade(?) a LWAPP 1242 model device. We need it to be autonomous until such time, a Controller can be introduced into the environment. We have no IOS version AP's on-hand, so this is a must-do process.


I have accessed the instructions that discuss pressing the MODE button, etc. The ESC button has no affect whatsoever during flash initialization - I never see the [ ap: ] prompt. Have tried multiple versions, including over 60 seconds of holding MODE down when unplugging and plugging power cable back in.


I am statically connected to the AP using 10.0.0.x range, as directed and TFTP Server is running with appropriate file downloaded and renamed per instructions. The MODE process does prompt for accessing TFTP server - but process simply times out and runs back to existing flash file.


As instructed, I press MODE and then after reboot attempt to access a webpage inside the device - it is still LWAPP - and nothing is accessible. Your instructions appear misleading.


http://www.cisco.com/en/US/partner/docs/wireless/access_point/12.2_15_JA/configuration/guide/s15trb.html#wp1048727


Would appreciate advice on how to access [ ap: ] only mode on 1242 model access point.


Suggestions?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alarussa52 Tue, 05/19/2009 - 07:56
User Badges:

I did see one error on my part - it states the file must be 123(7)JA, or earlier. We are retesting now...

alarussa52 Tue, 05/19/2009 - 10:14
User Badges:

This process, as you've outlined it on your website, simply will not work for me. The boot process of holding MODE button in until light goes RED, does allow for recovery option and it does access my TFTP Server (Solarwinds ver 9) looking for the 're-named' file, as per instructions.


However, it simply times out and reverts to loading the original LWAPP file, as opposed to loading the renamed autonomous file we would prefer.


AP has IP address of 10.0.0.1 255.0.0.0

Default-gateweay of 10.0.0.254

PC/TFTPserver using 10.0.0.2 255.0.0.0

PC Default gateway 10.0.0.254


This should be as simple as it ever gets.

I'm using the default version of hyperterm that comes with Windows XP.

TFTP Server is activated and started.

Root Directory: C:\TFTP-Root

Every action handled as Admin on the PC.


Got any ideas?


Robert.N.Barrett_2 Tue, 05/19/2009 - 17:33
User Badges:
  • Bronze, 100 points or more

Perhaps you missed the line in the documentation that reads:


Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.


Scott Fella Thu, 05/21/2009 - 03:44
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Or your FW is blocking TFTP. After holding the mode button down for about 20 seconds, you should see something on the console that say's mode button pressed, that is when you release the mode button.


Post you log so we can see where it fails.

Leo Laohoo Wed, 05/20/2009 - 16:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Try the following:

1. Connect the LAP to the same LAN as the TFTP server.


2. Give the AP an IP Address: lwapp ap ip address


3. From the LAP, ping the TFTP server


4. Copy the Autonomous IOS from the TFTP server to your AP.


5. Delete the LWAP IOS from the AP: delete /f /r flash:RCV prefix>


6. Boot the AP into Autonomous mode.


Hope this helps.

Actions

This Discussion