Not enough room on Flash when trying to upgrade Firmware on 1200 AP

Unanswered Question
May 19th, 2009

I am trying to upgrade the firmware on a Cisco 1200 AP via the web interface but keep getting an error saying not enough room on flash.

The firware currently on the AP is c1200-k9w7-tar.123-8.JA2 and I am tring to upgrade to c1200-k9w7-tar.123-8.JEC2.tar.

Please help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
John.Gerlach Tue, 05/19/2009 - 07:23

The Web interface will not work for you any longer since the images got too big. The Web interface likes to copy over the new image first and then delete the old one once it confirms it copied over successfully. Now you have to make a little leap of faith and use the command line to overwrite the existing software. Set up a TFTP server somewhere with the software image on it. Then telnet or SSH to the AP and use the following command syntax to load it on the AP:

archive download-sw /overwrite /reload tftp://

Substitute your TFTP server's IP address for the and then it's just a matter of verifying your software filename.

Enjoy. Have had to do this for years here, ever since the images got too large for WLSE to handle the upgrades.

kalpeshshah76 Wed, 05/20/2009 - 00:09

No, we have around 30 APs and need to update their frimware so that they are all the same.

John.Gerlach Wed, 05/20/2009 - 07:06

Typically you don't need to do anything special. The /overwrite option will take care of removing the old files prior to actually downloading the new image.

Unless your NVRAM is completely full of bogus files and crashdumps I don't think you should need to delete anything manually.

If it is full of files then you may want to telnet to a couple of different AP's to see what the "normal" files that are present are and then you could manually delete the extras. But from my experience I have only encountered this a couple of times and we have about 350+ 1200 series APs that I have done this for on several occasions. Crashdump files appeared to be the problems for those times.

kalpeshshah76 Wed, 05/20/2009 - 08:08

Thank you for your advice. I tried to load the firmware using Telnet and the command you suggest and this is what I get:

Roaming(ICT_Office)#$/reload tftp://

examining image...

Loading c1200-k9w7-tar.123-8.JEC2.tar from (via BVI1): !

extracting info (277 bytes)

Image info:

Version Suffix: k9w7-.123-8.JEC2

Image Name: c1200-k9w7-mx.123-8.JEC2

Version Directory: c1200-k9w7-mx.123-8.JEC2

Ios Image Size: 4342272

Total Image Size: 5079552

Image Feature: WIRELESS LAN

Image Family: C1200

Wireless Switch Management Version: 1.0

ERROR: Not enough free space in "flash:/"

ERROR: Clean up and try again.archive download: takes 4 seconds


John.Gerlach Wed, 05/20/2009 - 08:53

What does a dir of your AP look like? If I look at one of my APs this is what I show for a "normal" list of files:


Directory of flash:/

2 -rwx 4816 Apr 22 2009 15:54:55 -05:00 config.txt

4 -rwx 1945 Apr 22 2009 15:54:55 -05:00 private-config

7 drwx 512 Nov 24 2008 19:30:40 -06:00 c1200-k9w7-mx.123-8.JEC2

5 -rwx 525184 Feb 29 2008 17:01:51 -06:00 r0.rcore

3 -rwx 2072 Apr 22 2009 15:54:55 -05:00 private-multiple-fs

159 -rwx 378 May 19 2009 23:35:03 -05:00 env_vars

7741440 bytes total (2200064 bytes free)


And, as luck would have it, I have an r0.rcore file out there which is about half a MB. I believe that is a core dump file which you can delete to free up space if needed. But I am curious what kind of files you have on your system. An unsuccessful upgrade attempt from the web interface may have left some other remnants behind that could be removed.

kalpeshshah76 Thu, 05/21/2009 - 00:16

Actually, when I looked at the files on the AP, there were alot of Crash Reports has you had said, and so I deleted those, and it then managed to update the firmware.

Thank you for your help, much appreciated.

Just as another query, I was wondering if you use a WLAN Controller as you have a large number of APs.

We have around 32, all on the same SSID, but the problem we have is that if a member of staff moves from one end of the school, they may drop their connectivity. We would like to have a seamless network. Would you have any suggestions.

John.Gerlach Thu, 05/21/2009 - 06:27

We actually have a large project going on right now to revamp our network. We do have a couple of WiSM switches with a total of 4 WiSM blades (8 controllers) total. It is moving slowly but we are ripping out are old 1200's and currently we are deploying the AP1252 APs. Not sure if that will be changing in the future to the 1131 or 1140.

The drops you talk of could be caused by a number of reasons. Does the client's IP address need to change when the wireless device moves from one end of the school to the other? If so, then the "drop" is a very normal thing without a controller as the client must get a new IP address and that can be very disruptive to communications/applications. We actually have a very large ugly campus-wide vlan for most of our wireless users which gets us around a lot of those types of roaming issues but I would have a hard time recommending that to anyone.

If you are on the same subnet throughout the client roam then I guess I don't know why you would be dropping your connections. Is there thorough wireless coverage or what else is different about the environment where they start and where they end their roam?

And by same SSID, is the security also identical from AP to AP? That would be a killer.

spollock Sat, 01/02/2010 - 09:53

Same issue here, I don't see anything obvious that is filling up flash.

Currently running:  Cisco IOS Software, C1200 Software (C1200-K9W7-M), Version 12.3(7)JA, RELEASE SOFTWARE (fc1)

cisco AIR-AP1231G-A-K9     (PowerPC405GP) processor (revision A0) with 14838K/1536K bytes of memory.
Processor board ID FOC093250T6
When I try to upgrade to *any* later version I get this error.
examining image...
Loading c1200-k9w7-tar.123-8.JA2.tar from (via BVI1): !
extracting info (274 bytes)!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 5017600 bytes]
Image info:
    Version Suffix: k9w7-.123-8.JA2
    Image Name: c1200-k9w7-mx.123-8.JA2
    Version Directory: c1200-k9w7-mx.123-8.JA2
    Ios Image Size: 4321792
    Total Image Size: 5018112
    Image Feature: WIRELESS LAN
    Image Family: C1200
    Wireless Switch Management Version: 1.0
ERROR: Not enough free space in "flash:/"
ERROR: Clean up and try again.
Flash shows:
Directory of flash:/
    3  -rwx          76   Mar 1 2002 03:11:38 -08:00  private-multiple-fs
    4  -rwx        1917   Mar 1 2002 03:11:37 -08:00  private-config
  147  -rwx        1407   Mar 1 2002 03:11:37 -08:00  config.txt
  148  -rwx         211   Mar 1 2002 03:11:52 -08:00  env_vars
    5  drwx         512   Sep 8 2005 02:20:20 -07:00  c1200-k9w7-mx.123-7.JA
7741440 bytes total (2817024 bytes free)
Directory of flash:/c1200-k9w7-mx.123-7.JA/
    6  drwx          64   Sep 8 2005 02:18:38 -07:00  html
  143  -rwx     3679615   Sep 8 2005 02:20:10 -07:00  c1200-k9w7-mx.123-7.JA
  144  -rwx      131328   Sep 8 2005 02:20:11 -07:00  5001.img
  145  -rwx      131328   Sep 8 2005 02:20:14 -07:00  5101.img
  146  -rwx      131328   Sep 8 2005 02:20:16 -07:00  6301.img
  153  -rwx      131328   Sep 8 2005 02:20:18 -07:00  6701.img
  154  -rwx      131328   Sep 8 2005 02:20:20 -07:00  6701_cal.img
  155  -rwx         271   Sep 8 2005 02:20:20 -07:00  info
7741440 bytes total (2817024 bytes free)
What can I manually delete?
Leo Laohoo Sat, 01/02/2010 - 15:52

Unfortunately, your AP1200 is the first generation that came with a beagar's 8mb of flash.  This means that you will need to delete the current IOS (delete /f /r flash:c1200-k9w7-mx.123-7.JA) and upload the new IOS.

Unfortunate because when you have deleted the old IOS you must'nt reboot the AP or that means that you have to add another process to your task.

Hope this helps.

spollock Sat, 01/02/2010 - 17:15

Worked perfectly, thanks!

It's still did not solve my original problem however -- I was sure it would  :-)

I am trying to turn the 1200 into a workgroup bridge to connect to a 3rd party AP (linksys) and it appeared that CSCsb31178 would have been fixed after any version other than the one I had on there.   I am now at  Version 12.3(8)JA2

Instead of the the original error message about WPA2 from the bug,  it now says:

*Mar  1 00:10:42.627: %DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: No Response

The AP with SSID works just fine with any standard wireless client, wide open: broadcast ssid and no wep/wpa

dot11 ssid
   authentication open
dot11 network-map
username cisco password 7 072C285F4D06
bridge irb
interface Dot11Radio0
no ip address
no ip route-cache
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role workgroup-bridge
bridge-group 1
bridge-group 1 spanning-disabled


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode